Results 1 to 8 of 8

Thread: MTU Help...registry tweak not working

  1. #1
    Advanced Member X-Nemesis's Avatar
    Join Date
    Nov 2000
    Location
    Kitchener, ON, Canada
    Posts
    576

    MTU Help...registry tweak not working

    Ok...here's where I'm frustrated. I ran the SG analyzer and it told me that my MTU was set to 1440 and that it was not fully optimized. So I downloaded and ran the win2k/xp PPPOE reg tweak..rebooted, and ran the test again. Here are my results.

    I'm using xp and I read in mnosteele52's tips that "This value should be 1452 if using PPPoE DSL or 1440 if using XP and have a PPPoE DSL connection." I am using XP and have a PPPoE DSL connection behind a netgear RP-114 router. So are my settings correct then or is the analyzer telling me that I can still increase my mtu for better results?

    If I can still increase my mtu then how do I go about doing that...I ran the Optimizer and used the settings for DSL PPPoE with a 1492 MTU...and yet when I reboot, the analyzer says that my MTU is still 1440????

    Speede.golden.net
    Browser/OS = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705)
    Note: Read the FAQ if the above is not your IP address.

    TCP options string = 020405780103030201010402

    MTU = 1440
    MTU is not fully optimized for broadband. Consider increasing your MTU to 1500 for better throughput.

    MSS = 1400
    Maximum useful data in each packet = 1400, which equals MSS.
    MSS is not fully optimized for broadband (although it might work well for slower connections). Consider increasing your MTU value.

    Default Receive Window (RWIN) = 255552
    RWIN Scaling (RFC1323) = 2 bits
    Unscaled Receive Window = 63888
    For optimum performance, consider changing RWIN to a multiple of MSS.
    Other values for RWIN that might work well with your current MTU/MSS:
    515200 (MSS x 46 * scale factor of 8)
    257600 (MSS x 46 * scale factor of 4)
    128800 (MSS x 46 * scale factor of 2)
    64400 (MSS x 46)

    bandwidth * delay product:
    Your RcvWindow limits you to: 10222.08 kbps (1277.76 KBytes/s) @ 200ms
    Your RcvWindow limits you to: 4088.832 kbps (511.104 KBytes/s) @ 500ms

    MTU Discovery (RFC1191) = ON

    Time to live left = 52 hops
    TTL value is ok.

    Timestamps (RFC1323) = OFF

    Selective Acknowledgements (RFC2018) = ON

    IP type of service field (RFC1349)= 00000000
    mnosteele52's mnosteele52's

    Hope someone can give me a hand here.

  2. #2
    Dr Tweak mnosteele52's Avatar
    Join Date
    Jul 2001
    Location
    Chesapeake, VA
    Posts
    11,912
    Try this fix from Bob:

    1) Download this file http://www.carricksolutions.com/XP_MTU.reg
    2) Right click the file and choose "Merge"
    3) Click "Yes"
    4) Go to "Start" -> Click on "Run" -> Type in "Regedt32.exe" -> Click "OK"
    5) Go to this Reg Key "[HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\ Services\NdisWan\ Parameters\Protocols\0]"
    6) Double click on "Protocol MTU"
    7) Click on "Decimal" -> Enter your desired value (I.E.: Anything less then 1480.) Use 1480
    8) Click "OK"
    9) Done!


  3. #3
    Advanced Member X-Nemesis's Avatar
    Join Date
    Nov 2000
    Location
    Kitchener, ON, Canada
    Posts
    576
    Thanks for the fast reply mnosteele52.

    We'll give it a run and see how things turn out.

    Appreciate the help!

  4. #4
    Advanced Member X-Nemesis's Avatar
    Join Date
    Nov 2000
    Location
    Kitchener, ON, Canada
    Posts
    576
    Well...the analyzer still tells me that I'm not optimized..and I'm still at 1440.

    Any ideas?

  5. #5
    SG Enthusiast
    Join Date
    Mar 2002
    Location
    Poland
    Posts
    1,107
    hehehehe
    from first your post
    and have a PPPoE DSL
    connection behind a netgear RP-114 router


    your router cut MTU
    so your registry setings...
    will be to TCP not PPPoE
    and MTU for PPPoE should be tweaked in ROUTER :2cool:

  6. #6
    TCP/IP Dude rmrucker's Avatar
    Join Date
    Sep 2000
    Location
    Long Beach, CA, USA
    Posts
    896
    As above -- it is your router that is the problem.

    For what it is worth:
    http://www.dslreports.com/faq/710

  7. #7
    Dr Tweak mnosteele52's Avatar
    Join Date
    Jul 2001
    Location
    Chesapeake, VA
    Posts
    11,912
    Originally posted by rmrucker
    As above -- it is your router that is the problem.

    For what it is worth:
    http://www.dslreports.com/faq/710
    I didn't even notice he was using a router.

  8. #8
    SG Enthusiast
    Join Date
    Mar 2002
    Location
    Poland
    Posts
    1,107
    In my opinion
    ROUTER is advantage in internet connection:2cool:
    particular in small net: a few pc-s & periferals
    In many such installations is the best point of hdw. hehehe

    one can see that is still very modern equipment
    I dissagree with your router that is the problem
    YES but but only for "inattentive"

    summary
    for tweaking of your connecton
    PC with wXP
    optimize to TPC/IP 100 full duplex connection
    (not as PPPoE or similar)
    but RWIN &deriviate optimize
    to your CAPS
    as a multiple MSS (MTU-40) ROUTER setting


    also on ROUTER (BUT not on OS)set PPPoE &deriviate

    my BEST advice to you :
    ask for tweaking mnosteele52 HE IS THE BEST in tweaking

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •