Results 1 to 10 of 10

Thread: how should i clean my monitor?

  1. #1
    Banned athalonxpkid's Avatar
    Join Date
    Jan 2002
    Location
    Pittsburgh, PA
    Posts
    147

    how should i clean my monitor?

    i have a COMPAQ FS940 flat SCREEN MONITOR, not a flatpanel, and i was wondering what i should use to clean it. i heard windex is bad for it.

  2. #2
    Canadian, eh... you hoser lewis's Avatar
    Join Date
    Feb 2000
    Location
    Canada
    Posts
    480
    Yep windex is bad!! Get a cleaner made by Endust. Its for electronics. It is an anti-static cleaneer for monitors, tvs,vcrs...

  3. #3
    Banned athalonxpkid's Avatar
    Join Date
    Jan 2002
    Location
    Pittsburgh, PA
    Posts
    147
    thanx

  4. #4
    Banned athalonxpkid's Avatar
    Join Date
    Jan 2002
    Location
    Pittsburgh, PA
    Posts
    147
    thanx man

  5. #5
    Flip Chip Qwijib0's Avatar
    Join Date
    Jan 2001
    Location
    Tucson, Arizona Processor: GenuineIntel Member #4896
    Posts
    8,268
    Originally posted by athalonxpkid
    thanx man


    ..or at least your double replies
    If your browser can't read unicode, you should probably switch!

  6. #6
    Second Most EVIL YARDofSTUF's Avatar
    Join Date
    Nov 2000
    Location
    USA
    Posts
    70,014
    Originally posted by Qwijib0


    http://www.u.arizona.edu/~jasonk/sgq/pic/jefferson.jpg

    ..or at least your double replies




    i use a damp cloth

  7. #7
    Elite Member Jim's Avatar
    Join Date
    Oct 2000
    Posts
    13,231
    Originally posted by Qwijib0


    ..or at least your double replies
    Am I the only one who finds it amusing that "athalonxpkid" and "christopher561"'s posts are remarkably similar, in both content (or lack thereof) as well as spelling (or again, a lack thereof). Odd how both do the same double posting thing as well, eh?

  8. #8
    All Ur Base R Belong 2 Us Christopher561's Avatar
    Join Date
    Jul 2001
    Location
    Pittsburgh,PA
    Posts
    1,766
    Originally posted by BIGJIMSLATE


    Am I the only one who finds it amusing that "athalonxpkid" and "christopher561"'s posts are remarkably similar, in both content (or lack thereof) as well as spelling (or again, a lack thereof). Odd how both do the same double posting thing as well, eh?
    Originally posted by Christopher561
    DoNT MESs wItH ME!!
    SG RocKS! :2cool:
    Dude thE DiScriPtion of this SmiLy is rolling on ThE FlooR.

  9. #9
    Elite Member Jim's Avatar
    Join Date
    Oct 2000
    Posts
    13,231
    I'm sure Qwijib0 is thrilled you're using his bandwidth. At the very least, link from your own webspace.

  10. #10
    Chinese Vampire tHE_0ne's Avatar
    Join Date
    Jan 2002
    Location
    Williamsburg/Norfolk VA
    Posts
    5,870
    windex

    My~Rig
    |Athlon 64 X2 3800+ Toledo 2.0GHz @ 2.5Ghz||ASROCK 939Dual-SATA2||OCZ Platinum 2GB (2 x 1GB) PC3200|ZALMAN 120MM CNPS7700-CU|
    |ATI XT 1600 PRO|CSB SB0570 Audigy SE 7.1||WD SE16 SATA 320GB HD|Hitachi SATA 160GB HD|Thermaltake TR2 W0070 ATX 430W Power Supply |WIN 7 Ultimate| (College Budget)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •