Results 1 to 6 of 6

Thread: c++ graphic question

  1. #1
    Morterator Immortal's Avatar
    Join Date
    Apr 2000
    Location
    Mississauga, Ontario , Canada. Behaviour : Good
    Posts
    22,668

    Unhappy c++ graphic question

    how come when I try to do some graphics animation or something thru c++ it always gives me a gray screen...

    I dont have the code right now.. but does anyone have any idea?

  2. #2
    Member
    Join Date
    Apr 2000
    Location
    Burnaby, BC, Canada
    Posts
    83
    You may want to be a little bit more specific, such as:

    What kind of graphics animation are you trying to do?
    What OS are you running? (yes, this makes a HUGE difference)
    What API calls are you using?
    What compiler are you using?
    Does the system you are using even support graphics?

    Assuming you were using a Win32 OS (Win2000, Win9x, etc), there are a number of different ways to "do some graphics animation", ranging from plain old single buffered Windows GDI, up to triple buffered Direct3D. We need a whole lot more in the way of details before we can give you any help.

  3. #3
    Morterator Immortal's Avatar
    Join Date
    Apr 2000
    Location
    Mississauga, Ontario , Canada. Behaviour : Good
    Posts
    22,668
    my animation is real basic stuff..

    like
    for (i=1;i=10;i++)
    {
    circle (200+i400+i,50)
    }

    that's it.. and I have already initiated graphics stuff...

  4. #4
    Member
    Join Date
    Apr 2000
    Location
    Burnaby, BC, Canada
    Posts
    83
    If you aren't going to supply the info needed, I can't help you. Obviously, you haven't initiated the graphics properly, or you wouldn't have a grey screen. For any GUI type OS, you can't simply draw to the screen, you generally need to obtain a device context or graphics handle. If you don't get one correctly, then you won't be able to draw to the screen.

    So, if you want to get some help here, we need to know what exactly you are trying to do, and what you are actually doing, so we can figure out why it isn't working.

  5. #5
    Morterator Immortal's Avatar
    Join Date
    Apr 2000
    Location
    Mississauga, Ontario , Canada. Behaviour : Good
    Posts
    22,668

    Smile

    thanx for all your help... I'm just going to find the answer myself...

  6. #6
    Advanced Member CAR-15's Avatar
    Join Date
    Jun 2001
    Location
    IL
    Posts
    560
    LOL, dont get pissy Immortal
    AMD XP2100+
    Soltek SL-75DRV5
    256 MB Samsung PC2100
    Radeon 8500

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •