Page 1 of 2 12 LastLast
Results 1 to 20 of 28

Thread: Need help setting MSS/MTU

  1. #1
    Registered User Mr White's Avatar
    Join Date
    Mar 2001
    Posts
    303

    Question Need help setting MSS/MTU

    Im lost the tcp/ip test keeps saying my MTU is set at 1454 even though i added the damn patch and rebooted. What am i doing wrong?
    it was fine a few days ago but not now.
    thanx

  2. #2
    Lobo
    Guest

    Post

    What do you want your MSS and MTU set too, your on PPPoE are you not

  3. #3
    Lobo
    Guest

    Post

    Please go to http://www.dslreports.com/tweaks and take test
    turn off firewalls if you have one, take test and then click on results
    Copy results by highlighting everything with mouse,
    left button on mouse hold down and drag.
    Copy results by hiting Ctrl & c, on keyboard, come back to Speedguide, to copy results from test in reply box, curor blinking at begining of box Hit Ctrl & v, on keyboard
    Thank you

  4. #4
    Lobo
    Guest

    Post

    If you want to adjust your own do this, Windows will automattically set MSS 40 less than MAXMTU, 1500 MTU is not for PPPoE:
    Please go to:http://www.dslreports.com/front/drtcp.html
    Download DR. TCP to your desktop
    Where it saids adapter settings, select your adapter
    Where it says Windows sclaing- yes
    Where it says Selective Acks-yes
    Path MTU Discovery - yes
    Black Hole Detection - No
    TTL-64 or 32 (up to you) No affect on speed.
    Set MAX MTU and MSS will be set
    Where it says Time Stamping, no
    click apply
    Reboot for changes to take affect

    Do not change any numbers in this box unless you know what you are doing.
    A blank box only means that the default setting is being used

  5. #5
    Registered User Mr White's Avatar
    Join Date
    Mar 2001
    Posts
    303

    Post

    Thanx Lobo but i already got that dr.tcp and ive tried all that but it still comes up as my MTU 1454 on both tests? I want it set for 1492,i have PPPoE connection

    [ 03-22-2001: Message edited by: Mr White ]

  6. #6
    Registered User Mr White's Avatar
    Join Date
    Mar 2001
    Posts
    303

    Post

    TCP options string = 0204058601010402

    MTU = 1454
    MTU is not fully optimized for broadband. Consider increasing your MTU to 1500 for better throughput.

    MSS = 1414
    Maximum useful data in each packet = 1414, which is equal to MSS.
    MSS is not fully optimized for broadband (although it might work well for slower connections). Consider increasing your MTU value.

    Default Receive Window (RWIN) = 16384
    RWIN Scaling (RFC1323) = 0 bits
    Unscaled Receive Window = 16384
    For optimum performance, consider changing RWIN to a multiple of MSS.
    Other values for RWIN that might work well with your current MTU/MSS:
    520352 (MSS x 46 * scale factor of 8)
    260176 (MSS x 46 * scale factor of 4)
    130088 (MSS x 46 * scale factor of 2)
    65044 (MSS x 46)

    bandwidth * delay product:
    Your RcvWindow limits you to: 655.36 kbps (81.92 KBytes/s) @ 200ms
    Your RcvWindow limits you to: 262.144 kbps (32.768 KBytes/s) @ 500ms
    Consider increasing your RWIN value to optimize TCP/IP for broadband.

    MTU Discovery (RFC1191) = ON

    Time to live left = 117 hops
    TTL value is ok.

    Timestamps (RFC1323) = OFF

    Selective Acknowledgements (RFC2018) = ON

    IP type of service field (RFC1349)= 00000000

  7. #7
    Registered User Mr White's Avatar
    Join Date
    Mar 2001
    Posts
    303

    Post

    Here is the tweak test..

    Receive Window: 16384
    Scaling: none
    Path MTU Discovery: ON
    RFC1323 Window Scaling: OFF
    RFC1323 Time Stamping: OFF
    Selective Acks: ON
    MSS requested: 1414
    TTL: 128
    (less any hops behind firewall)
    TTL remaining: 114


    Example 146000 byte download
    Actual data bytes sent: 146000
    Actual data packets: 104
    Max size packet sent: 1454
    Max size packet recd: 1454
    Retransmitted data packets: 0
    sacks you sent: 0
    pushed data pkts: 18
    data transmit time: 1.981 secs
    our max idletime: 179.5 ms
    transfer rate: 52868 bytes/sec
    transfer rate: 422 kbits/sec
    transfer efficiency: 100%


    ICMP quality readings
    Minimum ping: 92 ms
    Maximum ping: 99 ms
    Ping stability:
    97 98 94 93 95 99 95 97 95 92

  8. #8
    Lobo
    Guest

    Post

    Why is RWIN so small, what OS are you on, and yes your MTU should be 1492, maim page this site under registry Tweaks will explain how to change MTU will will change MSS, I want to know why RWIN is so small

  9. #9
    Lobo
    Guest

    Post

    You also have to reboot after making any changes wih Dr. TCP

  10. #10
    Lobo
    Guest

    Post

    You also need to turn Windows scaling ON with Dr.TCP

  11. #11
    Registered User Mr White's Avatar
    Join Date
    Mar 2001
    Posts
    303

    Post

    Yes i have rebooted and i did turn scalling on but it didnt change my mtu to 1492. I even looked in my registry and it says 0001-0009 all are MTU 1492... so is it set or is the test screwed up for me? Ill change RWIN

  12. #12
    Registered User Mr White's Avatar
    Join Date
    Mar 2001
    Posts
    303

    Post

    RWIN is small because window scaling is off and the rwin calculator said with speed of 1000kbits/latency 85ms =10625

  13. #13
    Lobo
    Guest

    Post

    Reboot computer after changing RWIN and retest, what OS

  14. #14
    Lobo
    Guest

    Post

    Scaling needs to be on

  15. #15
    Registered User Mr White's Avatar
    Join Date
    Mar 2001
    Posts
    303

    Post

    I have Win98,not SE.
    Speeds look better now ,but why is the mtu still showing 1454??


    Receive Window: 127776
    Scaling: 1
    Path MTU Discovery: ON
    RFC1323 Window Scaling: ON
    RFC1323 Time Stamping: OFF
    Selective Acks: ON
    MSS requested: 1414
    TTL: 64
    (less any hops behind firewall)
    TTL remaining: 50


    Example 146000 byte download
    Actual data bytes sent: 146000
    Actual data packets: 104
    Max size packet sent: 1454
    Max size packet recd: 1454
    Retransmitted data packets: 0
    sacks you sent: 0
    pushed data pkts: 3
    data transmit time: 1.490 secs
    our max idletime: 169.4 ms
    transfer rate: 53789 bytes/sec
    transfer rate: 430 kbits/sec
    transfer efficiency: 100%


    ICMP quality readings
    Minimum ping: 81 ms
    Maximum ping: 87 ms
    Ping stability:
    83 86 83 86 85 81 85 84 86 87

  16. #16
    Lobo
    Guest

    Post

    Using Dr TCp select your adapter first, then set MTU to 1492, click apply, when it lites up, reboot, retest at our test and post back here, RWIN is not what patch set it at if patch is installed right, did you read how to install patch

  17. #17
    Registered User Mr White's Avatar
    Join Date
    Mar 2001
    Posts
    303

    Post

    Ive done that though,there is 3 adapters which one are you refering to? dlink,dial-up or pppoe adapter? the patch is installed properly now

  18. #18
    Lobo
    Guest

    Post

    Well if patch is installed right now it puts the right numbers in, if you reboot after installing patch, take our test after rebooting and post results:
    1. Go to http://forums.speedguide.net/optd.shtml and click on check connection.
    2. Copy all this by highlighting everything in box with mouse
    (you may have to make box smaller. To copy contents of box, highlight, then hit Ctrl & c, on your keyboard, when you return to Speedguide in reply box, with cursor blinking, hit Ctrl & v, this will copy contents in box so I may look at it. Thank you.
    X out your IP Address as we don't want world to know this info

    Tweaking will not fix Packet Loss
    Multiplayer games over UDP
    Your regular ping time
    Regular PC Freezes
    impotence
    Spike Lagg

  19. #19
    Registered User Mr White's Avatar
    Join Date
    Mar 2001
    Posts
    303

    Post

    Ok ive done everything you said

    TCP options string = 020405860103030201010402

    MTU = 1454
    MTU is not fully optimized for broadband. Consider increasing your MTU to 1500 for better throughput.

    MSS = 1414
    Maximum useful data in each packet = 1414, which is equal to MSS.
    MSS is not fully optimized for broadband (although it might work well for slower connections). Consider increasing your MTU value.

    Default Receive Window (RWIN) = 255552
    RWIN Scaling (RFC1323) = 2 bits
    Unscaled Receive Window = 63888
    For optimum performance, consider changing RWIN to a multiple of MSS.
    Other values for RWIN that might work well with your current MTU/MSS:
    520352 (MSS x 46 * scale factor of 8)
    260176 (MSS x 46 * scale factor of 4)
    130088 (MSS x 46 * scale factor of 2)
    65044 (MSS x 46)

    bandwidth * delay product:
    Your RcvWindow limits you to: 10222.08 kbps (1277.76 KBytes/s) @ 200ms
    Your RcvWindow limits you to: 4088.832 kbps (511.104 KBytes/s) @ 500ms

    MTU Discovery (RFC1191) = ON

    Time to live left = 53 hops
    TTL value is ok.

    Timestamps (RFC1323) = OFF

    Selective Acknowledgements (RFC2018) = ON

    IP type of service field (RFC1349)= 00000000

  20. #20
    Lobo
    Guest

    Post

    OK, on DR.TCP set time stamps to on, set dlink adapter to MTU 1492
    and PPPoE adapter to MTU of 1492, retest

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •