Results 1 to 6 of 6

Thread: RWIN will not change....

  1. #1
    Member
    Join Date
    Feb 2001
    Location
    Crestview,FL
    Posts
    78

    Post RWIN will not change....

    I just took Speedguides test,here are my results

    TCP options string = 020405b4

    MTU = 1500
    MTU is at optimal value

    MSS = 1460
    Maximum useful data in each packet = 1460, which seems to be equal to MSS.

    Default Receive Window (RWIN) = 49152
    RWIN Scaling (RFC1323) = 0 bits
    Unscaled Receive Window = 49152
    For optimum performance, consider changing RWIN to a multiple of MSS.
    Other values for RWIN that might work well with your current MTU/MSS:
    513920 (MSS x 44 * scale factor of 8)
    256960 (MSS x 44 * scale factor of 4)
    128480 (MSS x 44 * scale factor of 2)
    64240 (MSS x 44)

    bandwidth * delay product:
    Your RcvWindow limits you to: 1966.08 kbps (245.76 KBytes/s) @ 200ms
    Your RcvWindow limits you to: 786.432 kbps (98.304 KBytes/s) @ 500ms

    MTU Discovery (RFC1191) = false

    Time to live = 51 hops

    Timestamps (RFC1323) = false

    Selective Acknowledgements (RFC2018) = false

    IP type of service field (RFC1349)= 00000000


    So I downloaded Cablenuts 3.65 patch, installed, rebooted then took the same test and nothing changed. So I looked in my registry and my RWIN is 522680. What the hell??? Which one is wrong... the test result or my registry RWIN value? Thx.

  2. #2
    Super Good Guy! dannjr's Avatar
    Join Date
    Jul 2000
    Location
    Chicago
    Posts
    2,233

    Post

    What OS are you running...
    what or how do you connect
    who is the ISP

    [ 03-08-2001: Message edited by: dannjr ]

  3. #3
    Advanced Member cablenut's Avatar
    Join Date
    Aug 2000
    Location
    Indianapolis, IN
    Posts
    863

    Talking

    RWIN Scaling (RFC1323) = 0 bits
    Unscaled Receive Window = 49152
    For optimum performance, consider changing RWIN to a multiple of MSS.
    Other values for RWIN that might work well with your current MTU/MSS:
    513920 (MSS x 44 * scale factor of 8)
    256960 (MSS x 44 * scale factor of 4)
    128480 (MSS x 44 * scale factor of 2)
    64240 (MSS x 44)

    Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VxD\MSTCP

    make sure the Tcp1323Opts string is there and set to "1" or "3"

    now if that is ok then go to my site and get the vtcp386 patch for Windows 98 in my software section thanks..
    Head webcheese and geek guru @ http://www.cablenut.com

  4. #4
    Member
    Join Date
    Feb 2001
    Location
    Crestview,FL
    Posts
    78

    Post

    Thx for replying fellas....
    DannyJr, Im running Windows98, I have Cox@home

    Will do that Cablenut.... Thx again fellas.

  5. #5
    TCP/IP Dude rmrucker's Avatar
    Join Date
    Sep 2000
    Location
    Long Beach, CA, USA
    Posts
    896

    Lightbulb

    I think the key will be the vtcp.386 patch.

    And why do you have Sack and PMTUD off -- are you using a router?

    [ 03-08-2001: Message edited by: rmrucker ]

  6. #6
    Lobo
    Guest

    Post

    Either one, the patch is on patch page Vtcp386 Fix, retest, repost

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •