Results 1 to 5 of 5

Thread: TCPOptimizer Tweaks Wont apply due to PowerShell Issue (PLEASE HELP)

  1. #1

    TCPOptimizer Tweaks Wont apply due to PowerShell Issue (PLEASE HELP)

    I've noticed that for some reason certain tcp settings fail to apply after using TCPOptimizer even though I always use it in Administrator mode. For example, I change MinRTO from 300 to 100 and apply, but after I restart its back on 300. The congestion provider feature has the same issue, always stuck on cubic even if I set it to ctcp, default, etc. To deal with this issue I tried looking at the "Path" section TCPOptimizer shows when listing all the changes about to be made. By using that I went into Windows PowerShell in Admin to try and use the given command to manually change my MinRTO, but I got the following error (the full command is also listed).

    PS C:\WINDOWS\system32> Set-NetTCPSetting -SettingName internet -MinRto 100

    Set-NetTCPSetting : Property MinRto is read-only
    At line:1 char:1
    + Set-NetTCPSetting -SettingName internet -MinRto 100
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : InvalidArgument: (MSFT_NetTCPSett...ystemName = ""):ROOT/StandardCimv2/MSFT_NetTCPSettin
    g) [Set-NetTCPSetting], CimException
    + FullyQualifiedErrorId : Windows System Error 87,Set-NetTCPSetting

    Note that the command I put in is an exact copy-paste of what I got in TCPOptimizer. I also googled the correct syntax on the microsoft site so I know the command is supposed to be accurate. I then proceeded to try the command with other TCP settings, but always got the same error. I believe this has something to do with why I am unable to change some tcp settings. Please Help!

  2. #2
    Administrator Philip's Avatar
    Join Date
    May 1999
    Jacksonville, Florida
    Blog Entries
    What version/build of Windows? If Windows 10, you can type "winver" in the search dialog.

  3. #3
    Windows10, 20H2 (OS Build 19042.1165)

  4. #4
    Administrator Philip's Avatar
    Join Date
    May 1999
    Jacksonville, Florida
    Blog Entries
    TCP Optimizer works well with all current Windows 10 builds, including yours. Note that some of the more advanced settings may not work under Windows 10 Home.
    That said, when you start PowerShell, you'd have to right-click on it, and choose "Run as Administrator" for many of the commands to work without a permission error. You would have to do the same with the TCP Optimizer.

    I just tested under Windows 10 Pro Version 21H1 Build 19043.1165 and it works fine, including:
    Set-NetTcpSetting -SettingName Internet -MinRto 300
    Set-NetTcpSetting -SettingName Internet -InitialRto 3000

    If I run it as regular user, I'd get a different error than yours though ("Permission Denied", rather than "Invalid Argument") :
    PS C:\Users\Philip> Set-NetTcpSetting -SettingName Internet -MinRto 300
    Set-NetTcpSetting : Access is denied.
    At line:1 char:1
    + Set-NetTcpSetting -SettingName Internet -MinRto 300
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : PermissionDenied: (MSFT_NetTCPSett...ystemName = ""):ROOT/StandardCimv2/MSFT_NetTCPSetti
       ng) [Set-NetTCPSetting], CimException
        + FullyQualifiedErrorId : Windows System Error 5,Set-NetTCPSetting
    It could be that this particular setting is not available under your Windows build/version for some reason. Is it Windows 10 Home? I would try to update Windows to a newer build if those particular settings are important to you.
    Linux is user friendly, it's just picky about its friends...
    Disclaimer: Please use caution when opening messages, my grasp on reality may have shaken loose during transmission (going on rusty memory circuits).

  5. #5
    Yeah I do happen to use Home, not Pro. I know its nothing to do with Admin since I have run TCPOptimizer/Powershell/CMD in Admin 100% of the time I use them. So sounds like switching to Pro is the answer, I'll update if I have further issues.

Similar Threads

  1. TCPOptimizer Issue
    By Rennison in forum General Broadband Forum
    Replies: 0
    Last Post: 05-07-13, 04:29 PM
  2. Help, TcpOptimizer tweaks never show up in Tcp/Ip analyser
    By Captn Snook in forum Broadband Tweaks Help
    Replies: 36
    Last Post: 06-13-07, 09:49 AM
  3. Using BatchRun to apply tweaks???
    By JawZ in forum Broadband Tweaks Help
    Replies: 5
    Last Post: 03-29-03, 10:40 AM
  4. Replies: 2
    Last Post: 09-24-02, 07:26 AM
  5. Reg Tweaks Apply to Client Computers?
    By sprice1 in forum Broadband Tweaks Help
    Replies: 2
    Last Post: 02-02-01, 05:41 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts