Hello,
I don't know if it is the right place to expose my problem.
I am having a problem with my ftp connections.
I explain what is happening to me:
I take a lot of photos that I store on an external hard drive and on idevicse (1 iphone and 2 ipad) in an application (my private photo which has an ftp server).
Currently, I have 23,163 photos and videos in 664 folders.
I have a laptop PC (HP on Windows vista) and a desktop PC (Dell on Windows 8).
To transfer my photos from the external hard drive to an idevice, I connect the idevice to Wifi (WLAN), I start the ftp server (192.168.8.104: 2121) and I use filezilla or Winscp.
When I use my laptop connected to the WLAN, it takes me about 4 minutes 30 seconds to get the complete list of files from the ftp server (Add files to queue).
But, if I am using my desktop computer, it takes me up to 30 minutes to get this list and often the list is not complete. My last test lasted 17 min 54 sec and there were only 23108 files in the list.
This is due to a large number of disconnections from the ftp server as a result of many periods of inactivity.
Here is an excerpt from the Filezilla messages where a period of inactivity appears:
2021-02-09 11:02:18 7808 1 Command: CWD /Clementine/Little
2021-02-09 11:02:18 7808 1 Response: 200 directory changed to /Clementine/Little
2021-02-09 11:02:18 7808 1 Command: PWD
2021-02-09 11:02:18 7808 1 Response: 257 "/Clementine/Little" is the current directory.
2021-02-09 11:02:18 7808 1 Command: CWD 2018
2021-02-09 11:02:18 7808 1 Response: 200 directory changed to /Clementine/Little/2018
2021-02-09 11:02:18 7808 1 Command: PWD
2021-02-09 11:02:18 7808 1 Response: 257 "/Clementine/Little/2018" is the current directory.
2021-02-09 11:02:18 7808 1 Command: PASV
2021-02-09 11:02:18 7808 1 Response: 227 Entering Passive Mode (192,168,8,104,208,122)
2021-02-09 11:02:18 7808 1 Command: MLSD
2021-02-09 11:02:21 7808 1 Response: 150 Accepted data connection
2021-02-09 11:02:21 7808 1 Response: 226 Transfer complete.
2021-02-09 11:02:41 7808 1 Error: Connection timed out after 20 seconds of inactivity
2021-02-09 11:02:41 7808 1 Error: Failed to retrieve directory listing
2021-02-09 11:02:41 7808 1 Status: Disconnected from server
2021-02-09 11:02:41 7808 1 Status: Connecting to 192.168.8.104:2121...
2021-02-09 11:02:41 7808 1 Status: Connection established, waiting for welcome message...
2021-02-09 11:02:41 7808 1 Response: 220 ---------- Welcome to Private Photo ----------
2021-02-09 11:02:41 7808 1 Command: AUTH TLS
2021-02-09 11:02:41 7808 1 Response: 500 'AUTH': command not understood.
2021-02-09 11:02:41 7808 1 Command: AUTH SSL
2021-02-09 11:02:41 7808 1 Response: 500 'AUTH': command not understood.
2021-02-09 11:02:41 7808 1 Status: Insecure server, it does not support FTP over TLS.
2021-02-09 11:02:41 7808 1 Command: USER xxxxx
2021-02-09 11:02:41 7808 1 Response: 331 Password required for Linkus
2021-02-09 11:02:41 7808 1 Command: PASS ****
2021-02-09 11:02:41 7808 1 Response: 230 User Linkus logged in.
2021-02-09 11:02:41 7808 1 Command: OPTS UTF8 ON
2021-02-09 11:02:41 7808 1 Response: 502 Unknown command 'UTF8'
2021-02-09 11:02:41 7808 1 Status: Logged in
2021-02-09 11:02:41 7808 1 Status: Retrieving directory listing of "/Clementine/Little/2018"...
2021-02-09 11:02:41 7808 1 Command: CWD /Clementine/Little/2018
2021-02-09 11:02:41 7808 1 Response: 200 directory changed to /Clementine/Little/2018
2021-02-09 11:02:41 7808 1 Command: TYPE I
2021-02-09 11:02:41 7808 1 Response: 200 Type set to I
2021-02-09 11:02:41 7808 1 Command: PASV
2021-02-09 11:02:41 7808 1 Response: 227 Entering Passive Mode (192,168,8,104,155,41)
2021-02-09 11:02:41 7808 1 Command: MLSD
2021-02-09 11:02:43 7808 1 Response: 150 Accepted data connection
2021-02-09 11:02:43 7808 1 Response: 226 Transfer complete.
2021-02-09 11:02:43 7808 1 Status: Directory listing of "/Clementine/Little/2018" successful

Periods of inactivity occur randomly (after 1 to 30 seconds of activity).

By connecting my desktop computer to my router with an Ethernet cable or in Wifi, the result is the same.
By disabling my bitdefender firewall and antivirus as well as the Windows firewall, the result is the same.
I did an optimization with TCP Optimizer, the result is the same.
As the connections work fine with my laptop, I think the problem is neither with the idevices ftp server, nor with filezilla (configured identically on the desktop and on the laptop), nor with the router, nor with the network cards since the problem is the same in Wifi or Ethernet. The problem should therefore come from windows 8.
Does anyone have a solution?
Thanks in advance.