Results 1 to 3 of 3

Thread: TCP Optimizer broke my wake on lan - how do i fix it?

  1. #1
    Junior Member
    Join Date
    Jul 2018

    TCP Optimizer broke my wake on lan - how do i fix it?

    Oh boy. lots of jaded/cynical gum flapping going on directed at the developers of Multiplicity. Ive been saaaaalty as I couldnt(cant) get wake on lan to work ala their app. They used some arbitrary port (30564 or some such) which I presumed to be the issue.

    No matter what I did, it wouldnt work.

    Today I did an in place upgrade of windows to restore my recovery partition. It ends up bamboozling a handful of things a user might change which leaves said user needing to mop up and put things back in order after the fact.

    One such thing - is the tweaks applied by tcp optimizer.

    So i opened tcp optimizer and thought to myself, i should test multiplicity RQ. Poof, it worked. I was astonished. worked literally instantaneously. Tried a half a dozen more times. sleep wake sleep wake. Yay for that.

    So i ran tcp optimizer (considered a macrium backup prior and like a moron i didnt) and restarted when requested. POOF, as quick as it was fixed, its re-broken.

    I tried the windows defaults button, restarted... no dice. It changes something that doesnt get reverted.

    Now to be clear, it doesnt break wake on lan in general. I can still wake via the UWP app "wake-on-lan" and i can still wake via teamviewer (but i think thats irrelevant as they use some proprietary cloud voodoo i presume).

    its something with timing that doesnt get along with multiplicity and doesnt get reverted with the windows defaults button.

    Anyone able to help me sort this out before i lose whats left of my hair lol >.<

  2. #2
    Administrator Philip's Avatar
    Join Date
    May 1999
    Jacksonville, Florida, United States
    Blog Entries
    Hello, sorry to hear about the odd issues.

    In the TCP Optimizer, try the File menu, both "Reset TCP/IP" and "Reset Winsock". This should bring the TCP/IP stack back to the Windows defaults for sure, as it resets it completely without resorting to reinstalling the OS.

    If that doesn't work, try reinstalling the NIC drivers. It is also possible that the Multiplicity driver installs something proprietary on top of TCP/IP if it installs some drivers. Any firewall that may be preventing the packets? Is the TCP Optimizer the only change?

    Do you have multiple network adapters (even virtual ones, VPNs, vlans, etc.) ? Multiplicity may be trying to wake the wrong one. Try disabling all other adapters, if that works you may want to change their priority, so the right NIC has the lowest priority before others.
    Linux is user friendly, it's just picky about its friends...
    Disclaimer: Please use caution when opening messages, my grasp on reality may have shaken loose during transmission (going on rusty memory circuits).

  3. #3
    Junior Member
    Join Date
    Jul 2018
    hi Philip. thank you for the reply. Ive actually been trying to fix this for weeks. I do have other nic's, a wifi adapter and a vlan. Already been down that path. Disabled them, and checked to ensure the proper nic had priority via powershell. physical ethernet had the lowest of 5 on both the sender and receiver.

    It is very odd behavior considering other WoL apps work well enough.

    I did notice that when I use the software KVM to connect, sometimes controls dont register and i need to disconnect/reconnect. Unfortunately I cnat say whether this is related to tcp optimizer or multiplicity itself as ive been using tcp optimizer for ages, whereas im a new multiplicity user.

    As for firewalls. Just the windows and gateway firewall. I disabled all of the above and the result was the same. Moreso the fact it worked when they were all enabled anyhow (until i ran tcp optmizer and restarted anwyays)

    Networking isnt even close to my forte, so im going to keep digging. I'll start with the tcp/ip reset and winsock reset i didnt even know existed within tcp optimizer.

    Will report back as soon as i get to it. thanks again for your time and help

Similar Threads

  1. How do you wake up?
    By Humboldt in forum General Discussion Board
    Replies: 12
    Last Post: 02-03-12, 10:07 PM
  2. lets wake up the block... hell lets wake up the state!
    By Joe in forum General Discussion Board
    Replies: 0
    Last Post: 11-14-04, 08:48 PM
  3. Wake on lan..
    By Immortal in forum Networking Forum
    Replies: 7
    Last Post: 01-25-03, 04:03 PM
  4. Wake Up !!!!
    By Grimson in forum General Discussion Board
    Replies: 15
    Last Post: 04-04-02, 11:31 AM
  5. Wake On Lan
    By glears in forum Hardware & Overclocking
    Replies: 3
    Last Post: 07-24-01, 07:50 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts