Results 1 to 5 of 5

Thread: Slow Single Thread TCP speed multithreaded is fine

  1. #1

    Slow Single Thread TCP speed multithreaded is fine

    Hello ,
    I have a 60mbps unlimited connection that promises 60 down and 25 up
    when i test on speed test websites it shows that I get 58 down and 25 up to my isp but when I do the single mode test the speed comes down to 1-5 mbps.the same happens when testing to other servers outside my isp network .
    my single thread downloads are very slow too
    I get 200 kbps max and sometimes get 900 max .
    but when i download multithreaded I get good speed and i cam max out my line speed.
    it happens all the time.
    i have called my isp they run a test on multithreaded mode and tell me i have no problem.

    i have run some wireshark traces while running these tests and while doing normal downloads
    there are tons(2000+) dup ack and 500+ tcp retransmissions reported
    but odly enough pinging my local gateway i have no loss whatsoever
    i have also ran an mtr test and it reports loss only on the 3rd hop inside my isp network
    when i run mtr in tcp mode the latency fluctuates on the 3rd hop between 900ms and 7000ms
    idk if that is due to ratelimiting or something else

    below is the mtr result
    i have run all the test directly connected to the ethernet cable my isp provides
    my isp is lan ethernet based ...
    TCP mode MTR


    ______________________Loss% Snt Last Avg Best Wrst StDev
    1.|-- myrouter __________0.0% 10 0.5 0.5 0.5 0.6 0.0
    2.|-- ispgateway_________0.0% 10 1.3 1.2 1.2 1.4 0.0
    3.|-- node1_____________40.0% 10 3160. 1935. 6.9 3160. 1379.2
    4.|-- ??? ______________ 100.0 10 0.0 0.0 0.0 0.0 0.0
    5.|-- node-2____________ 0.0% 10 1.4 1.4 1.2 1.5 0.0
    6.|-- ??? _______________100.0 10 0.0 0.0 0.0 0.0 0.0

    ICMP mode MTR



    _______________Loss% Snt Last Avg Best Wrst StDev
    1. 192.168.31.1___0.0% 1518 0.4 0.4 0.4 0.8 0.0
    2. 172.18.237.1___0.5% 1518 1.1 1.0 1.0 2.4 0.0
    3. 203.171.243.1__56.4% 1518 10.3 14.5 2.5 188.0 22.7
    4. ???
    5. 203.171.240.1__0.0% 1517 37.7 39.2 36.6 85.2 3.6
    Last edited by clockstoper; 11-20-19 at 10:59 AM. Reason: added details

  2. #2
    SpeedGuide.net TCP Analyzer Results
    Tested on: 2019.11.20 10:55
    IP address: 115.187.xx.xx
    Client OS/browser: Windows 10 (Chrome 78.0.3904.108)

    TCP options string: 020405b4010303080402080a008ad59300000000
    MSS: 1460
    MTU: 1500
    TCP Window: 263424 (not multiple of MSS)
    RWIN Scaling: 8 bits (2^8=256)
    Unscaled RWIN : 1029
    Recommended RWINs: 64240, 128480, 256960, 513920, 1027840
    BDP limit (200ms): 10537kbps (1317KBytes/s)
    BDP limit (500ms): 4215kbps (527KBytes/s)
    MTU Discovery: ON
    TTL: 39
    Timestamps: ON
    SACKs: ON
    IP ToS: 00000000 (0)

  3. #3
    https://www.speedguide.net/speedtest...est=1574265654
    Single thread outside isp network



    Multithread inside isp network



    Singlethread inside isp network


  4. #4
    Administrator Philip's Avatar
    Join Date
    May 1999
    Location
    Jacksonville, Florida, United States
    Posts
    10,378
    Blog Entries
    6
    Seems the third hop is congested/overloaded. some nodes give much lower priority to icmp traffic (pings), especially under load. As to the slow single-thread performance outside of your ISP, it is likely due to over-subscription as well, it is typical for many residential internet providers. The fact that you get fast downloads from their local servers doesn't measure the performance of their backbones, their connections and peering arrangements with other ISPs.

    Seems the issue is with your ISP, not local to your connection.
    Linux is user friendly, it's just picky about its friends...
    Disclaimer: Please use caution when opening messages, my grasp on reality may have shaken loose during transmission (going on rusty memory circuits).
    ๑۩۞۩๑

  5. #5
    ok thank you for the information ,I also thought the issue is in the isp network since I posted ,they have sent a tech to my place to check it for Own Domain faults and they didn't find any lol .....so the guy called the hub and got me a static ip since then it has improved a bit i get close to 20mbps now but the losses on the 3rd hop still persist.I will try mailing the ppl higher up and see what they can do .again thank you.

Similar Threads

  1. Slow Internet speed behind router, fine from Modem
    By m0gwai in forum General Broadband Forum
    Replies: 0
    Last Post: 05-02-13, 06:02 AM
  2. Speed is slow through router and fine through modem
    By jeek325i in forum General Broadband Forum
    Replies: 1
    Last Post: 12-14-10, 12:03 PM
  3. DSL slow, speed test fine
    By EightToedSloth in forum Broadband Tweaks Help
    Replies: 21
    Last Post: 06-09-09, 06:16 PM
  4. Slow DSL Download speed (fine upload speed)
    By mojo8472 in forum General Broadband Forum
    Replies: 6
    Last Post: 12-19-08, 10:47 PM
  5. Slow speed on web surfing,download speeds are fine though
    By hellgrace in forum Broadband Tweaks Help
    Replies: 4
    Last Post: 12-18-07, 11:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •