Page 4 of 11 FirstFirst 12345678 ... LastLast
Results 61 to 80 of 213

Thread: TCP Optimizer needs new version since v1709 Windows Update [updated]

  1. #61
    Regular Member n1kobg's Avatar
    Join Date
    Jan 2018
    Posts
    120
    Yeah, this site dslreports.com is good but it doesnt work for me, Ive test 2 connections there.Every time i test my connection it gives me unacurate results or the tool dont work for my connection. For people in USA that may work but at least for me the tools & speed tests they have not working.Good thing is you can check some info there.
    I just saw i didnt post the right "right click options" file Instead I post the raw file from my registry I used for base.

    Unfortunately I dont have test bench or at least a 2nd PC where I can test my tweaks more closely. Virtual machine is the alternative but not for all tweaks + Ive disabled all unnecessary services in order to reduce the system's footprint.
    I'll post it but I decided to reduce it a bit. i hope it works fine. Please give me a feedback if everything is ok or something else you noticed. Actually they both still needs to be refined along with the Game Power Plan.
    So thats on-the-work version i guess.Ill post the final later on. Youmay see options which you can change.Im not sure its because of the different CPUs or something else.

    https://mega.nz/#!p5JwgRJQ!0fVKyQe8R...V24O0dqhslTQPU

    If you have problems install it write me here. Sometimes the GUIDs are changing & thats one side to check if the install_Ultra_Gaming_Mode_n1kobg.bat doesnt work.
    Last edited by n1kobg; 03-27-18 at 05:04 PM.

  2. #62
    Something we need to fix guys is.
    To turn Nagle Algorithm completely off.

    C:\Windows\system32>netsh int tcp show supplemental

    Globale TCP-Standardvorlage: internet

    Zusätzliche TCP-Parameter
    ----------------------------------------------
    Mindest-RTO (ms) : 300
    Anfängliches Überlastungsfenster (MSS) : 10
    Überlastungssteuerungsanbieter : cubic
    Neustart des Überlastungsfensters aktivieren : disabled
    Zeitüberschreitung für verzögerte Bestätigung (ms) : 40 { NAGLE }
    Häufigkeit für verzögerte Bestätigung : 2 { NAGLE }

    RACK aktivieren : enabled
    Tail Loss Probe aktivieren : enabled


    SettingName : Internet
    MinRto(ms) : 300
    InitialCongestionWindow(MSS) : 10
    CongestionProvider : CUBIC
    CwndRestart : False
    DelayedAckTimeout(ms) : 40 { NAGLE }
    DelayedAckFrequency : 2 { NAGLE }

    MemoryPressureProtection : Disabled
    AutoTuningLevelLocal : Normal
    AutoTuningLevelGroupPolicy : NotConfigured
    AutoTuningLevelEffective : Local
    EcnCapability : Disabled
    Timestamps : Disabled

    InitialRto(ms) : 2000
    ScalingHeuristics : Disabled
    DynamicPortRangeStartPort : 49152
    DynamicPortRangeNumberOfPorts : 16383
    AutomaticUseCustom : Disabled
    NonSackRttResiliency : Disabled
    ForceWS : Enabled
    MaxSynRetransmissions : 2
    AutoReusePortRangeStartPort : 0

    AutoReusePortRangeNumberOfPorts : 0

    Registry Settings are not working. Maybe it never worked? Someone Tested the Nagle Registry Fix? Maybe TCPNODELAY turn this 2 Settings off? I dont know.


    ==================================================================================================== ================================

    About CSGO. I got very good Hitbox, now. On **** Internet i dont want to know what happens if you play with these Settings on a good Internet Connection.

    Maybe someone wants to test it, too?

    Net_graph var value: is much more stable, and reg improved on SWEDISH and NETHERLANDS servers.

    What i did.
    Code:
    SettingName                     : Internet
    MinRto(ms)                      : 300
    InitialCongestionWindow(MSS)    : 10
    CongestionProvider              : CUBIC
    CwndRestart                     : False
    DelayedAckTimeout(ms)           : 40
    DelayedAckFrequency             : 2
    MemoryPressureProtection        : Disabled
    AutoTuningLevelLocal            : Normal
    AutoTuningLevelGroupPolicy      : NotConfigured
    AutoTuningLevelEffective        : Local
    EcnCapability                   : Disabled
    Timestamps                      : Disabled
    InitialRto(ms)                  : 2000
    ScalingHeuristics               : Disabled
    DynamicPortRangeStartPort       : 49152
    DynamicPortRangeNumberOfPorts   : 16383
    AutomaticUseCustom              : Disabled
    NonSackRttResiliency            : Disabled
    ForceWS                         : Enabled
    MaxSynRetransmissions           : 2
    AutoReusePortRangeStartPort     : 0
    AutoReusePortRangeNumberOfPorts : 0
    
    
    
    
    PS C:\Windows\system32> Get-NetOffloadGlobalSetting
    
    
    ReceiveSideScaling           : Disabled
    ReceiveSegmentCoalescing     : Disabled
    Chimney                      : Disabled
    TaskOffload                  : Disabled
    NetworkDirect                : Enabled
    NetworkDirectAcrossIPSubnets : Blocked
    PacketCoalescingFilter       : Disabled
    
    PS C:\Windows\system32> Get-NetAdapterAdvancedProperty
    
    Name                      DisplayName                    DisplayValue                   RegistryKeyword RegistryValue  
    ----                      -----------                    ------------                   --------------- -------------  
    Ethernet                  Flusssteuerung                 Rx und Tx aktiviert            *FlowControl    {3}            
    Ethernet                  Interrupt-Drosselung           Deaktiviert                    *InterruptMo... {0}            
    Ethernet                  IPv4-Prüfsummen abladen        Rx und Tx aktiviert            *IPChecksumO... {3}            
    Ethernet                  Jumbo Packet                   Deaktiviert                    *JumboPacket    {1514}         
    Ethernet                  Large-Send-Offload V2 (IPv4)   Deaktiviert                    *LsoV2IPv4      {0}            
    Ethernet                  Large-Send-Offload V2 (IPv6)   Deaktiviert                    *LsoV2IPv6      {0}            
    Ethernet                  Max. Anzahl RSS-Warteschlangen 2 Warteschlangen               *NumRssQueues   {2}            
    Ethernet                  Protokoll-ARP-Abladung         Aktiviert                      *PMARPOffload   {1}            
    Ethernet                  Protokoll-NS-Abladung          Aktiviert                      *PMNSOffload    {1}            
    Ethernet                  Paketpriorität und VLAN        Paketpriorität und VLAN akt... *PriorityVLA... {3}            
    Ethernet                  Empfangspuffer                 256                            *ReceiveBuffers {256}          
    Ethernet                  RSS (Empfangsseitige Skalie... Aktiviert                      *RSS            {1}            
    Ethernet                  Geschwindigkeit und Duplex     1,0 Gbit/s Vollduplex          *SpeedDuplex    {6}            
    Ethernet                  TCP-Prüfsummen abladen (IPv4)  Rx und Tx aktiviert            *TCPChecksum... {3}            
    Ethernet                  TCP-Prüfsummen abladen (IPv6)  Rx und Tx aktiviert            *TCPChecksum... {3}            
    Ethernet                  Übertragungspuffer             512                            *TransmitBuf... {512}          
    Ethernet                  UDP-Prüfsummen abladen (IPv4)  Rx und Tx aktiviert            *UDPChecksum... {3}            
    Ethernet                  UDP-Prüfsummen abladen (IPv6)  Rx und Tx aktiviert            *UDPChecksum... {3}            
    Ethernet                  Akt. über Magic Packet         Deaktiviert                    *WakeOnMagic... {0}            
    Ethernet                  Akt. bei Musterübereinstimmung Deaktiviert                    *WakeOnPattern  {0}            
    Ethernet                  Adaptives Interframe-Spacing   Deaktiviert                    AdaptiveIFS     {0}            
    Ethernet                  Energieeffizientes Ethernet    Aus                            EEELinkAdver... {0}            
    Ethernet                  PME aktivieren                 Aktiviert                      EnablePME       {1}            
    Ethernet                  Interrupt-Drosselungsrate      Aus                            ITR             {0}            
    Ethernet                  Kompatibilitätsmodus für äl... Deaktiviert                    LinkNegotiat... {1}            
    Ethernet                  Verbindungsereignis protoko... Deaktiviert                    LogLinkState... {16}           
    Ethernet                  Gigabit Master/Slave-Modus     Automatische Erkennung         MasterSlave     {0}            
    Ethernet                  Lokal verwaltete Adresse       --                             NetworkAddress  {--}           
    Ethernet                  Geschw. beim Abschalten red... Deaktiviert                    ReduceSpeedO... {0}            
    Ethernet                  Systemleerlauf-Energiesparo... Deaktiviert                    SipsEnabled     {0}            
    Ethernet                  ULP-Modus                      Deaktiviert                    ULPMode         {0}            
    Ethernet                  Auf Verbindung warten          Automatische Erkennung         WaitAutoNegC... {2}            
    Ethernet                  Akt. bei Verbindung            Deaktiviert                    WakeOnLink      {0}

  3. #63
    Regular Member n1kobg's Avatar
    Join Date
    Jan 2018
    Posts
    120
    @st1cky
    TcpAckFrequency to 1 is the maximum number of outstanding acknoledgements.Thats the minimum time it can operate. You cant make it to stop working. We need to operate as fast as possible. This is what we call to disable Nagles Algorithm. If you know how to lower the Delayed acknowledgment timeout from 40 to lower value thats will be great Delayed Confirmation Frequency: 2 is again the lowest you can get. If im missing something pls explain?

    About the improved performance in CSGO I have a feeling its because you disable chimney, ReceiveSegmentCoalescing ,TaskOffload, Timestamps, EcnCapability. RSS & Checksum Offloading are useful depending on the system (and maybe the game) + its harder to see the difference on faster CPU. On slow CPUs offloading have to be enabled for sure IMO.

  4. #64
    Junior Member
    Join Date
    Mar 2018
    Posts
    39
    @St1cky
    If you compare our settings, you can see what is different. You changed CTCP and went on CUBIC. You have Autotuning enabled, which is the only thing I will experiment more. I have it on desabled and was thinking setting Highlyrestricted.
    You have offloadings enabled, I am happy like this with disabled...

    I would like to report what happens in CSGO (for n1kobg , we must start playing PUBG ... LOL) with my settings. What I did apart from the settings shown on page 3, is configure my router (I should have done that a long time ago). Its nothing much, but I made a simple external port forwarding setting for CSGO IP-s and I have set MTU on my router to be the same as in my OS settings, MTU = 1492. (BTW I have tested MTU 1240 for CSGO and it was horible)

    So now the strangest thing happens when I connect to a CSGO server.
    But first the base line ... My standard ping on my favourite server was always 45 -50 before joining this forum and experimenting wtih NIC and OS internet settings.

    So now, In the first 5 seconds after connection, my ping is very high. Like 75 - 80.
    But than it starts going down. After 30 seconds is at base level of 45 -50.
    But than it goes further down. Like 1 - 2 every 10 seconds. After 2 minutes my ping goes down to 30 - 32.
    And it stays there. As this is a casual server with 36 players, depending on server load, my ping will rise back to maybe 40 - 45 for full server load. As soon as there is a moderate number of players on the server and thus server is not overloaded, my ping goes down.
    On other servers , where number of players is smaller, I have gone from 32 - 38 to low as 16 !!!!!

    I am talking about ping number that is shown besides the player when you press "TAB" (in CSGO)
    Although this number might not be really a ping but some kind of ping indicator, this shows me that we ARE on the right track and that my system adapts to server condition and internet grid in general and manages to bring out the maximum.
    What I like even more is that this adaptation process is not erratic but is slow and gentle, so it doesnt upset my game.

    My hitreg is OK, depending on servers and maps. Steam servers - hitreg is excelent, nonsteam servers - depends on a map (just concluded that I will erase and reinstall the maps with bad hitreg).
    This is also important to notice ... as I play mostly on an nonsteam server(CSROG) where most of my friends hang out, and as it is a dust 2 server, /new Dust2, Old dust2, Dust2 - winter..../ some maps have excelent hitreg, but one map in particular is avfull for me in terms of hitreg.... so I conclude that hitreg has something to do with map optimisation also (am I wrong).

    So to conclude I will test with different Autotuning settings although my system does some kind of tuning as it is, and please give me your opinion about my ping or better jet ping indicator behaviour.

  5. #65
    Regular Member n1kobg's Avatar
    Join Date
    Jan 2018
    Posts
    120
    jack37. You should always set your router and your windows MTU to be equal values. Good timing, just last night I wrote about the MTU. BTW I think thats what hepened here. Your ping is high at the beginning because your PC and the Server are making test and are trying to determine the highest non fragmented MTU value so they send back & forth few packets.
    Yes you should of optimize your router at day one The fact that your ping make such big ping drop tells me your system is not fully optimized. Either that or you have issues with your router or net provider. If you are the only one whos using the internet connection I strongly suggest you skip the router and plug the cable directly into the PC. If you have trouble call your ISP they should help you on the phone or send a technician to properly configure your setup.

    I just finished patching few of my batch files into one big new file including System, Network Optimizations + some Services for disabling. It consists of old & new tweaks. I'll leave a day or 2 to clean the bugs or mistakes which Inevitably will make watching the screen for few hours. I decided to leave the Game Mode separate.
    Last edited by n1kobg; 03-28-18 at 09:09 PM.

  6. #66
    Regular Member n1kobg's Avatar
    Join Date
    Jan 2018
    Posts
    120

    PERFORMANCE_BOOSTER_v1.0

    ENJOY

    PERFORMANCE_BOOSTER_v1.0

    * need tweaking


    Please report the bugs here (im sure there will be bugs).
    Last edited by n1kobg; 03-30-18 at 01:50 AM.

  7. #67
    Junior Member
    Join Date
    Mar 2018
    Posts
    10
    Quote Originally Posted by n1kobg View Post
    ENJOY

    PERFORMANCE_BOOSTER_v1.0

    https://mega.nz/#!94gHhTbQ!cHyXLa_CC...KHgEcVjgXZWZHE


    Please report the bugs here (im sure there will be bugs).
    Hello n1kobg, good afternoon I used your optimization files for my windows 10 v1709 after formatting, install drivers, programs and make different configurations. After using all the .bat options I literally broke windows and had to format again.

    What I call broken is that it took a long time to load the operating system and stayed on the screen preparing windows ... after a while when that screen on the desktop passes, the programs and services loaded super slow, and after opening a window or a program, the windows was crooked saying the error does not respond

    I hope you can continue retouching your optimization file, since I see it very interesting

    Sorry for my awful english.
    Greetings.

  8. #68
    Junior Member
    Join Date
    Mar 2018
    Posts
    10
    Quote Originally Posted by Ailurus View Post
    Hello n1kobg, good afternoon I used your optimization files for my windows 10 v1709 after formatting, install drivers, programs and make different configurations. After using all the .bat options I literally broke windows and had to format again.

    What I call broken is that it took a long time to load the operating system and stayed on the screen preparing windows ... after a while when that screen on the desktop passes, the programs and services loaded super slow, and after opening a window or a program, the windows was crooked saying the error does not respond

    I hope you can continue retouching your optimization file, since I see it very interesting

    Sorry for my awful english.
    Greetings.
    Hello again, after doing a few tests I found the error that happens to me that I freeze the pc, and is in the part of service modifications, I think that by deactivating a specific service or services, I miss the mentioned error previously, in which everything takes time to load.

  9. #69
    Regular Member n1kobg's Avatar
    Join Date
    Jan 2018
    Posts
    120
    Yes, thank you.
    When I wrote your first post I realize I went too far with service optimizations. Ive made these tweaks in several different takes, never at once. The new Win 10 has different service dependencies. Thats why I made it on modules so you can use different sections of the file. Ill remove the link and tweak the services section. The reason your system took long time to boot is windows tried to fix WindowsStore. Thats what I think at least.

    Can you confirm its from CDPUser and/or CDPSvc ??

    You first have to disable Windows Store then disable them. What error did you get?

    BTW after I did the tweaks my system restart for 5-7 seconds. I added new options now.To disable all Windows Apps except calculator (the only useful app) and to disable Windows Store. You still can use Windows Game Mode if you want to use it.
    I just tried service optimizations without the services I think are problematic and everything is ok, Thats why I recommend step by step tweaking. Restart every time. thats the best approach. I could post all the tweak files separately but thats around 10 batch files.

    If someone have to test the file in Virtual environment will be great.
    Last edited by n1kobg; 03-30-18 at 03:20 AM.

  10. #70
    Junior Member
    Join Date
    Mar 2018
    Posts
    10
    The truth is that I have no idea what would be CDPUser and / or CDPSvc, but what I did to solve the problem was to modify the .bat and looking for internet information on how to modify the registry through a .bat, I went to the registration part in its file and change all the services from deactivated to automatic from 000004 to 000002 (4 to 2), I think that's it.

    After doing that, restart pc and the problem that the pc was frozen was solved, so I do not know which service will be the specific to solve this problem

    In case you want to know the version of the windows that I have installed is this: http://www.majorgeeks.com/files/deta...on_64_bit.html

    The windows store I have disabled and I think that in this retouched version and was deactivated

    I could help you by making a virtual machine, I have no problem.

  11. #71
    Junior Member
    Join Date
    Mar 2018
    Posts
    39
    Hello guys,
    unfortunately I am still at NIC settings and experimenting...
    Regarding this, here is an interesting link: https://blogs.technet.microsoft.com/...or-windows-10/
    It is up to date explanation about 1-2 things we are debating here.

    So folowing this, I made some tests and here are the results.
    First about testing. The only way I can test stuff (if there is something better please advice) is by going to : http://www.dslreports.com/speedtest as it has a feature called "bufferbloat" (true readout???) and beside that is ingame feeling (CSGO).

    So I changed CTCP to CUBIC and Autotuning from DISABLED to HIGHLY RESTRICTED.

    DSLREPORTS results: Bufferbloat is in general lower (cca 10%) from previous settings (CTCP, Autotuning disabled) BUT every few seconds bufferbloat jumps to MAX (for a fraction of second)! As if my OS constantly pushes large amount of data just to see how much it can push through the internet. I find this strange , and I think this combo is better for quantity and not for pure speed. (OFC I am making conclusions about stuff I dont know anything about LOL)

    Strangely in game feeling shows no signs of this bufferbloat spikes. The game IS a tiny bit slower (ping indicator is showing 10% higher ping than before - CTCP, no Autotuning).
    Ping is more stable from the start, not like before High than going down.
    No lag, no stuttering, no hickups, decent hitreg, but most importantly the game runs VERY VERY fluid and as said hitreg is still pretty decent.
    Also I think energy consumption is better optimized with CUBIC because as soon as I changed to CUBIC my laptop fans stopped (?????????). Temps in general are a bit lower.

    So to describe in another words, CTCP and no Autotuning is like riding a racing car which is fast but you feel every bump on the road and steering is precise but stiff, and CUBIC is 10%-15% towards a fast car but you still have some suspension and some indirect stearing .... well if you are into cars you will understand.

    Surfing the web is just as equal as the game feeling. Just a fraction slower but a nicer experience. Pages open up withouth visible hickups but maybe 10% slower....

    And please tell me how to attach pictures into this forum...

    And will join you in testing the Performance Booster soon.

  12. #72
    Regular Member n1kobg's Avatar
    Join Date
    Jan 2018
    Posts
    120
    Ok thank you;. Virtual Machine will speed the thigs up. So services are the problem Did you had any other bugs? With other sections of the file ?

    BTW st1cky that analogyu you made with cars is very accurate
    I see bufferbloat mentioned only when testings normal everyday tasks & browsing. Im not sure its relevant for gaming. I could be wrong.
    Last edited by n1kobg; 03-30-18 at 03:58 AM.

  13. #73
    Junior Member
    Join Date
    Mar 2018
    Posts
    39

    Angry

    Quote Originally Posted by n1kobg View Post
    Ok thank you;. Virtual Machine will speed the thigs up. So services are the problem Did you had any other bugs? With other sections of the file ?

    BTW st1cky that analogyu you made with cars is very accurate
    NOT st1cky !!!!!!!!!!!!!!!

  14. #74
    Junior Member
    Join Date
    Mar 2018
    Posts
    39
    Hahahahahahahahahaah

  15. #75
    Regular Member n1kobg's Avatar
    Join Date
    Jan 2018
    Posts
    120
    Heres the corrected PERFORMANCE_BOOSTER_v2.0 file:

    https://mega.nz/#!osBSwKBI!1g4INEORs...KjzyC3wmbii4EU

    Please report the bugs and tell me if you have improvement and what you think about the batch.

    ps. Oh Im sory jack37 Im rushing to prepare for going out. Im going to my grandparents. Im sory I mixed your name.Never the less good analogy

  16. #76
    Junior Member
    Join Date
    Mar 2018
    Posts
    39
    Quote Originally Posted by n1kobg View Post
    Heres the corrected PERFORMANCE_BOOSTER_v2.0 file:

    https://mega.nz/#!osBSwKBI!1g4INEORs...KjzyC3wmbii4EU

    Please report the bugs and tell me if you have improvement and what you think about the batch.

    ps. Oh Im sory jack37 Im rushing to prepare for going out. Im going to my grandparents. Im sory I mixed your name.
    NO biggy at all! Nice work!!!!
    Just in case rename the files to V_2.0, not to make confusion... When you get the time.

  17. #77
    Regular Member n1kobg's Avatar
    Join Date
    Jan 2018
    Posts
    120
    I did renamed the files ?! Or maybe you nmean in the zip file itself yes. Like I said Im in a hurry
    Ok see ya in few hours.

  18. #78
    Junior Member
    Join Date
    Mar 2018
    Posts
    1
    Quote Originally Posted by n1kobg View Post
    Heres the corrected PERFORMANCE_BOOSTER_v2.0 file:

    https://mega.nz/#!osBSwKBI!1g4INEORs...KjzyC3wmbii4EU

    Please report the bugs and tell me if you have improvement and what you think about the batch.

    ps. Oh Im sory jack37 Im rushing to prepare for going out. Im going to my grandparents. Im sory I mixed your name.Never the less good analogy
    Im folllowing this thread from the begining and found something new from you guys, let you say thanks I tried this tweak file, well after applying and restarting windows it took quite a long loading time and after loading windows there was some problem with windows desktop. It freezed and popped up dialog box that windows explorer is not responding. After ~5min everythings was fine. All situation was very simillar like Ailurus described.

  19. #79
    Regular Member n1kobg's Avatar
    Join Date
    Jan 2018
    Posts
    120
    Hm. thank you. So what you re saying. Did the windows applied the Last Known Good Configuration or the tweaks were made successfully?
    Ill have to reduce the number of the tweaks. I just realize that I want everything off and disabled to reduce the Windows footprint. Not everyone want to have only 28 services.Ill have to check them all services.
    For me works perfectly fine.

  20. #80
    n1kobg add coreparking disable and msi gpu mode

Similar Threads

  1. Replies: 10
    Last Post: 09-16-10, 10:02 AM
  2. TCP Optimizer version 3.0.3 released (64-bit Windows 7/2008 fix)
    By Philip in forum Broadband Tweaks Help
    Replies: 30
    Last Post: 09-06-10, 10:18 AM
  3. TCP Optimizer version 3.0.2 released (Windows 7/Vista support !)
    By Philip in forum Broadband Tweaks Help
    Replies: 18
    Last Post: 07-29-10, 03:07 PM
  4. TCP Optimizer version 3.0 released ! (Windows 7/Vista support)
    By Philip in forum Broadband Tweaks Help
    Replies: 37
    Last Post: 07-12-10, 10:27 AM
  5. Xfire has been updated to version .18
    By JawZ in forum Gaming
    Replies: 3
    Last Post: 07-23-04, 06:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •