Results 1 to 3 of 3

Thread: HP OfficeJet Pro 8740 Setup Problem

  1. #1
    Advanced Member
    Join Date
    Nov 2000
    Davie, FL

    HP OfficeJet Pro 8740 Setup Problem

    So I was helping someone today, setup a new printer, HP OfficeJet Pro 8740. After initial setup, I connected the printer to his wifi. I then used his iPhone and got the printer added and did a test print of the Google Home Page, from inside Safari. I then completed setting the printer up, with the CD, from his Windows 10 Desktop PC. For this, we wanted to use the USB and I connected it as such. It all worked. But then, for some reason, it is no longer is visible on the iPhone, nor his Macbook Air. I power cycled his AT&T Router, I powercycled the printer and both Apple devices. On the Windows 10 PC, in DEVICES AND PRINTERS, both the USB connected printer, as well as the wifi connected printer (that Windows 10 finds on it's own) both show up. I even tried to RESET the printer's Network Settings to Factory Default and then re-connected it to the wifi, still would not work. I had to give up for today. Very odd, I usually never have a problem getting Apple devices to see a printer setup such as this. And I have done many installs where the PC is connected USB, but other devices can print to it thru wifi (on the network). I made sure, many times, that the Apple devices were connected to his same wifi network.

    Has anyone ever seen such a problem? Have any fixes I am overlooking?


  2. #2
    Administrator Philip's Avatar
    Join Date
    May 1999
    Jacksonville, Florida, United States
    Blog Entries
    Is the WiFi network "private" ? It wont work with public WiFi.
    Have you tried resetting all printers on the iOS devices? That sometimes does the trick.
    "AirPrint" may have to be enabled in the printer settings, if it is there.
    You may want to disable Firewall temporarily while testing, router must allow Bonjour packets, but all that should be fine if they were working before.

  3. #3
    Advanced Member
    Join Date
    Nov 2000
    Davie, FL
    Yes it is a private wifi, at home. Service and box are AT&T. Router SSID is persons last name and the wifi password is his phone number. As I said, when I very first did it, it worked fine, and I did nothing different than many other Network Printer Mac & Windows setups I have done in the past.

    Not sure about resetting printers on the iOS. But no printers show up. On the iPhone it says select printer and now there is nothing there and it does not find it. On the Macbook Air in System Preferences, Printers, no printers are showing and when I click ADD it does not find any. Also, when I ran the HP Easy Setup on the Macbook it comes up No Devices Found.

    I can check for Airprint in the printer settings, I did see Bonjour enabled with a Bonjour name.

    I had meant to add that I set this up just as I have successfully done many others. I even tried unhooking the USB (to the Win 10 PC), just in case that was interfering with the Printer's wifi. I don't think that is the case, as during the time it was connected USB it still had a solid blue wifi logo on the printer. It is so strange. Especially when it first worked out of the box, then stopped working for some unknown reason.

Similar Threads

  1. HP Officejet Pro L7580 as NW Printer
    By Qui-Gon John in forum Networking Forum
    Replies: 3
    Last Post: 05-16-08, 07:34 AM
  2. HP 725 Series OfficeJet All-In-One
    By Joint Chiefs of Staff in forum Hardware & Overclocking
    Replies: 4
    Last Post: 12-17-01, 10:34 AM
  3. officejet t65
    By skeets44 in forum Hardware & Overclocking
    Replies: 2
    Last Post: 12-10-01, 08:22 PM
  4. officejet t65 not working w/ windows xp
    By skeets44 in forum Software Forum
    Replies: 0
    Last Post: 12-09-01, 10:08 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts