I have a strange problem that I could use some help with. I have Verizon 15/2 fios and have been running speed tests this past week since I noticed a considerable slowdown. Before I get too deep into this let me give some background:

1). I have 4 PC's 2 desktop units and 2 laptops.

2). First desktop was reformatted and a clean install of XP with SP3 was installed.

3). Second desktop has Linux Mint installed on it.

4). First laptop has XP with SP3 installed.

5). Second laptop has Vista.

On desktop #1 I go to speakeasy.net and run a speed test. I get 2.5/1.8. I do the same test on speedtest.net and get the same slow results. I test on desktop #2 the "Linux" box and I get full 15/2.

I then test all my other windows based PC's and they all have the slow 2.5/1.8 speed.

I then boot into a ubuntu linux "Live CD" and run the speed tests again on desktop #1 and I get full 15/2.

So the network card in desktop #1 is fine and this is either a router or a windows thing. I contact Verizon and they agree to replace my actiontec router. I get the new router and the same problems still exist. They direct me to a different speed test site "myspeed.visualware" and it shows the full 15/2, so they say my line is fine and they can't help anymore. I download a lot of usenet stuff and I used to get my full 15 meg download, but now I'm only getting 2.5 meg. I'm also seeing the same slow speeds on speedtest.net and speakeasy.net.

All of my windows based PC's have slow speed tests. desktop #1 has been reformatted and a clean copy of windows XP with SP3 has been applied.

Things I've tried:

1). Ran the FiOS optimizer from verizon.
2). Changed the duplex to everything I could and re-tested but same results.
3). Ran drtcp and put in the RWIN and MTU settings.
4). Tried all the PC's at my house and all windows PC's have the slow speed on usenet and speed sites like speakeasy.net and speedtest.net
5). If I boot to linux and run the same test on any of my PC's I get full speed 15/2 on all sites.

So what am I missing. Are the packets from linux so different from windows?? I know the hardware is good because I can run the same test using windows and linux on the same box using the same nic.

Their seems to be a direct link to sites like speakeasy and speedtest that show a slow download speed and that is what is holding me back from downloading off usenet at the full speed of what my line is capable of. Why do sites like myspeed.visualware show my full speed while others don't?

Any help would be greatly appreciated. I have never had this problem before and it has only happened the past two weeks. Verizon says everything is good on their end, but I'm not happy with the service.