Results 1 to 4 of 4

Thread: Fin_wait_2

  1. #1
    Junior Member
    Join Date
    Jun 2017
    Posts
    2

    Fin_wait_2

    Hi everybody,
    hoping this is the right forum.
    Well, my problem is as follow:
    since a couple of months i've noted ugly performance of my broadband connection, a 100Mb fiber FTTCAB type.
    Quoting a different post from another forum/user that describes perfectly my problem
    I am using Windows 7 x64 Ultimate Edition. Whenever I start a download from my download manager it downloads at full speed for about 2 mins and then FIN_WAIT_2 gets accumulated and they start pulling the data thus reducing the download speed of the actual file. I have tried different download managers but all in vain.
    Now in that post, the culprit seemed to be the AV; so i did as follow:
    1) uninstalled my current AV ( a different one )
    2) reboot
    3) used -AT MY OWN RISK- the net for a couple of hours doing usual stuff as everyday.
    As result, NEVER a single instance of FIN_WAIT_2 was detected in my pc.
    4) reinstalled the same AV.
    5) repeated step 3.
    As result LOTS of FIN_WAIT_2 was detected in my pc.

    So the AV seems to be responsable for this mess

    The only solution was to manually close this connections using TCPView.

    I'll move to another AV but meanwhile, i was wondering if there was any patch/tweak or similia to limit/[auto]close this pesky FIN_WAIT_2 socket's state.
    I read about a tweak
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\TCPFinWait2Delay
    but it didn't solve my issue.
    So i'm here asking any advices fro you,
    Any hints ?

    Regards.
    Creatchy

  2. #2
    Administrator Philip's Avatar
    Join Date
    May 1999
    Location
    Jacksonville, Florida, United States
    Posts
    9,461
    Blog Entries
    6
    If you have already tried the Registry parameter "TCPFinWait2Delay", there is no other user-defined setting that I am aware of to control it.. I believe the default in Windows was 240 seconds, we recommend lowering that to 30-45s generally.

    When your AV is running, do those connections close after ~240 seconds?
    Which AV is the culprit for you?

    You may want to try disabling your AV's "internet" monitoring, so that they do not monitor web pages and downloads, this may help.

    Thanks for writing, sorry I can't be of more help.

  3. #3
    Junior Member
    Join Date
    Jun 2017
    Posts
    2
    Hi Philip,
    thanks 4 your kind and fast reply.
    I tuned TCPFinWait2Delay value to 30. but i really don't know if this setting is useful under W7; M$ article referred to W2003 server.
    My AV is ESET, other was BitDefender.
    I haven't checked if then connections were closed after 240 seconds; but even if i closed Firefox ( Chrome was the same ), they were there !!!
    Anyway this is an absurd behaviour !
    Thanks,
    Creatchy.

  4. #4
    Administrator Philip's Avatar
    Join Date
    May 1999
    Location
    Jacksonville, Florida, United States
    Posts
    9,461
    Blog Entries
    6
    Yeah, it is definitely an annoying issue to leave a lot of connections in that state.
    Like I said, some of those AVs can be set not to validate web content at all, that may mitigate the issue somehow.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •