Hi ,2 ol

i'm a newbie need help or suggestion for a slow or unstable net connection .
my location is philippines currently a smartbro broadband subscriber their Ad is
7xfaster than dial-up connection.
@
motorola modem canopy
dlink wireless N150 home router
OS windows Xp



< my current speed test >
SpeedGuide.net Speed Test Results
123 kbps down (~0.12 Mbps, 15 KB/s)↓
150 kbps up (~0.15 Mbps, 18 KB/s)↑
250 KB downloaded in 16.698 seconds
100 KB uploaded in 5.469 seconds
Tested on: 2011.10.23 04:37 EDT
Tested from: speedguide.net
Test Link: http://www.speedguide.net/speedtest/...p?test=3466114
Latency: 249ms



< my current setting >
SpeedGuide.net TCP Analyzer Results
Tested on: 10.23.2011 04:40
IP address: 121.1.xx.xx
Client OS: Windows XP

TCP options string: 020405b40103030001010402
MSS: 1460
MTU: 1500
TCP Window: 32120 (multiple of MSS)
RWIN Scaling: 0 bits
Unscaled RWIN : 32120
Recommended RWINs: 64240, 128480, 256960, 513920, 1027840
BDP limit (200ms): 1285kbps (161KBytes/s)
BDP limit (500ms): 514kbps (64KBytes/s)
MTU Discovery: ON
TTL: 41
Timestamps: OFF
SACKs: ON
IP ToS: 00000000 (0)


< my current save settings by SG TCP Optimizer >
TcpWindowSize =32120
GlobalMaxTcpWindowSize =32120
DefaultReceiveWindow =-1
EnablePMTUDiscovery =1
EnablePMTUBHDetect =0
SackOpts =1
DefaultTTL =64
TcpMaxDupAcks =2
Tcp1323Opts =1
DisableTaskOffload =0
MaxConnectionsPerServer =10
MaxConnectionsPer1_0Server =20
InternetMTU =-1
{D6277990-4C6A-11CF-8D87-00AA0060F5BF}=-2
MaxNegativeCacheTtl =0
NegativeCacheTime =-1
NetFailureCacheTime =0
NegativeSOACacheTime =0
NonBestEffortLimit =0
DisableUserTOSSetting =0
DefaultTOSValue =80
LocalPriority =5
HostsPriority =6
DnsPriority =7
NetbtPriority =8
SizReqBuf =16384
ProtocolMTU =-2
TCPNoDelay =-1
MaxUserPort =-1
TcpTimedWaitDelay =-1
[]
MTU =1500
TcpWindowSize =-1
NonBestEffortLimit =-1
TcpAckFrequency =-1
TcpDelAckTicks =-1
[]
MTU =1500
TcpWindowSize =-1
NonBestEffortLimit =-2
TcpAckFrequency =-1
TcpDelAckTicks =-1

i have tried different sets of value as for the moment this is
" THE BEST " connection i ever had at 15KB/s.
and
SMARTBRO INC. CO. keeps telling me that i have a "GOOD CONNECTION".

i'm asking for anyone who could help or suggest for a real connection ..