I am using a server switch and client switches. below is a copy of the config i am using. Anyone got any ideas wher i am going wrong?


configurations for Server

enab
conf term
hostname MainSwitch
exit
vlan database
vtp domain RedDiamond
vtp server
vtp password cisco
vlan 10 name ITsupport
vlan 20 name Management
vlan 30 name Accounts
exit
conf term
Interface range fa0/1
switchport mode trunk
exit
Interface range fa0/2
switchport mode trunk
exit
Interface range fa0/3-6
switchport mode access
switchport access vlan 10
exit
Interface range fa0/7-10
switchport mode access
switchport access vlan 20
exit
Interface range fa0/11-14
switchport mode access
switchport access vlan 30
exit
interface vlan 1
ip address 192.168.1.3 255.255.255.0
ip default-gateway 192.168.1.1


Configurations for Client

enab
conf term
hostname Switch1
exit
vlan database
vtp domain RedDiamond
vtp client
vtp password cisco
exit
conf term
Interface range fa0/1
switchport mode trunk
exit
Interface range fa0/2
switchport mode trunk
exit
Interface range fa0/3-6
switchport mode access
switchport access vlan 10
exit
Interface range fa0/7-10
switchport mode access
switchport access vlan 20
exit
Interface range fa0/11-14
switchport mode access
switchport access vlan 30
exit
interface vlan 1
ip address 192.168.1.3 255.255.255.0
ip default-gateway 192.168.1.1