Results 1 to 10 of 10

Thread: Problem with TCPAckFrequency and TCPDelAckTicks

  1. #1

    Problem with TCPAckFrequency and TCPDelAckTicks

    I believe I found a bug that is causing severe speed problems when using the Optimizer. Here are the details...
    OS: Windows XP SP3
    Broadband Connection: 50Mbps Download x 5Mbps Upload

    If I launch TCP Optimizer and slide the bar to 50Mbps, just select my primary network adapter (Broadcom NetXtreme 57xx Gigabit Controller), select Optimal and modify then things work great. I'm hitting 50-60Mbps everytime to speed test servers.

    However, if instead I check the box for "Modify all Network Adapters" which is just one more adapter (Intel Pro Wireless 2200BG Network Connection) and apply the changes my speeds go to hell, between 1-4Mbps.

    I started looking at the settings when I do both methods and the only difference is that the TCPAckFrequency and TCPDelAckTicks is getting set to "1500" when I modify all adapters as opposed to "N/A" for when I just modify the one by itself. Another interesting point is that if I first launch the program, select the one adapter and apply the optimal settings it says it will set the 2 options to "N/A". If I exit that without committing the changes, select modify all and click apply, it shows the value being set to "1500". Then if I exit that, uncheck modify all and go back to just modifying the 1 adapter it still shows "1500" for the new setting. Weird little bug....

    I started looking online and it appears the valid range for this setting is 0-6, and in TCP Optimizer itself under custom settings the only options are N/A, 0 and 1 which all 3 work fine. So I think there is something causing these 2 settings to get set to 1500 by mistake when selecting modify all adapters.

  2. #2
    fem the retarded rabbit mccoffee's Avatar
    Join Date
    Nov 2001
    Cleveland, Ohio, United States
    i"m going to have Philip take a look at this post.

    If you can post a link to the article with the valid ranges so we could all see what the promblem maybe

    try some of the tips suggested here
    Last edited by mccoffee; 09-14-10 at 11:51 AM.
    Comptia a+ n+

  3. #3
    That's actually one of the articles I read. And if you look, for XP it says:
    TcpAckFrequency = 2 (Default=2, 1=Disables delayed ACK, 2-n = If n outstanding ACKs before timed interval, sent ACK)

    Looking at that I would say 1500 is not a valid value for the setting. Even if it is, it's definitely causing a problem.

    It doesn't mention XP specifically for the TcpDelAckTicks but it mentions it for 2000:
    TcpDelAckTicks = 1 (Default=2, 0=Disables delayed ACK, 1-6 = 100-600 ms)

    Which that one looks like it could be 0-6 for Win2000. Can't find much about it for XP.

  4. #4
    Subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<Interface GUID>
    Entry: TcpAckFrequency
    Value Type: REG_DWORD, number
    Valid Range: 0-255
    Default: 2
    HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\ interface-name

    Range 0-6

  5. #5
    Junior Member
    Join Date
    Sep 2010
    I'm having the same problem, XP or 2003. I just delete these two key off the interface and it work great after that.

  6. #6
    Yup, I did the same thing and it fixed it on mine. Just not sure why it's setting it in the first place.

  7. #7
    Administrator Philip's Avatar
    Join Date
    May 1999
    Jacksonville, Florida
    Blog Entries
    Thanks for catching this, seems it is a bug when selecting "All network adapters". Will be fixed in the next release.

  8. #8
    Administrator Philip's Avatar
    Join Date
    May 1999
    Jacksonville, Florida
    Blog Entries
    Fixed, released version 3.0.5
    Linux is user friendly, it's just picky about its friends...
    Disclaimer: Please use caution when opening messages, my grasp on reality may have shaken loose during transmission (going on rusty memory circuits).

  9. #9
    No prob. Glad I could help!

  10. #10
    Regular Member KEiGHT's Avatar
    Join Date
    Feb 2014
    TcpAckFrequency=1 (disable Nagling algorithm)
    TcpDelAckTicks=0 (disable Nagling algorithm) works only when Nagling is enabled !
    TCPNoDelay=1 (disable Nagling algorithm)

    Here is where SG TCP Optimizer is wrong set for Windows 7 SP1 x64;


    Specifies the time interval that defines the end of a segment stream. When this interval elapses between the receipt of TCP segments, TCP considers the segment stream to be complete, and it sends an ACK message to acknowledge the segment. Otherwise, TCP acknowledges every other segment only. This interval is used in TCP's delayed acknowledgment strategy, in accordance with RFC 1122, Requirements for Internet hosts—communication layers.

    TcpDelAckTicks default value is 2 in the registry of windows 7 , which in SG TCP Optimizer shows disabled: 0
    If I set this one with SG TCP Optimizer, his value will be set as 0 but in SG TCP Optimizer after restart, show default n/a instead of Disabled: 0
    The odd fact is , cuz if I set in registry to 2, in SG TCP Optimizer will appear correct value Disabled: 0 and if I set it to Disabled: 0 with SG TCP Optimizer in registry will appear 0 but in SG TCP Optimizer shows default n/a instead of Disabled: 0

    Why is that ?

    So, the real configs for registry are here;

    ;Online Gaming config:


    ;Internet browsing/download Normal config:

    Last edited by KEiGHT; 07-18-14 at 09:03 AM.
    Every man has his destiny.

Similar Threads

  1. School Technology
    By Tammy Woods in forum
    Replies: 1
    Last Post: 08-30-10, 07:49 PM
  2. Browsing problem.
    By Anon in forum General Broadband Forum
    Replies: 3
    Last Post: 02-23-10, 01:11 PM
  3. Did this get resolved?
    By Chad Ingram in forum
    Replies: 1
    Last Post: 11-20-09, 11:09 AM
  4. network problem.. could it be virus attack?
    By maxchock in forum Networking Forum
    Replies: 0
    Last Post: 10-04-08, 04:18 AM
  5. Problem: Accessing RapidShare through Wireless Router
    By pg in forum
    Replies: 1
    Last Post: 05-03-08, 07:12 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts