I cannot get my ASA 5505 to allow email in. Email sends out just fine. I am running Microsoft Exchange 2010 as the email server and I do have static IPs.

External email address : 74.13.1.4
Internal Email Address: 10.151.1.5

Here is the config file:
hostname ciscoasa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd Vj6Qfko9VNRUamrf encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 10.151.x.x 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 74.13.x.x 255.255.255.248
!
interface Vlan12
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
access-list OUTSIDE extended permit ip host x.x.y.y any
access-list OUTSIDE extended permit tcp any host 74.13.1.4 eq smtp
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp 10.151.1.5 smtp netmask 255.255.255.255
route outside 0.0.0.0 0.0.0.0 74.13.1.4 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
client-update enable
telnet timeout 5
ssh 64.235.105.6 255.255.255.255 outside
ssh timeout 5
console timeout 0
group-policy TECH internal
group-policy TECH attributes
wins-server value 192.168.1.10
dns-server value 67.69.x.x 67.69.x.x
vpn-tunnel-protocol IPSec
default-domain value health
username support password xlka4cPiHU08vL0A encrypted privilege 0
username support attributes
vpn-group-policy TECH
tunnel-group TECH type ipsec-ra
tunnel-group TECH general-attributes
default-group-policy TECH
tunnel-group TECH ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map global_policy
class inspection_default
inspect esmtp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:4c0641038fe4cb7f8a93bae881a5ea07
: end

Any help is greatly appreciated.