Hello, and thanks in advance to anyone willing to help. I'm using a Nokia 3110 Classic (GPRS/EDGE capable; maximum speed stated is 460.8 Kbps) as a dial-up modem with a laptop running Windows 7 Home Premium. Windows Auto-Tuning is disabled. After a couple hours reading various articles and threads here, I used TCP Optimizer to change the default Windows settings, resulting in a speed improvement of roughly 40 Kbps (from about 180 Kbps to about 220 kbps) . My TCP Analyzer results after the tweaks are:


SpeedGuide.net TCP Analyzer Results
Tested on: 01.12.2010 20:52
IP address: 115.67.xxx.xxx(proxy:64.255.180.51)
Client OS: Windows 7
TCP options string: 020405b40402080a906154650000000001030307
MSS: 1460
MTU: 1500
TCP Window: 5888 (NOT multiple of MSS)
RWIN Scaling: 7 bits (2^7=128)
Unscaled RWIN : 46
Recommended RWINs: 64240, 128480, 256960, 513920, 1027840
BDP limit (200ms): 236kbps (29KBytes/s)
BDP limit (500ms): 94kbps (12KBytes/s)
MTU Discovery: ON
TTL: 49
Timestamps: ON
SACKs: ON
IP ToS: 00000000 (0)


Unfortunately it seems that my provider fixes the RWIN at 5888 and also doesn't allow for turning off of Timestamps . Please, does anyone know any tricks for getting around these facts or, at the least, know of better settings in TCP Optimizer given my situation? Thanks again for your time.