Results 1 to 4 of 4

Thread: Arris Modem + D-Link Router = No Internet

  1. #1

    Arris Modem + D-Link Router = No Internet

    Hi Forum,

    I have an Arris Touchstone CM550A Cable Modem, and also a D-Link DIR-625 Wireless Router.

    I recently changed my DSL modem to the Cable modem mentioned above when I changed my internet service provider.

    The problem is that my router won't stay connected to the internet through the cable modem. If I connect my laptop directly to the Arris modem with a LAN cable my internet works perfectly. However before I switched from DSL modem to Cable modem, I was also receiving the internet through my D-Link wireless router without problem. So I don't think that either of the devices are faulty.

    Here are the steps that I have tried so far and have failed (some gotten from this forum):
    • Upgraded the Firmware on the router to the latest version.
    • Reset both the D-Link Router and the Arris Cable Modem
    • Disable DHCP server on the router
    • Plug the modem into one of the LAN ports on the router instead of Internet port.
    • Clone PC Mac address in the router's internet settings.
    • Reset router to factory settings and reboot.

    It is also important to note that resetting the D-Link router or any change that involves rebooting the router will result in a temporary connection to the internet.
    But I get disconnected after 5-10 minutes and then I have to reset it again if I want temporary internet access.

    Right now I'm connected directly to the modem, and miserable because it is far from my regular workspace.

    Help would be greatly appreciated.

  2. #2
    I use an Arris TM602G cable modem with a DLink DIR-300 wireless router. After a few hours I cannot connect to any sites. I had the 'Enable DNS Relay' option set under the Lan Setup menu. Today, I have disabled this option and am connecting for the last 5 hours or so. I am not familiar with the menu options for your router, but if it has an Enable DNS Relay option then try and disable it.

    Hopes this continue to work for me, and hope it works for you.

  3. #3
    This ISP uses the Arris modems you can check this link for troubleshooting. I was getting a lot of trouble setting up a router with one of these modems. the modem seems to remember the mac address of the first (and only the first) computer/network device plugged into its network port. Only this device can receive an IP address. You can reset it to clear its memory and then plug in your router right after and it should receive an IP.You can also try removing the battery. Or you can clone the MAC address of the first network device you plugged into it. Hope that helps.

  4. #4
    Have you tried to Reset your router, then try Reset by pressing a small switch on the back side using Pen or a pin.

    Then you have to Re Configure Router

Similar Threads

  1. should I Bridge the modem or Router...?
    By Alien-3000 in forum Wireless Networks & Routers
    Replies: 2
    Last Post: 04-24-09, 02:00 AM
  2. Speeds 6mbps through modem 56kish through router
    By Ascosis in forum General Broadband Forum
    Replies: 6
    Last Post: 01-03-08, 07:09 PM
  3. Really frustrating problem with connecting to Internet via wireless router
    By Senor_Hybrido in forum Wireless Networks & Routers
    Replies: 12
    Last Post: 06-12-07, 10:05 PM
  4. DSL modem and Wireless router in parallel
    By rajanv in forum Wireless Networks & Routers
    Replies: 2
    Last Post: 12-04-06, 02:31 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts