Results 1 to 2 of 2

Thread: Inconsisten Atheros Wifi with Ubuntu

  1. #1
    MarkA
    Guest

    Inconsisten Atheros Wifi with Ubuntu

    I have read several threads about the Atheros AR2413-related chipset
    having problems with Linux, but I have never seen this particular problem
    described: SOMETIMES my laptop boots just fine, and at other times it
    fails to recognize the wifi chip: wifi%d: unable to attach hardware:
    'Hardware revision not supported' (HAL status 13). When this happens, I
    can reliably get Ubuntu to recognize the chip by booting into WinXP,
    letting XP connect to the wireless network, then rebooting into Ubuntu.
    Sometimes just rebooting Ubuntu gets it to work, but the XP boot works
    every time.

    My system is an Acer Aspire 3502wLCi laptop. wifi chipset: Atheros AR2413
    802.11bg NIC (as reported by 'lshw') Ubuntu 8.04
    madwifi, ath_pci 0.9.4, ath_hal 0.9.18.0

    What would cause this erratic behavior? Was it the position of the stars
    when I was born? Any advice would be most appreciated.

    --
    MarkA
    Keeper of Things Put There Only Just The Night Before
    About eight o'clock


  2. #2
    alexd
    Guest

    Re: Inconsisten Atheros Wifi with Ubuntu

    MarkA wrote:

    > I can reliably get Ubuntu to recognize the chip by booting into WinXP,
    > letting XP connect to the wireless network, then rebooting into Ubuntu.


    If you remove the power from the laptop and disconnect the battery, does it
    work if you boot straight into Ubuntu?

    --
    <http://ale.cx/> (AIM:troffasky) (UnSoEsNpEaTm@ale.cx)
    21:23:20 up 50 days, 4:19, 2 users, load average: 0.21, 0.19, 0.12
    A few flakes working together can unleash an avalanche of destruction



Similar Threads

  1. WIFI & LAN connection
    By Noel S Pamfree in forum ms.public.windows.networking.wireless
    Replies: 3
    Last Post: 03-12-09, 05:44 PM
  2. Trouble connecting to a 'non ssid broadcasting' wifi network
    By Gregor Stefka in forum ms.public.windows.networking.wireless
    Replies: 5
    Last Post: 12-30-08, 08:21 AM
  3. Files Visible Over WiFi and Hard-Wired, But Won't Open Over WiFi?
    By (PeteCresswell) in forum ms.public.windows.networking.wireless
    Replies: 2
    Last Post: 12-29-08, 11:21 AM
  4. Advise: 2 Separate WiFi Routers & Subnets - Need to work in following way
    By crashnburn in forum Wireless Networks & Routers
    Replies: 0
    Last Post: 04-25-08, 06:54 PM
  5. Two PC's on crossover kills WiFi
    By just bob in forum ms.public.windows.networking.wireless
    Replies: 7
    Last Post: 04-16-08, 10:54 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •