Results 1 to 12 of 12

Thread: Using GPRS/EDGE mobile phone as dial-up modem

  1. #1

    Using GPRS/EDGE mobile phone as dial-up modem

    Hello. And thank you all in advance for both your patience--this is my first foray into a forum--and your help. I really appreciate it. Anyway, I've a question to which I couldn't find an answer searching older posts (please feel free to direct me there if you know of just such a post): I'm using a mobile phone (Nokia 3110 Classic) with GPRS/EDGE as a dial-up modem, and after using TCP Optimizer to tweak my settings, the results of the TCP Analyzer aren't even close to what I set. Now, when I have access to a wireless connection, and tweak my settings accordingly with TCP Optimizer, the TCP Analyzer results perfectly mirror my settings. But not with the GPRS/EDGE modem. After using the features in TCP Optimizer, I determined that I could set my MTU to 1500 and that I would make my TCP Window setting 92160 since my maximum bandwidth is 460.8 Kbps (DTac/Happy is the provider; I'm located in Krabi, Thailand) and the average result of 3 latency tests was 1600ms. However, here are the TCP Analyzer results:


    Tested on: 03.25.2009 22:40
    IP address: 115.67.xxx.xx
    Client OS: Windows XP

    TCP options string: 020405640103030004020000
    MSS: 1380
    MTU: 1420
    TCP Window: 4380 (NOT multiple of MSS)
    RWIN Scaling: 0 bits
    Unscaled RWIN : 4380
    Recommended RWINs: 63480, 126960, 253920, 507840, 1015680
    BDP limit (200ms): 175kbps (22KBytes/s)
    BDP limit (500ms): 70kbps (9KBytes/s)
    MTU Discovery: ON
    TTL: 228
    Timestamps: OFF
    SACKs: ON
    IP ToS: 00000000 (0)


    I'm, as usual, clueless. Do any of you informed folks have an idea how I can rectify this situation, or at least the best possibility? Thanks again.

  2. #2
    SG Enthusiast Rollingstone's Avatar
    Join Date
    Jan 2008
    Location
    HoChiMinh, Vietnam
    Posts
    3,161
    Try the following with TCP Optimizer:

    General Settings tab:
    Custom settings - check
    Modify All Network Adapters - check
    network adapter selection - your NIC
    MTU - 1420
    TTL - 64
    Windows Scaling - uncheck
    TCP Receive Window - 63480
    MTU Discovery - Yes
    Black Hole Detect - No
    Selective Acks - Yes
    Max Duplicate ACKs - 2
    TCP 1323 Options:
    Timestamps - uncheck

    Advanced Settings tab:
    Max Connections per Server - 8
    Max Connections per 1.0 Server - 8
    LocalPriority - 5
    Host Priority - 6
    DNSPriority - 7
    NetbtPriority - 8
    Lan Browsing speedup - optimized
    QoS: NonBestEffortLimit - 0
    ToS: DisableUserTOSSetting - 0
    ToS: DefaultTOSValue - 80
    MaxNegativeCacheTtl - 0
    NetFailureCacheTime - 0
    NegativeSOACache Time - 0
    LAN Request Buffer Size - 32768
    Firefox Extreme Speed Edition

    What makes you: "...waking up in the morning so excited about & wanna FLY out of the door ?"

  3. #3

    Thanks

    Wow, and thank you very much for your consideration. I took your advice, and after using your settings, ran TCP Optimizer to make sure all was as you'd suggested. It was. However, upon running TCP Analyzer things don't seem to jibe. Does this matter? Really: when I open and then run TCP Optimizer all shown settings match your kind suggestions; yet, TCP Analyzer's results claim something different. Here are those results:


    Tested on: 03.26.2009 10:37
    IP address: 115.67.xxx.xxx
    Client OS: Windows XP

    TCP options string: 020405640103030004020000
    MSS: 1380
    MTU: 1420
    TCP Window: 4380 (NOT multiple of MSS)
    RWIN Scaling: 0 bits
    Unscaled RWIN : 4380
    Recommended RWINs: 63480, 126960, 253920, 507840, 1015680
    BDP limit (200ms): 175kbps (22KBytes/s)
    BDP limit (500ms): 70kbps (9KBytes/s)
    MTU Discovery: ON
    TTL: 228
    Timestamps: OFF
    SACKs: ON
    IP ToS: 00000000 (0)


    What's your thought (an obviously much more informed thought than my own) on this? Again, thanks for your time.

  4. #4
    SG Enthusiast Rollingstone's Avatar
    Join Date
    Jan 2008
    Location
    HoChiMinh, Vietnam
    Posts
    3,161
    TCP Window: 4380 (NOT multiple of MSS)
    RWIN Scaling: 0 bits
    Unscaled RWIN : 4380
    Recommended RWINs: 63480, 126960, 253920, 507840, 1015680
    Run TCP Settings again, when done correctly , your TCP Window should be 63480.
    Firefox Extreme Speed Edition

    What makes you: "...waking up in the morning so excited about & wanna FLY out of the door ?"

  5. #5
    Thank you for your patience, but I wanted to check something. Again I took your advice and reran the TCP Optimizer with your suggested settings, and again the results of the TCP Analyzer didn't jibe. So, I went to a wireless spot and ran the Analyzer with the Optimizer settings for the GPRS/EDGE mobile. Here are the results:


    Tested on: 03.26.2009 21:49
    IP address: 118.173.xx.xxx
    Client OS: Windows XP
    TCP options string: 0204041c01010402
    MSS: 1052
    MTU: 1092
    TCP Window: 63480 (NOT multiple of MSS)
    RWIN Scaling: 0 bits
    Unscaled RWIN : 63480
    Recommended RWINs: 65224, 130448, 260896, 521792, 1043584
    BDP limit (200ms): 2539kbps (317KBytes/s)
    BDP limit (500ms): 1016kbps (127KBytes/s)
    MTU Discovery: ON
    TTL: 27
    Timestamps: OFF
    SACKs: ON
    IP ToS: 00000000 (0)


    I then turned off the wireless, connected with the mobile phone, and reran the Analyzer. Here are those results.


    Tested on: 03.26.2009 21:55
    IP address: 115.67.xxx.xxx
    Client OS: Windows XP
    TCP options string: 020405640103030004020000
    MSS: 1380
    MTU: 1420
    TCP Window: 4380 (NOT multiple of MSS)
    RWIN Scaling: 0 bits
    Unscaled RWIN : 4380
    Recommended RWINs: 63480, 126960, 253920, 507840, 1015680
    BDP limit (200ms): 175kbps (22KBytes/s)
    BDP limit (500ms): 70kbps (9KBytes/s)
    MTU Discovery: ON
    TTL: 228
    Timestamps: OFF
    SACKs: ON
    IP ToS: 00000000 (0)


    I think that, after reading some sticky posts, I understand the change in the MTU as it's controlled by the router/modem. But I still don't get the TCP Window number discrepancy. Perhaps the GPRS/EDGE is a factor? I'll actually be at a computer most of the day today, so if you need more information I'll check this post regularly. And thanks again for your knowledge.

  6. #6
    SG Enthusiast Rollingstone's Avatar
    Join Date
    Jan 2008
    Location
    HoChiMinh, Vietnam
    Posts
    3,161
    Tested on: 03.26.2009 21:49
    IP address: 118.173.xx.xxx
    Client OS: Windows XP
    TCP options string: 0204041c01010402
    MSS: 1052
    MTU: 1092
    TCP Window: 63480 (NOT multiple of MSS)
    RWIN Scaling: 0 bits
    Unscaled RWIN : 63480
    Recommended RWINs: 65224, 130448, 260896, 521792, 1043584
    BDP limit (200ms): 2539kbps (317KBytes/s)
    BDP limit (500ms): 1016kbps (127KBytes/s)
    MTU Discovery: ON
    TTL: 27
    Timestamps: OFF
    SACKs: ON
    IP ToS: 00000000 (0)
    Turn on wireless, set TCP Window to 65224 and see if it will change !
    Firefox Extreme Speed Edition

    What makes you: "...waking up in the morning so excited about & wanna FLY out of the door ?"

  7. #7
    Do you mean turn on the wireless receiver even when I'm using the GPRS/EDGE modem? Perhaps I was unclear at the beginning. My main internet connection is via a Nokia 3110 Classic mobile phone utilizing GPRS/EDGE technology, ISP DTac/Happy, residing in Krabi, Thailand. To get a wireless signal I need to go to a cafe in town, which isn't very practical for my typical usage. Thus, I'm trying to tweak my settings to optimize the dial-up connection. Now, after using TCP Optimizer and TCP Analyzer in conjunction, and consecutively with both a wireless signal and the mobile phone modem (info in last post), I've determined that it's not the TCP Optimizer but apparently the mobile phone modem (GPRS/EDGE?) that's limiting my RWIN. Or so it seems given the discrepancy between the two Analyzer results taken mere minutes apart--wireless and dial-up--with the Optimizer settings unchanged. Thanks again for your patience, as it's sometimes tough for me to communicate about new subject matter in writing. Again I'm near a computer most of the day (hoping for a good dial-up connection!), so any more of your ideas are very welcome.

  8. #8
    SG Enthusiast Rollingstone's Avatar
    Join Date
    Jan 2008
    Location
    HoChiMinh, Vietnam
    Posts
    3,161
    Download Cablenut and set DefaultReceiveWindow to 63480, save to registry and reboot ! (for your GPRS/EDGE connection via mobile modem)
    Firefox Extreme Speed Edition

    What makes you: "...waking up in the morning so excited about & wanna FLY out of the door ?"

  9. #9
    I'll take your suggestion as quickly as my addled brain (and connection) will allow, then let you know how it worked. Many thanks.

  10. #10
    OK. Downloaded, installed, and ran Cablenut, setting DefaultReceiveWindow to 63480 using the adjuster.exe. After rebooting, I reopened the Cablenut adjust.exe and it shows 63480 for both the GlobalMaxTcpWindowSize and TcpWindowSize. However, the results of TCP Analyzer are the same as before:


    SpeedGuide.net TCP Analyzer Results
    Tested on: 03.28.2009 04:03
    IP address: 115.67.xxx.xxx
    Client OS: Windows XP
    TCP options string: 020405640103030004020000
    MSS: 1380
    MTU: 1420
    TCP Window: 4380 (NOT multiple of MSS)
    RWIN Scaling: 0 bits
    Unscaled RWIN : 4380
    Recommended RWINs: 63480, 126960, 253920, 507840, 1015680
    BDP limit (200ms): 175kbps (22KBytes/s)
    BDP limit (500ms): 70kbps (9KBytes/s)
    MTU Discovery: ON
    TTL: 228
    Timestamps: OFF
    SACKs: ON
    IP ToS: 00000000 (0)


    Any more thoughts,? And, if you reckon the phone is fixing an untweakable 4380 for the TCP Window, do you have any recommendations for settings for the tweakable values? Heck, maybe I'll try using 1380 or 4140 for the TCP Window since they're multiples of MSS! Seriously, any other ideas will be greeted with a spirit of optimism, and much appreciation.

  11. #11
    SG Enthusiast Rollingstone's Avatar
    Join Date
    Jan 2008
    Location
    HoChiMinh, Vietnam
    Posts
    3,161
    I guess your TCP Window is being limited by Mobile modem !
    Firefox Extreme Speed Edition

    What makes you: "...waking up in the morning so excited about & wanna FLY out of the door ?"

  12. #12
    Yep, it sure seems like that's the case. Do you--or anyone else who's so inclined to reply--have any ideas how to work around a GPRS/EDGE modem that seems to limit the TCP Window? Regardless, Rollingstone, I thank you for your kind assistance and wish you only well.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •