Results 1 to 2 of 2

Thread: assign IP to a network device

  1. #1
    Junior Member
    Join Date
    Dec 2008
    Posts
    1

    assign IP to a network device

    I have a network device (LED Sign) that is shipped with an IP of 192.168.X
    I need to write a utility for my customers to assign a new IP to it. The sign has a web based setup screen.
    My problem is that my customers may have a 10.1.X network.
    They setup the sign by connecting directly to it via a crossover or through a hub.
    I know the MAC address(serial number) of the sign.
    I set up a small 10.1.X network with a router and gateway and plugged my machine and the sign into a hub to simulate a customer.
    I tried adding an entry in my machines' ARP cache as 10.1.1.100 and then pinged 10.1.1.100 but no joy.
    I have been scouring the net and reading anything and everything I can find that even remotely is in the ball park, I've learned more about networks and IP routing than I ever thought I would but can't seem to get my head around this one.
    Does anyone have any ideas on how I can get to a 192.1.X device from a 10.1.X device with a known MAC address?

    Thanks for any Ideas

  2. #2
    SG Enthusiast koldchillah's Avatar
    Join Date
    Apr 2002
    Location
    Orlando, FL
    Posts
    4,609
    On your computer, temporarily change the IP address of your network adapter to 192.168.x.x with a subnet mask of 255.255.255.0.. Now you are on the same subnet as the sign and you should be able to login to the sign and change the IP of the sign to your 10.1.x.x range. Then you just change your IP settings on your computer back to the 10.x.x.x range and you are all set.
    "Nobody's invincible, no plan is foolproof, We all must meet our moment of truth." - Guru

Similar Threads

  1. (long post) New system and new tech advice and help.
    By osuprowler in forum Hardware & Overclocking
    Replies: 11
    Last Post: 10-07-08, 11:05 PM
  2. trying to see remote network device on local network
    By quincyg in forum Networking Forum
    Replies: 0
    Last Post: 05-30-08, 01:31 PM
  3. few questions about my internet...
    By charlieC in forum General Broadband Forum
    Replies: 1
    Last Post: 04-08-08, 09:06 PM
  4. Slow page loading. Loads of info! Help.
    By Magnus3204 in forum General Broadband Forum
    Replies: 3
    Last Post: 09-06-07, 09:13 AM
  5. Were can I find what slot I have for vid card
    By agustintorre in forum Hardware & Overclocking
    Replies: 51
    Last Post: 02-10-07, 05:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •