I have a 50/10 Mbit/s cable connection from my ISP Com Hem and I'm using Windows Vista Home Premium 64-bit. This is my result from TCP Analyzer:

« SpeedGuide.net TCP Analyzer Results »
Tested on: 10.12.2008 12:08
IP address: 83.249.xxx.xx

TCP options string: 020405b40103030201010402
MSS: 1460
MTU: 1500
TCP Window: 65700 (multiple of MSS)
RWIN Scaling: 2 bits (2^2=4)
Unscaled RWIN : 16425
Recommended RWINs: 64240, 128480, 256960, 513920, 1027840
BDP limit (200ms): 2628kbps (329KBytes/s)
BDP limit (500ms): 1051kbps (131KBytes/s)
MTU Discovery: ON
TTL: 103
Timestamps: OFF
SACKs: ON
IP ToS: 00000000 (0)

I keep losing my internet connection several times every day. It goes away for a few seconds and then comes back again. It's really annoying when you're using an application that requires you to stay connected. I've noticed that one of the lights that is always lit on my cable modem goes out for these few seconds. I don't think it's a problem with the cable modem itself though since I've had this issue with my previous modem too. I'm using a D-Link DIR-655 router and I'm wondering if that might be the problem? Here's a log from when I lost my connection one time:

[INFO] Sat Oct 11 02:18:06 2008 Blocked incoming ICMP packet (ICMP type 8) from 84.7.37.152 to 83.249.148.35
[INFO] Sat Oct 11 02:18:06 2008 Blocked incoming ICMP packet (ICMP type 8) from 91.109.71.143 to 83.249.148.35
[INFO] Sat Oct 11 02:18:05 2008 Blocked incoming ICMP packet (ICMP type 8) from 90.211.160.248 to 83.249.148.35
[INFO] Sat Oct 11 02:18:05 2008 Blocked incoming ICMP packet (ICMP type 8) from 86.215.64.112 to 83.249.148.35
[INFO] Sat Oct 11 02:18:02 2008 Blocked incoming ICMP packet (ICMP type 8) from 84.193.143.134 to 83.249.148.35
[INFO] Sat Oct 11 02:18:00 2008 Blocked incoming ICMP packet (ICMP type 8) from 195.0.217.141 to 83.249.148.35
[INFO] Sat Oct 11 02:17:59 2008 Blocked incoming ICMP packet (ICMP type 8) from 84.60.163.11 to 83.249.148.35
[INFO] Sat Oct 11 02:17:59 2008 Blocked incoming ICMP packet (ICMP type 8) from 85.179.198.176 to 83.249.148.35
[INFO] Sat Oct 11 02:17:59 2008 Blocked incoming ICMP packet (ICMP type 8) from 86.22.6.128 to 83.249.148.35
[INFO] Sat Oct 11 02:17:59 2008 Blocked incoming ICMP packet (ICMP type 8) from 78.149.161.183 to 83.249.148.35
[INFO] Sat Oct 11 02:17:59 2008 Blocked incoming ICMP packet (ICMP type 8) from 84.49.81.29 to 83.249.148.35
[INFO] Sat Oct 11 02:17:59 2008 Blocked incoming ICMP packet (ICMP type 8) from 85.177.230.16 to 83.249.148.35
[INFO] Sat Oct 11 02:17:58 2008 Blocked incoming ICMP packet (ICMP type 8) from 83.196.216.123 to 83.249.148.35
[INFO] Sat Oct 11 02:17:58 2008 Blocked incoming ICMP packet (ICMP type 8) from 88.147.47.208 to 83.249.148.35
[INFO] Sat Oct 11 02:17:58 2008 Blocked incoming ICMP packet (ICMP type 8) from 81.39.86.61 to 83.249.148.35
[INFO] Sat Oct 11 02:17:58 2008 Blocked incoming ICMP packet (ICMP type 8) from 86.144.48.103 to 83.249.148.35
[INFO] Sat Oct 11 02:17:58 2008 Blocked incoming ICMP packet (ICMP type 8) from 92.1.152.105 to 83.249.148.35
[INFO] Sat Oct 11 02:17:50 2008 Blocked outgoing ICMP packet (ICMP type 3) from 192.168.0.194 to 159.153.163.51

I have no idea what settings to change to possibly fix this but if anyone could offer any help, that'd be great.