Results 1 to 16 of 16

Thread: Help Tweak Alltel Wireless Settings

  1. #1
    Junior Member
    Join Date
    Apr 2008
    Posts
    7

    Help Tweak Alltel Wireless Settings

    I've been playing with the settings for awhile now and come to the conclusion my unexperienced butt needs some serious help. I really have no clue at this point as to what to set my settings to for max speeds.

    The advertised package is UP TO 2.4mbps. So that's what I've been basing all my settings off of.

    It is also a USB modem. I will be going through ethernet as soon as I can afford the router.

    So that's:
    2.4mbps - advertised
    300KB/sec - max download
    500ms - max delay (averaged 300-450ish depending on the site pinged)
    I used http://www.dslnuts.com/bitsbytes.shtml to calculate my TCP receive with 300 bandwidth, 500 latency, and 1460 MSS.

    Here's what my current settings are:
    SpeedGuide.net TCP Analyzer Results
    Tested on: 04.24.2008 14:15
    IP address: 75.116.xx.xxx

    TCP options string: 020405b40103030201010402
    MSS: 1460
    MTU: 1500
    TCP Window: 148920 (multiple of MSS)
    RWIN Scaling: 2
    Unscaled RWIN : 37230
    Reccomended RWINs: 64240, 128480, 256960, 513920
    BDP limit (200ms): 5957kbps (745KBytes/s)
    BDP limit (500ms): 2383kbps (298KBytes/s)
    MTU Discovery: ON
    TTL: 53
    Timestamps: OFF
    SACKs: ON
    IP ToS: 00000000 (0)

    My TTL is set to 64.

    My issue is I frequently am downloading large files and suddenly I have a packet loss. This happens consistently and corrupts downloads. Only fix was to set my MTU to 1472, which is the highest possible MTU without fragmentation according to the MTU tester. By doing this it appears my speeds become slower.

    I just used the OPTIMIZE setting, applied, restarted. Then clicked custom and changed the TCP receive. So everything is basically default but for TTL and TCP receive. I set it for 2500Kbps on the slider.

    So can any of you experts out there help me? If you need anymore info then please let me know. Thank you.

    *Edit*
    With my settings I posted above. During a download test I no longer get packet loss at 1500 MTU, BUT I'm downloading at only 54KB/sec average. It should be double or more, but it's not. So whatever I tweaked fixed the packet loss (I assume TTL. It was 54 or my TCP receive. It was 256960.), but my speeds are still slow.

    *Edit*
    Here's a speed test: (this is the exact results when downloading files as well, 50-60KB/s)
    SpeedGuide.net Speed Test Results
    464 kbps down (~0.46 Mbps, 57 KB/s)↓
    99 kbps up (~0.1 Mbps, 12 KB/s)↑
    1024 KB downloaded in 18.093 seconds
    250 KB uploaded in 20.782 seconds
    Tested on: 2008.04.24 14:37 EDT
    Tested from: globalgoldtalk.com
    Test Link: http://www.speedguide.net/speedtest/...t=YXPNXBPCR26O
    Latency: 194ms
    Location: US

    *Edit*
    After trying 8 different RWIN values I can conclude absolutely none of the changes do jack crap. The only difference is if I set it to low then my computer becomes a bottleneck. If I set it at the maximum. It has no bottleneck other then the service. Being wireless, no 2 tests will ever be alike.

    Here's the results:
    128480 = 639/88
    148920 = 632/82
    93440 = 609/87
    256960 = 544/80
    232320 = 542/85
    124100 = 541/81
    156220 = 514/83
    64240 = 449/81

    As you can see.. there is absolutely NO pattern. The ONLY value changed is the RWIN. Everything else was kept the same as a constant. This also means the speed tests was done on the same 6 servers for each RWIN.

    So what I'm going to do is set it so the max it can receive is 1.5mb because I'm on Rev0 that is the maximum I can obtain. 2.4mb is for RevA.. not sure why they even advertise that speed. It's not even physically possible.

    So that means. 1.5Mbps = 188KB/sec (rounded up), which is a RWIN of 93440.

    The ONLY change that impacted the connection greatly was MTU. If it's set to 1500 I have fragmentation, AKA I get packet loss. This causes a "Stop, go, Stop, go" action in downloads and speed tests. Changing it to 1472 prevents this entirely. According to the tester it's the highest MTU possible without fragmentation.

    I have no idea if this will impact speeds or not, but TBH I don't think I have a choice as it gets way to much packet loss if I set it to 1500.

    Also TTL must be 64. If it's any lower it can cause packet loss. If it's any higher it slows the connection. 64 is the sweet spot it would seam.

    If anyone else has suggestions. I'm all ears.. erm.. eyes.
    Last edited by Krileon; 04-24-08 at 06:20 PM.

  2. #2
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    You probably have used this DOS command to find your max. MTU:

    ping -f -l 1472

    Do not confuse this value of 1472 with MTU. It is just the largest packet size you can send out without fragmentation. To get your MTU, you need to add 28 (for overheads) to it.

    Thus your MTU is 1500 (=1472+28).
    "Contentment is not the fulfillment of what you want, but is the realisation of how much you already have" - anon

  3. #3
    fem the retarded rabbit mccoffee's Avatar
    Join Date
    Nov 2001
    Location
    Cleveland, Ohio, United States
    Posts
    13,365
    it's a wireless connection so many factors that could cause that intefence I"ve seen some guides where you can make your own attenna to help pick up more of a signal.

    Also with the wireless gear make sure the firmware is up to date on it also check the network dirvers are up to date. Keep the mtu the way it is since you have latency drop packets you want to try keep the pipe open to allow the packets to the equimpent.
    Comptia a+ n+

  4. #4
    Advanced Member chpalmer's Avatar
    Join Date
    Oct 2002
    Location
    Kitsap co. Wa
    Posts
    552
    USB could be causing you these issues.


    What is the model of your dsl modem?

    You can plug directly from the ethernet port to your computers ethernet port just as you would your usb connection. The router is highly recommended but not necessary for it to work...
    Never take any crap off an inanimate object!!

    Never send email to this address: spam@euclidian.com. This is a spam trap and everyone sending any email to this address will be blacklisted.

  5. #5
    Junior Member
    Join Date
    Apr 2008
    Posts
    7
    The issue appears to be Alltel.

    I've found countless complaints of the same situation. It would appear I've optimized it to the maximum. The only bottleneck remaining is Alltels Network.

    They're apparently doing changes that is screwing everyones speeds up. Everyone appears to have lost 50% or more of their speeds.

    My settings are:
    MTU: 1500
    TCP Receive Window: 148920
    MTU Discovery: Yes
    Black Hole Detection: No
    Selective ACKs: Yes
    Max Duplicate ACKs: 2
    TTL: 64
    Window Scaling: Checked
    MaxConnectionsPerServer: 10
    MacConnectionsPer1_0Server: 20
    LocalPriority: 1
    HostPriority: 1
    DNSPriority: 1
    NetbtPriority: 1
    LAN Browsing Setup: Optimized
    QoS: 0
    DefaultTOSSetting: 0
    DefaultTOValue: 80
    DNS Error Caching: All 0
    LAN Request Buffer: 32768

    @chpalmer: DSL Modem? It's alltel wireless.. UM150 Modem. Router appears to speed up the connection from other peoples reports. I'll be making the purchase for a Crandlepoint MBR1000 when I've got the extra money.

    @mccoffee: I've got a powerful 9dB gain antenna and am getting -69 to -74 signal strength. Perfect for max EVDO Rev0 speeds. Everything is up to date.

    @trogers: I used TCPOptimizer Largest MTU tool. 1472 is the max without fragmentation, but I changed it to 1500 anyway.

  6. #6
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    Quote Originally Posted by Krileon View Post
    @trogers: I used TCPOptimizer Largest MTU tool. 1472 is the max without fragmentation, but I changed it to 1500 anyway.
    The TCP Optimizer works on the same DOS command - to find by ping the largest non-fragmented packet size. You then need to add 28 to the result. Thus your connection line has an MTU of 1500.

    If your line is ADSL, you would have gotten 1464 instead, for MTU of 1492.

    Try using 64240 for TCP Window and uncheck Window scaling. The reason is that any value higher then 65535 requires Window scaling, and this would increase signal overheads.
    Last edited by trogers; 04-26-08 at 09:52 PM.
    "Contentment is not the fulfillment of what you want, but is the realisation of how much you already have" - anon

  7. #7
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    Quote Originally Posted by Krileon View Post
    500ms - max delay (averaged 300-450ish depending on the site pinged)
    I used http://www.dslnuts.com/bitsbytes.shtml to calculate my TCP receive with 300 bandwidth, 500 latency, and 1460 MSS.
    If you are getting 300-450ms ping times to dslnuts' site, there is probable signal quality issue in your line.

    Normal ping times within the US range from 90-130ms.

    Do a tracert to www.yahoo.com and post.
    "Contentment is not the fulfillment of what you want, but is the realisation of how much you already have" - anon

  8. #8
    Advanced Member chpalmer's Avatar
    Join Date
    Oct 2002
    Location
    Kitsap co. Wa
    Posts
    552
    Sorry- I had DSL on the mind when I wrote that...

    Can you try it on another computer and see if you have the same issues?

    Im wondering if the drivers for the usb are having conflicts causing these kinds of issues...
    Never take any crap off an inanimate object!!

    Never send email to this address: spam@euclidian.com. This is a spam trap and everyone sending any email to this address will be blacklisted.

  9. #9
    Junior Member
    Join Date
    Apr 2008
    Posts
    7
    Quote Originally Posted by trogers View Post
    The TCP Optimizer works on the same DOS command - to find by ping the largest non-fragmented packet size. You then need to add 28 to the result. Thus your connection line has an MTU of 1500.

    If your line is ADSL, you would have gotten 1464 instead, for MTU of 1492.

    Try using 64240 for TCP Window and uncheck Window scaling. The reason is that any value higher then 65535 requires Window scaling, and this would increase signal overheads.
    Didn't make any difference.

    Quote Originally Posted by trogers View Post
    If you are getting 300-450ms ping times to dslnuts' site, there is probable signal quality issue in your line.

    Normal ping times within the US range from 90-130ms.

    Do a tracert to www.yahoo.com and post.
    I read you need to set it to maximum anticipated latency. Normally it's 150-200ish or less. I set it for 500ms, because some sites/games run servers are very far distances or are not as high end. It's just to anticipate the delay. I could set the max delay to 250ms and be fine, but it isn't going to make any difference.

    I can set my RWIN higher or lower and it makes no difference. The only difference it makes is if I set it so low that my computer becomes a bottleneck. This all started happening when alltel decided to "improve" their network, but I had thought it was my doing. I've come to the conclusion it was not.

    Signal is not even remotely possible as to being the issue. I'm at -69 to -72dB at all times. This is PERFECT signal for full EVDO speeds.

    My ping to dslnuts site is 190-250ms. 90-130ms is RevA. Alltel is Rev0 still. Average to 5 different sites is 250ms, which is consistent with Rev0.

    Quote Originally Posted by chpalmer View Post
    Sorry- I had DSL on the mind when I wrote that...

    Can you try it on another computer and see if you have the same issues?

    Im wondering if the drivers for the usb are having conflicts causing these kinds of issues...
    Same results on any computer. Network ports are disabled from BIOS. They can't conflict. USB modem is the only modem installed. It's also being enhanced with more voltage then normal to boost antenna strength.
    Last edited by Krileon; 04-27-08 at 12:50 AM.

  10. #10
    Junior Member
    Join Date
    Apr 2008
    Posts
    7
    Ok I monitored a 150mb download using RWIN 64240 then compared it to 74460 (calculated with the dslnuts calculator).

    My results are astonishing. While 64240 presented absolutely no packet loss it would not surpass greater then 85-90KB/sec.

    Then 74460 would allow me to reach speeds of even 150KB/sec it had packet loss and was unstable speed often going between 80-150KB/sec randomly non-stop. Never a stable speed. I let it complete a 20mb file without pause/resume capability program and as suspected the download was dropped and corrupted. It stopped at 9mb for a 20mb file. So this is clearly a bad choice to go.

    So it looks like 64240 is my maximum. I'm going to try pushing it more and more until it starts having packet loss then go down slightly and leave it there.

    At least I found the window of maximum for my connection it would seam. Sad that it hurts my speed so greatly. This packet loss thing is recent too. I used to download at a stable speed of 115KB/sec.. what a sad day this is. Stuck at 80-90KB/sec and no more.

    Is there some kind of explanation as to why this would happen?

  11. #11
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    Since you said that the natural ping times of your connection line is almost double the usual values of 90-130ms,

    try the following with TCP Optimizer:

    General Settings tab:
    Custom settings - check
    Modify All Network Adapters - check
    network adapter selection - your NIC
    MTU - 1500
    TTL - 64
    TCP Receive Window - 128480
    MTU Discovery - Yes
    Black Hole Detect - No
    Selective Acks - Yes
    Max Duplicate ACKs - 2
    TCP 1323 Options:
    Windows Scaling - checked
    Timestamps - uncheck

    Advanced Settings tab:
    Max Connections per Server - 10
    Max Connections per 1.0 Server - 20
    LocalPriority - 1
    Host Priority - 1
    DNSPriority - 1
    NetbtPriority - 1
    Lan Browsing speedup - optimized
    QoS: NonBestEffortLimit - 0
    ToS: DisableUserTOSSetting - 0
    ToS: DefaultTOSValue - 80
    MaxNegativeCacheTtl - 0
    NetFailureCacheTime - 0
    NegativeSOACache Time - 0
    LAN Request Buffer Size - 32768
    Then select "Apply Changes" and reboot to take effect
    "Contentment is not the fulfillment of what you want, but is the realisation of how much you already have" - anon

  12. #12
    Junior Member
    Join Date
    Apr 2008
    Posts
    7
    Quote Originally Posted by trogers View Post
    Since you said that the natural ping times of your connection line is almost double the usual values of 90-130ms,

    try the following with TCP Optimizer:

    General Settings tab:
    Custom settings - check
    Modify All Network Adapters - check
    network adapter selection - your NIC
    MTU - 1500
    TTL - 64
    TCP Receive Window - 128480
    MTU Discovery - Yes
    Black Hole Detect - No
    Selective Acks - Yes
    Max Duplicate ACKs - 2
    TCP 1323 Options:
    Windows Scaling - checked
    Timestamps - uncheck

    Advanced Settings tab:
    Max Connections per Server - 10
    Max Connections per 1.0 Server - 20
    LocalPriority - 1
    Host Priority - 1
    DNSPriority - 1
    NetbtPriority - 1
    Lan Browsing speedup - optimized
    QoS: NonBestEffortLimit - 0
    ToS: DisableUserTOSSetting - 0
    ToS: DefaultTOSValue - 80
    MaxNegativeCacheTtl - 0
    NetFailureCacheTime - 0
    NegativeSOACache Time - 0
    LAN Request Buffer Size - 32768
    Then select "Apply Changes" and reboot to take effect
    I get packet loss at any RWIN above the maximum non-scaled value. So anything more then 65535 has packet loss. Not exactly double. For the most part it's around 190ish primarly, but again it's Rev0 not RevA. That makes a HUGE difference as the upload time on RevA is double or more then Rev0 allowing more data to flow. As well as the backhaul is much faster then Rev0 technology. RevA allows truely 2mb down or more and 300KB/sec up or more. While Rev0 only allows half that on the best of days. Remember it's wireless. Speed of radio waves still applies and while both wireless and wired travel at the speed of light. Wired does not have obstructions such as trees, houses, weather to effect it's round trip. The round trip adds time. Thus wireless can't be compared to the "standard US pings." Same applies to satellite internet.
    Last edited by Krileon; 04-27-08 at 09:28 AM.

  13. #13
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    Do you have a Rev A card to take advantage of the increased speed when your ISP upgrade to Rev A?

    http://evdoinfo.blogspot.com/2007/03...vdo-rev-0.html
    "Contentment is not the fulfillment of what you want, but is the realisation of how much you already have" - anon

  14. #14
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    One more thing to try. See if a lower MTU with solve the problem of packet losses when RWIN is above 65535.

    Try the following with TCP Optimizer:

    General Settings tab:
    Custom settings - check
    Modify All Network Adapters - check
    network adapter selection - your NIC
    MTU - 1440
    TTL - 64
    TCP Receive Window - 128800
    MTU Discovery - Yes
    Black Hole Detect - No
    Selective Acks - Yes
    Max Duplicate ACKs - 2
    TCP 1323 Options:
    Windows Scaling - checked
    Timestamps - uncheck

    Advanced Settings tab:
    Max Connections per Server - 10
    Max Connections per 1.0 Server - 20
    LocalPriority - 1
    Host Priority - 1
    DNSPriority - 1
    NetbtPriority - 1
    Lan Browsing speedup - optimized
    QoS: NonBestEffortLimit - 0
    ToS: DisableUserTOSSetting - 0
    ToS: DefaultTOSValue - 0
    MaxNegativeCacheTtl - 0
    NetFailureCacheTime - 0
    NegativeSOACache Time - 0
    LAN Request Buffer Size - 32768
    Then select "Apply Changes" and reboot to take effect
    "Contentment is not the fulfillment of what you want, but is the realisation of how much you already have" - anon

  15. #15
    Junior Member
    Join Date
    Apr 2008
    Posts
    7
    Quote Originally Posted by trogers View Post
    Do you have a Rev A card to take advantage of the increased speed when your ISP upgrade to Rev A?

    http://evdoinfo.blogspot.com/2007/03...vdo-rev-0.html
    Yep. UM150 is RevA ready.

    Quote Originally Posted by trogers View Post
    One more thing to try. See if a lower MTU with solve the problem of packet losses when RWIN is above 65535.

    Try the following with TCP Optimizer:

    General Settings tab:
    Custom settings - check
    Modify All Network Adapters - check
    network adapter selection - your NIC
    MTU - 1440
    TTL - 64
    TCP Receive Window - 128800
    MTU Discovery - Yes
    Black Hole Detect - No
    Selective Acks - Yes
    Max Duplicate ACKs - 2
    TCP 1323 Options:
    Windows Scaling - checked
    Timestamps - uncheck

    Advanced Settings tab:
    Max Connections per Server - 10
    Max Connections per 1.0 Server - 20
    LocalPriority - 1
    Host Priority - 1
    DNSPriority - 1
    NetbtPriority - 1
    Lan Browsing speedup - optimized
    QoS: NonBestEffortLimit - 0
    ToS: DisableUserTOSSetting - 0
    ToS: DefaultTOSValue - 0
    MaxNegativeCacheTtl - 0
    NetFailureCacheTime - 0
    NegativeSOACache Time - 0
    LAN Request Buffer Size - 32768
    Then select "Apply Changes" and reboot to take effect
    I'll try that in a minute and edit in my results, but looking at previous tests it probably won't work.

    Also I managed to get 98KB/sec on my current settings. I think I'm getting the speeds I should, but the network is bottlenecking me due to their "improved" changes.

  16. #16
    Junior Member
    Join Date
    Apr 2008
    Posts
    7
    Sorry for the wait.

    Setting MTU to 1440 didn't do anything. Still get packet loss.

Similar Threads

  1. WRTSL54GS Wireless Speed Drop v/s Wired Comparision
    By Alterego in forum Wireless Networks & Routers
    Replies: 0
    Last Post: 10-06-07, 03:04 AM
  2. Tweak my EV-DO wireless connection
    By rockypr70 in forum Broadband Tweaks Help
    Replies: 1
    Last Post: 07-28-07, 11:58 AM
  3. Suggestions for Tweak Settings
    By skat325is in forum Broadband Tweaks Help
    Replies: 11
    Last Post: 05-14-07, 10:22 PM
  4. Linksys WRT54G and Intel PRO Wireless 2200 : Connection Drops
    By Alterego in forum Wireless Networks & Routers
    Replies: 0
    Last Post: 05-10-07, 12:59 PM
  5. Because of my wireless card or the wireless network??
    By Mahalo in forum Wireless Networks & Routers
    Replies: 3
    Last Post: 04-17-07, 02:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •