Results 1 to 8 of 8

Thread: 2001 Mitsubishi Eclipse question

  1. #1
    mikemean's Avatar
    Join Date
    Nov 2000
    Location
    406
    Posts
    8,705

    2001 Mitsubishi Eclipse question

    The man bought one and the horn does not work. All we get is a clicking sound when hitting the horn. checked the fuses and whatnot and they are ok. Any ideas?

  2. #2
    Forum Techie A_old's Avatar
    Join Date
    Jan 2000
    Location
    Atlanta
    Posts
    10,663

  3. #3
    Jen's Best Friend RoscoPColtrane's Avatar
    Join Date
    Sep 2000
    Location
    Fort Worth, Texas
    Posts
    6,154
    First step, sell it and buy and American made car!



    ****************************************************************************************
    Abit NF7-S 2.0, Barton 2500+ @ 2.2 Ghz, 2 Gig ddr3200, 80gig Seagate HDD, ATI x850 PRO @ 550/600, WinXP Pro

    J B K M

    Pittsburgh Steelers Super Bowl XL Champions!!!!!

  4. #4
    Senior Member fastchevy's Avatar
    Join Date
    Jan 2001
    Location
    OKC
    Posts
    6,963
    If the fuses are OK and any relays then put a volt meter up to the hot of the horn wiring and ground the other one...have someone hit the horn button and if you get 12v it's the horn itself.
    .

  5. #5
    TypicalWhitePerson JC's Avatar
    Join Date
    Oct 2000
    Location
    Single Wide
    Posts
    4,560
    I think this needs to be moved to the automotive forum
    Speedguide.... If you don't love Obama you won't like it here.
    Straight out the Trailer!
    Re.....Spect "walk"!

    MacBook Pro 2.33Ghz, 3G of Ram, OS X

  6. #6
    resident plumber Mark's Avatar
    Join Date
    Apr 2001
    Location
    .
    Posts
    13,148
    voltmeter to the wires leading into the horns, see if you are getting voltage, if so, replace horn, if not, search further.

  7. #7
    Message from my son:

    If it is not getting voltage, it is in the airbag because the horn and the airbag is one unit. If you are getting voltage, than it is the horn.

    He said to make sure you have good ground. When you press the horn pad, it make a ground which sets off the horn. Make sure the horn pad is making good contact. It is when it makes the ground that the horn works.
    Last edited by Debbie; 03-23-08 at 09:09 PM.

  8. #8
    mikemean's Avatar
    Join Date
    Nov 2000
    Location
    406
    Posts
    8,705
    We will give that a shot. Thanks

Similar Threads

  1. Student Tazered at John Kerry Speech
    By Kyle in forum General Discussion Board
    Replies: 131
    Last Post: 09-22-07, 12:21 AM
  2. Bsod <-- Please Help
    By Sonic_X in forum Software Forum
    Replies: 7
    Last Post: 06-13-07, 03:47 AM
  3. Ask a stupid question, get a stupid answer
    By Chris in forum General Discussion Board
    Replies: 97
    Last Post: 09-06-06, 07:32 AM
  4. 2006 Mitsubishi Eclipse Ralliart AWD 4g63 Nasty....
    By tHE_0ne in forum General Discussion Board
    Replies: 8
    Last Post: 12-08-05, 06:18 AM
  5. 2006 Mitsubishi Eclipse
    By minir in forum General Discussion Board
    Replies: 15
    Last Post: 05-16-05, 04:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •