Results 1 to 8 of 8

Thread: Generic Host Process for Win32 Services

  1. #1
    Junior Member
    Join Date
    May 2007

    Unhappy Generic Host Process for Win32 Services

    Okay, I better make this quick before the error occur's again! (EDIT - Alright then, it already has so I'll write the rest of this in WordPad...)

    So after about 1-20 mintues of going online I get the error: "Generic Host Process for Win32 Services" followed by my internet being disconnected without the ability to get back online until I restart my computer. Another weird thing that happen's is that my Windows goes all... old-skool for a few seconds. The menu bars loose their shiny effect and go all grey.

    This is pretty infuriating and I can see there are actually loads of other people suffering from the same thing. In fact, I looked at the other thread and followed some of the instructions (downloaded Ad-Aware, SpyBlaster, SpyBot Search) and managed to get rid of a few suspicious things (AdWare removed several 'worms') but still the problem remain's.

    Please help me sort out this nightmare! I tried downloading the 'HiJack' but couldn't seem to get up the info I need. It said I had unzipped the file but then nothing else happened. Could you please tell me exactly how to retrieve it?

    Thank you!

  2. #2

  3. #3
    Junior Member
    Join Date
    May 2007

    Thumbs up

    Thanks for the tips mnosteele52.

    I've downloaded the first 2 things but don't know how to do a Microsoft update or how to reboot my PC! Will rebooting my computer delete anything?

    Also, I've ran the HiJack thing as well just in case and got this:

    Logfile of Trend Micro HijackThis v2.0.0 (BETA)
    Scan saved at 10:18:34, on 17/05/2007
    Platform: Windows XP SP2 (WinNT 5.01.2600)
    Boot mode: Normal

    Running processes:
    C:\Program Files\Common Files\AOL\ACS\AOLAcsd.exe
    C:\Program Files\Common Files\AOL\ACS\AOLDial.exe
    C:\Program Files\Common Files\Real\Update_OB\realsched.exe
    C:\Program Files\iTunes\iTunesHelper.exe
    C:\Program Files\QuickTime\qttask.exe
    C:\Program Files\Thomson\SpeedTouch USB\Dragdiag.exe
    C:\Program Files\MSN Messenger\MsnMsgr.Exe
    C:\Program Files\iPod\bin\iPodService.exe
    C:\Program Files\Internet Explorer\iexplore.exe
    C:\Program Files\Internet Explorer\iexplore.exe
    C:\Documents and Settings\Patrick\Local Settings\Temporary Internet Files\Content.IE5\J2M8J5P4\HiJackThis_v2[1]\HiJackThis_v2.exe

    R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page =
    R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = file://C:\APPS\IE\offline\uk.htm
    R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Window Title = Packard Bell
    O2 - BHO: Yahoo! Toolbar Helper - {02478D38-C3F9-4EFB-9B51-7695ECA05670} - C:\Program Files\Yahoo!\Companion\Installs\cpn\yt.dll
    O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 6.0\Reader\ActiveX\AcroIEHelper.dll
    O2 - BHO: (no name) - {53707962-6F74-2D53-2644-206D7942484F} - C:\Program Files\Spybot - Search & Destroy\SDHelper.dll
    O3 - Toolbar: (no name) - {BA52B914-B692-46c4-B683-905236F6F655} - (no file)
    O3 - Toolbar: AOL Toolbar - {4982D40A-C53B-4615-B15B-B5B5E98D167C} - C:\Program Files\AOL Toolbar\toolbar.dll
    O3 - Toolbar: Yahoo! Toolbar - {EF99BD32-C1FB-11D2-892F-0090271D4F88} - C:\Program Files\Yahoo!\Companion\Installs\cpn\yt.dll
    O4 - HKLM\..\Run: [AOLDialer] C:\Program Files\Common Files\AOL\ACS\AOLDial.exe
    O4 - HKLM\..\Run: [TkBellExe] "C:\Program Files\Common Files\Real\Update_OB\realsched.exe" -osboot
    O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files\iTunes\iTunesHelper.exe"
    O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\qttask.exe" -atboottime
    O4 - HKLM\..\Run: [SpeedTouch USB Diagnostics] "C:\Program Files\Thomson\SpeedTouch USB\Dragdiag.exe" /icon
    O4 - HKCU\..\Run: [Regscan] C:\WINDOWS\system32\regscan.exe
    O4 - HKCU\..\Run: [explorer] C:\WINDOWS\system32\services\explorer.exe
    O4 - HKCU\..\Run: [MsnMsgr] "C:\Program Files\MSN Messenger\MsnMsgr.Exe" /background
    O4 - HKCU\..\Policies\Explorer\Run: [1] C:\WINDOWS\system32\service\explorer.exe
    O4 - HKUS\S-1-5-19\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\CTFMON.EXE (User 'LOCAL SERVICE')
    O4 - HKUS\S-1-5-20\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\CTFMON.EXE (User 'NETWORK SERVICE')
    O4 - HKUS\S-1-5-18\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\CTFMON.EXE (User 'SYSTEM')
    O4 - HKUS\.DEFAULT\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\CTFMON.EXE (User 'Default user')
    O8 - Extra context menu item: &AOL Toolbar search - res://C:\Program Files\AOL Toolbar\toolbar.dll/SEARCH.HTML
    O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~3\OFFICE11\EXCEL.EXE/3000
    O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\WINDOWS\system32\msjava.dll
    O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\WINDOWS\system32\msjava.dll
    O9 - Extra button: AOL Toolbar - {4982D40A-C53B-4615-B15B-B5B5E98D167C} - C:\Program Files\AOL Toolbar\toolbar.dll
    O9 - Extra 'Tools' menuitem: AOL Toolbar - {4982D40A-C53B-4615-B15B-B5B5E98D167C} - C:\Program Files\AOL Toolbar\toolbar.dll
    O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~3\OFFICE11\REFIEBAR.DLL
    O9 - Extra button: - {CD67F990-D8E9-11d2-98FE-00C0F0318AFE} - C:\WINDOWS\system32\Shdocvw.dll
    O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
    O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
    O14 - IERESET.INF: START_PAGE_URL=file://C:\APPS\IE\offline\uk.htm
    O15 - Trusted Zone:
    O15 - Trusted Zone:
    O16 - DPF: RaptisoftGameLoader -
    O16 - DPF: {17492023-C23A-453E-A040-C7C580BBF700} (Windows Genuine Advantage Validation Tool) -
    O16 - DPF: {1D6711C8-7154-40BB-8380-3DEA45B69CBF} -
    O16 - DPF: {4F1E5B1A-2A80-42CA-8532-2D05CB959537} (MSN Photo Upload Tool) -
    O16 - DPF: {55027008-315F-4F45-BBC3-8BE119764741} (Slide Image Uploader Control) -
    O16 - DPF: {BFF1950D-B1B4-4AE8-B842-B2CCF06D9A1B} (Zylom Games Player) -
    O17 - HKLM\System\CCS\Services\Tcpip\..\{EE5315CB-EB0A-4027-98F3-D7F2DCA5BCF3}: NameServer =
    O22 - SharedTaskScheduler: Browseui preloader - {438755C2-A8BA-11D1-B96B-00A0C90312E1} - C:\WINDOWS\system32\browseui.dll
    O22 - SharedTaskScheduler: Component Categories cache daemon - {8C7461EF-2B13-11d2-BE35-3078302C2030} - C:\WINDOWS\system32\browseui.dll
    O23 - Service: AOL Connectivity Service (AOL ACS) - America Online, Inc. - C:\Program Files\Common Files\AOL\ACS\AOLAcsd.exe
    O23 - Service: AOL Spyware Protection Service (AOLService) - Unknown owner - C:\PROGRA~1\COMMON~1\AOL\AOLSPY~1\\aolserv.exe
    O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - C:\Program Files\Common Files\InstallShield\Driver\11\Intel 32\IDriverT.exe
    O23 - Service: iPodService - Apple Computer, Inc. - C:\Program Files\iPod\bin\iPodService.exe
    O23 - Service: LexBce Server (LexBceS) - Lexmark International, Inc. - C:\WINDOWS\system32\LEXBCES.EXE
    O23 - Service: SmartLinkService (SLService) - - C:\WINDOWS\SYSTEM32\slserv.exe

    End of file - 6517 bytes

  4. #4
    Dr Tweak mnosteele52's Avatar
    Join Date
    Jul 2001
    Chesapeake, VA
    Your log is clean...... and your kidding about not knowing how to reboot your pc right? (start button - shutdown - restart)

    Windows updates..... start button - Windows Update.

  5. #5
    Junior Member
    Join Date
    May 2007


    Oh god, I wasn't sure whether 'reboot' meant the same thing as 'restart'. How embarassing...

    Ah, finally able to post again! I followed your advice and, would you believe, I haven't seen the error again!! The bad news was it was replaced with an equally bad problem - the abilty to surf the web but not being able to type ANYWHERE, certain things not showing up and the message: "Done, but with errors on the page" written in the corner of the screen.

    So I was generally like: "oh **** it" until I tried ditching IE and getting Firefox2 and it seem's, touch wood, things have worked out.

    There is one last thing though. Now when I try to run basic things such as the help option in my Windows, I get an error message saying I don't have: MSIMG32.dll, and won't let me continue. Do you know what's up with that?

  6. #6
    Dr Tweak mnosteele52's Avatar
    Join Date
    Jul 2001
    Chesapeake, VA
    Your missing some Windows files, you need to insert your XP cd into one of your cdroms and go to start - run and type sfc /scannow this will replace any missing or corrupt system files.

  7. #7
    Junior Member MadDoctor's Avatar
    Join Date
    Apr 2001
    Looks dark
    *taking notes*
    People will forget what you said... and people will forget what you did... but people will never forget how you made them feel.

  8. #8
    Junior Member
    Join Date
    May 2007
    Quote Originally Posted by mnosteele52 View Post
    Your missing some Windows files, you need to insert your XP cd into one of your cdroms and go to start - run and type sfc /scannow this will replace any missing or corrupt system files.

    Hi again mnosteele. Thanks for your help earlier.

    I actually can't seem to find my XP disc anywhere. Is there anything I can do?

Similar Threads

  1. DSL Connection dropping randomly
    By Tomdanizer in forum General Broadband Forum
    Replies: 22
    Last Post: 07-17-11, 02:08 AM
  2. Replies: 88
    Last Post: 07-16-11, 12:23 PM
  3. Generic Host Process for Win32 Services internet shutdown
    By magus1992 in forum General Broadband Forum
    Replies: 2
    Last Post: 11-01-09, 02:31 PM
  4. Replies: 6
    Last Post: 07-23-07, 03:40 PM
  5. Generic Host Process for Win32 Services encountered a problem
    By kingcobra370 in forum Software Forum
    Replies: 2
    Last Post: 02-10-07, 03:14 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts