Hello All,

I actually did a fair amount of troubleshooting myself and came to know a strange error. I am running HP Pavillion Dv1000 with Dual Boot Windows XP SP2 and Ubuntu Linux 6.04 with Intel PRO/Wireless BG 2200 LAN Adapter.

The main problem lies with my Intel PRO/Wireless BG 2200 LAN card running under Windows XP SP2. It was working fine as far as I remember in the workplace. Since I bought a WRT54G for my home and tried to connect, I got to know an interesting fact. I checked its properties under device manager in Windows, it shows a MAC Address of 00:00:00:00:00:00, which is quite strange. It had a vaild MAC address the last time I used, but i dont know which software bug is causing this error now. Thats the reason that my LAN card can see the wireless network, but when I try connecting to it, it simply does not connects and obtains an IP address.

I tried checking this Intel PRO/Wireless BG 2200 by swapping it with my friends laoptop having the same one, and it works fine with his laptop and is able to connect to the wireless network. Unfortunately my friends same Intel PRO/Wireless BG 2200 is now showing the same MAC Address of 00:00:00:00:00:00 when used in my laptop.

The Intel PRO/Wireless BG 2200 works just fine when used within linux and displays the correct MAC address and is able to connect to my home wireless network.

I have tried uninstalling and updating all the drivers for Windows, both from my laptop's and Intel's website, but in vain. Having everything updated, I am unable to get the correct MAC address and thus to be able to connect under Windows.

Another thing which popped up in my mind is that, is it possible to somehow disable this MAC address of Wireless LAN Adapter in windows using any Group Policy Settings. Since with my current laptop I do log on to the WIRED network at my workplace domain and all the necessary domain policies are applied to it.

Any clue would be certainly appreciated for any encountering similar problem.