I have been accessing my webserver via my cable IP http://xx.xx.xx.xx/ (public) for over 12 months now, and have had no problems. About 4 days ago, it suddenly stopped working which is a major problem for me.

Without a router, I can access it fine, and with/without, I can access it fine if I use localhost or my private IP.

I'm using a Linksys BEFSR41 (v1). Basically my only real configuration to have it working was to forward port 80 to my private IP (192.168.1.100). After spending about 4 hours playing with the configuration and going crazy (including resetting factory defaults) I decided to buy a new one.

OK, this is where it got fun. Unfortunately only London Drugs was open, so I bought another Linksys (v3.1 this time). I was a little hesitant, but the only other brand they carried was D-Link. I went home, plugged it in, and within 15 seconds it disconnected. 5 minutes later, it reconnected, and then another few seconds later, connection lost. (repeat for 2 hours).

I plugged the old router back in... tried just about everything 3-4 times, triple checked all the IP addresses and ports, and it's all 100%. Just for kicks, I tried hooking up my D-Link wireless (using wired connection though) router, and strangely, the same thing happens.

How can I get this working?

summary

http://my.shaw.ip/ USED TO WORK with/without router

but now...

http://localhost/ WORKS
http://192.168.1.100/ WORKS

http://my.shaw.IP/ WORKS without routers
http://my.shaw.IP/ does NOT work with routers

Port 80 (TCP/UPD) is forwarded to 192.168.1.100
(I have also tried DMZ host, but no luck)

Any help would greatly be appreciated, before I begin smashing things...