Results 1 to 9 of 9

Thread: HELP! MTU limited to 1300

  1. #1

    HELP! MTU limited to 1300

    Hi there,

    since I updated my Fritz!Box Fon 7170 to the newest Firmware Version (29.04.29) and reinstalled Windows XP my MTU ist limited to 1300.
    I modified the MTU some months ago and there were no problems doing that.
    I used cablenut and the TCP-Optimizer.
    Beceause all MTU changes didn't take affect now, I tried the cFos Speed. But no change as well. Maybe it is the router, which is limiting my MTU? I tried to logon it via telnet but failed to do that. Maybe someone knows how to help me.

    Im not using any Firewall accept the one included by AVM and have AdAware and AntiVir installed.

    Thanks, Jan

    My TCP/IP Analyzer results:

    TCP options string = 020404ec0103030401010402
    MTU = 1300
    MTU is not fully optimized for broadband. Consider increasing your MTU to 1500 for better throughput. If you are using a router, it could be limiting your MTU regardless of Registry settings.

    MSS = 1260
    MSS is not optimized for broadband. Consider increasing your MTU value.

    Default TCP Receive Window (RWIN) = 827632
    RWIN Scaling (RFC1323) = 4 bits (scale factor of 8)
    Unscaled TCP Receive Window = 51727

    For optimum performance, consider changing RWIN to a multiple of MSS.
    Other RWIN values that might work well with your current MTU/MSS:
    524160 (MSS x 52 * scale factor of 8)
    262080 (MSS x 52 * scale factor of 4)
    131040 (MSS x 52 * scale factor of 2)
    65520 (MSS x 52)
    bandwidth * delay product (Note this is not a speed test):

    Your TCP Window limits you to: 33105 kbps (4138 KBytes/s) @ 200ms
    Your TCP Window limits you to: 13242 kbps (1655 KBytes/s) @ 500ms
    MTU Discovery (RFC1191) = ON
    Time to live left = 55 hops
    TTL value is ok.
    Timestamps (RFC1323) = OFF
    Selective Acknowledgements (RFC2018) = ON
    IP type of service field (RFC1349) = 00000000 (0)

  2. #2


    Another thing I just recognized is that my upload rate sank to only 56 kByte/s.
    I had more than 1 MBit before. I've got ADSL2+ 16000, but can only reach about 12Mbits. I reckon this is because I've got two TAEs. My ISP is 1&1. Maybe that's why my ping is so high at online games?!

  3. #3
    I could just fix the problems with the speed. Had some bad configurations in firefox. So the up- and download is fine again.
    But I still couldn't fix my MTU. Tried it with TuneUp Utilities but the programm is **** for network configurations.

    Hope to get some help soon!


  4. #4
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Bangkok, Thailand
    What brand and model of router are you using?

    Use the following with TCP Optimizer:

    General Settings tab:
    Custom settings - check
    Modify All Network Adapters - check
    network adapter selection - your NIC
    MTU - 1500
    TTL - 64
    TCP Receive Window - leave blank
    MTU Discovery - Yes
    Black Hole Detect - No
    Selective Acks - Yes
    Max Duplicate ACKs - 2
    TCP 1323 Options:
    Windows Scaling - checked
    Timestamps - uncheck

    Advanced Settings tab:
    Max Connections per Server - 10
    Max Connections per 1.0 Server - 20
    LocalPriority - 1
    Host Priority - 1
    DNSPriority - 1
    NetbtPriority - 1
    Lan Browsing speedup - optimized
    QoS: NonBestEffortLimit - 0
    ToS: DisableUserTOSSetting - 0
    ToS: DefaultTOSValue - 80
    MaxNegativeCacheTtl - 0
    NetFailureCacheTime - 0
    NegativeSOACache Time - 0
    LAN Request Buffer Size - 32768
    Then select "Apply Changes" and reboot to take effect

  5. #5
    I don't think its about those settings, but I will try it anayway.

    I'm using an AVM Fritz!Box Fon WLAN 7170.

  6. #6
    Yeah, my MTU is still the same, 1300.

    I heard if its the router u can connect to it via telnet and change the value?! But I am not sure about that. I tried to change the values directly in the registry, but no affect.

  7. #7
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Bangkok, Thailand
    This is a German-made product? Here is a link where you may find out how to get into web admin:

  8. #8
    Thanks, but i already got all the software and its updates. It's german by the way. It's not possible to change the MTU in the Fritz!Box control center.
    That's why I tried to connect via telnet to it. Thought there might be some more options to alter.

  9. #9
    I dont knwo why, but my MTU is back on 1492 again. Juhuu!

Similar Threads

  1. MTU & MSS give back different results ....
    By geo g in forum Broadband Tweaks Help
    Replies: 1
    Last Post: 09-18-06, 02:26 AM
  2. MTU question !
    By 100 010 00 in forum Broadband Tweaks Help
    Replies: 7
    Last Post: 06-11-06, 08:46 AM
  3. , Not showing correct MTU ???
    By speedms in forum General Broadband Forum
    Replies: 0
    Last Post: 03-12-06, 11:08 AM
  4. d-link dwl-520+ and MTU 1300
    By ssgatbliss in forum Wireless Networks & Routers
    Replies: 0
    Last Post: 06-17-05, 09:07 AM
  5. MTU limited to 1448
    By daledann in forum Broadband Tweaks Help
    Replies: 5
    Last Post: 04-18-05, 09:28 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts