Results 1 to 3 of 3

Thread: EnablePMTUDiscovery Question & MTU of 1492 Question

  1. #1

    EnablePMTUDiscovery Question & MTU of 1492 Question

    A while back I posted a few questions about the calculations for RWIN. It worked great at the time and to top it off, it actually worked better with an MTU of 1454 as opposed to PPPoE DSL's MTU of 1492. However, within a couple of weeks, my connection problems started up, slow page loads, lags in logging onto instant messaging, and so on (although when I downloaded large files, they kept a good 300+K/sec sustained download rate). So today, I decided once more to try 1492 and a new RWIN of 63888. Pages are way snappier in loading and I do not get any lags as I did before. However, I have one unusual quirk in that when I try to load Outlook Express, the initial attempt to contact the mail server yields a condition that causes Outlook Express to think I am offline. It then blinks on a message, "Work offline or try again?" Trying again makes it connect just fine, although that particular error message is unusual and something I never received when using an MTU of 1454. Oddly enough, I also get that error using pretty much all other major variants of MTU size > 1400 except 1454. Not that it's a major issue, it just seems odd and to me indicates something else underlying my connection that is causing it to not be optimal.

    And lastly, my question about EnablePMTUDiscovery. What relevance does this registry DWORD have on my connections to web servers? Currently, I have it disabled and am forcing Windows to use an MTU of 1492 regardless of the server. However, could this cause problems where servers are unable to use that size MTU? But on a similar token, does the extra overhead to detect the MTU of a server reduce internet performance?

  2. #2
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    Quote Originally Posted by singularity2006 View Post
    And lastly, my question about EnablePMTUDiscovery. What relevance does this registry DWORD have on my connections to web servers? Currently, I have it disabled and am forcing Windows to use an MTU of 1492 regardless of the server. However, could this cause problems where servers are unable to use that size MTU? But on a similar token, does the extra overhead to detect the MTU of a server reduce internet performance?
    Outlook Express links you directly to the mail server of your ISP. Is this server using MTU set to 1454, and thus have a problem in establishing a proper TCP handshake with your comp since you have turned off PMTUDiscovery?

    That is the prime purpose of PMTUDiscovery. Not all comps and ISPs use one single MTU value. With the PMTUDiscovery turned off, there will not be a proper TCP handshake and agreed TCP Protocols. The extra overhead is negiligble compared to connections stalling.

  3. #3
    Quote Originally Posted by trogers View Post
    Outlook Express links you directly to the mail server of your ISP. Is this server using MTU set to 1454, and thus have a problem in establishing a proper TCP handshake with your comp since you have turned off PMTUDiscovery?

    That is the prime purpose of PMTUDiscovery. Not all comps and ISPs use one single MTU value. With the PMTUDiscovery turned off, there will not be a proper TCP handshake and agreed TCP Protocols. The extra overhead is negiligble compared to connections stalling.
    Thanks for the information. I'll implement that into our network and see its effect. :]

Similar Threads

  1. Jumbo MTU Question
    By hudson in forum Broadband Tweaks Help
    Replies: 7
    Last Post: 08-16-06, 08:06 PM
  2. MTU question !
    By 100 010 00 in forum Broadband Tweaks Help
    Replies: 7
    Last Post: 06-11-06, 08:46 AM
  3. speedguide.net/analyzer.php , Not showing correct MTU ???
    By speedms in forum General Broadband Forum
    Replies: 0
    Last Post: 03-12-06, 11:08 AM
  4. 1492 or 1480 question
    By lacrosnu123 in forum Broadband Tweaks Help
    Replies: 3
    Last Post: 03-26-05, 09:57 AM
  5. Netgear WGT624v2 MTU Problem With PPPoE
    By patinsj in forum Broadband Tweaks Help
    Replies: 1
    Last Post: 02-19-05, 12:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •