I am trying to get a VPN solution running for a company and am having issues with the basic services that the old DSL router gave them and not the VPN connections. They require above all Win Live messenger functionality, I have spoken to the seller of the Cisco router and he sent me an ios that supports it, well this still didnt work. Does anyone know if this can work and can I not use the latest ios as the one he gave me is buggy and is claimed to be insecure.

IOS I am using is: c837-k9o3y6-mz.124-12

And my config:

no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname poofie
!
boot-start-marker
boot-end-marker
!
enable secret 5 mmmm
!
no aaa new-model
!
resource policy
!
ip dhcp excluded-address 192.168.70.111
!
!
ip cef
ip domain name mmmmm
ip name-server 1.1.1.1
ip name-server 1.1.1.1
ip ddns update method if
HTTP
add http://kkkkkorg/nic/update?system=dy...fhip.net&myip=
!
!
!
!
username icb privilege 15 secret 5 kkkkkkk.
!
!
!
!
!
interface Ethernet0
ip address 1.1.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
hold-queue 100 out
!
interface Ethernet2
no ip address
shutdown
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
pvc 8/35
pppoe-client dial-pool-number 2
!
!
interface FastEthernet1
duplex auto
speed auto
!
interface FastEthernet2
duplex auto
speed auto
!
interface FastEthernet3
duplex auto
speed auto
!
interface FastEthernet4
duplex auto
speed auto
!
interface Dialer1
ip ddns update hostname blah.net
ip ddns update if host members.dyndns.org
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 2
ppp authentication chap callin
ppp chap hostname telkomsa.net
ppp pap sent-username vvvvvvv@blahblah.telkomsa.net password 7 kkkkkkk0E0F
!
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
ip http access-class 1
ip http authentication local
no ip http secure-server
ip http max-connections 4
ip http timeout-policy idle 600 life 86400 requests 10000
!
ip nat inside source list 101 interface Dialer1 overload
ip nat inside source static tcp 1.1.1.1 443 interface Dialer1 443
ip nat inside source static tcp 1.1.1.1 80 interface Dialer1 80
ip nat inside source static tcp 1.1.1.1 25 interface Dialer1 25
!
access-list 1 permit 1.1.1.0 0.0.0.255
access-list 23 permit 1.1.1.0 0.0.0.255
access-list 101 permit ip 1.1.1.0 0.0.0.255 any
tftp-server 1.1.1.25
!
control-plane
!
!
line con 0
exec-timeout 120 0
login local
no modem enable
stopbits 1
line aux 0
line vty 0 4
access-class 1 in
exec-timeout 120 0
privilege level 15
login local
length 0
transport input ssh
!
scheduler max-task-time 5000
end

I have not included the VPN parts as it is not nesassary, I do inspect and add the line "ip inspect (name) out" to the dialer interface. I allso allow the ports through the dialer interface.
The access list to allow access is also added to the ethernet 0 interface.

Any help greatly appr.