Page 1 of 2 12 LastLast
Results 1 to 20 of 38

Thread: new provider slow download speed

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Junior Member
    Join Date
    May 2006
    Posts
    11

    new provider slow download speed

    hello im new to this so i may sound a little dumb

    Ive just switched to pipex and was promised a 4 meg connection hesres what im getting (previous tests)

    2006.11.14 17:23 1170 kbps [146KB/s] 354 kbps [44KB/s] Stevenage, UK dsl.pipex.com host-easy.co.uk FDB96QYAWL1
    2006.11.14 13:55 1240 kbps [155KB/s] 354 kbps [44KB/s] Stevenage, UK dsl.pipex.com host-easy.co.uk 0YCATCW728Y
    2006.11.14 13:46 1137 kbps [142KB/s] 354 kbps [44KB/s] Stevenage, UK dsl.pipex.com host-easy.co.uk MJ3PFU6M3XC
    2006.11.14 13:22 1931 kbps [241KB/s] 367 kbps [46KB/s] Stevenage, UK dsl.pipex.com host-easy.co.uk VXJHXJALIZ9

    Now i realise that as this is a new connection (ive only had it one day) it needs 10 days to "settle in" so my speeds will vary (thay have been as low as 330kbps)

    so is this normal? will i ever get my promised 4mbps? or is 2 all i can hope for?

    another thing , whatever my connection speed is when i try to download a file such as a game demo or graphics card drivers my download speed 24kb/s and has even been as low as 1.24kb/s!!

    i was getting 58kb/s with my 512 connection i dont know whats wrong , can anyone suggest a solution? ringing my isp takes over half an hour just to get through

    i dont know if i need to change any settings i assumed it would all be managed by the software i installed.

    i have a speedtouch 330 usb adsl modem

    if you need any more info ill be glad to supply it

    many thanks

    Darren

  2. #2
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    Whether you will get the 4 mbps depends much on how far you are from the central office of the ISP.

    I am located more than 3 km from my ISP's CO and my ISP can only offer me a 1 mbps line from their max 4 mbps service, but they are honest enough to charge me for a 1 mbps line.

    If you are located near enough to the CO (within a mile), your speed may be restricted by a small RWIN. Do the TCP Analyzer test and post the results.

  3. #3
    Junior Member
    Join Date
    May 2006
    Posts
    11
    thank you

    my other problem is terrible download speeds , if i goto microsofts own download section i get around 130-150kb/s as i would expect , but if i go anywhre else , nvidia drivers , game demos even this site my dowload speed is 30-40 kb/s??? I dont know why all the sites ive tested i used before when i had a 512 conn and my speeds were around 56kb/s as youd expect.

    why when i do a speed test (i assume you d/l and upload a file during these) does my connection show up fine but when i try to download any other type of file its terrible

    please help

    thank you

  4. #4
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    Do the TCP Analyzer test and post the results.

  5. #5
    Junior Member
    Join Date
    May 2006
    Posts
    11
    thank you for your help

    TCP options string = 020405b4

    MTU = 1500
    MTU is fully optimized for broadband.

    MSS = 1460
    Maximum useful data in each packet = 1460, which equals MSS.

    Default TCP Receive Window (RWIN) = 17520
    RWIN Scaling (RFC1323) = 0 bits
    Unscaled TCP Receive Window = 17520

    RWIN is a multiple of MSS
    Other RWIN values that might work well with your current MTU/MSS:
    513920 (MSS x 44 * scale factor of 8)
    256960 (MSS x 44 * scale factor of 4)
    128480 (MSS x 44 * scale factor of 2)
    64240 (MSS x 44)

    bandwidth * delay product (Note this is not a speed test):

    Your TCP Window limits you to: 700.8 kbps (87.6 KBytes/s) @ 200ms
    Your TCP Window limits you to: 280.32 kbps (35.04 KBytes/s) @ 500ms
    Consider increasing your RWIN value to optimize TCP/IP for broadband.

    MTU Discovery (RFC1191) = ON

    Time to live left = 124 hops
    TTL value is ok.

    Timestamps (RFC1323) = OFF
    Selective Acknowledgements (RFC2018) = OFF
    IP type of service field (RFC1349) = 00000000 (0)

    i dont know what any of this means

  6. #6
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    Your RWIN at 17520 is too low for a 4 mbps bandwidth.

    Use the TCP Optimizer with these custom settings:

    General Settings tab:
    Custom settings - check
    Modify All Network Adapters - check
    network adapter selection - your NIC
    MTU - 1500
    TTL - 64
    TCP Receive Window - 128480
    MTU Discovery - Yes
    Black Hole Detect - No
    Selective Acks - Yes
    Max Duplicate ACKs - 2
    TCP 1323 Options:
    Windows Scaling - checked
    Timestamps - uncheck
    Advanced Settings tab:
    Max Connections per Server - 10
    Max Connections per 1.0 Server - 20
    LocalPriority - 5
    Host Priority - 6
    DNSPriority - 7
    NetbtPriority - 8
    Lan Browsing speedup - optimized
    QoS: NonBestEffortLimit - 0
    ToS: DisableUserTOSSetting - 0
    ToS: DefaultTOSValue - 136
    MaxNegativeCacheTtl - 0
    NetFailureCacheTime - 0
    NegativeSOACache Time - 0
    LAN Request Buffer Size - 32768
    Then select "Apply Changes" and reboot to take effect

  7. #7
    Junior Member
    Join Date
    May 2006
    Posts
    11
    mate thank you VERY much for your time

    I have to goto work now , ill do as you ask tonight and ill report back and let you know how i got on

    Thank you

  8. #8
    Junior Member
    Join Date
    Nov 2006
    Posts
    18
    Ive the same problem my BB with pipex connects at 4.5 mb but my downloads are totally crap, i run a CAT5 cable from my modem direct to the wall socket and only average about 120kpb/s downloads.

    I tried the settings posted above and this is now my new read out..

    TCP options string = 020405b40103030101010402
    MTU = 1500
    MTU is fully optimized for broadband.
    MSS = 1460
    Maximum useful data in each packet = 1460, which equals MSS.
    Default TCP Receive Window (RWIN) = 128480
    RWIN Scaling (RFC1323) = 1 bits (scale factor of 2)
    Unscaled TCP Receive Window = 64240

    RWIN is a multiple of MSS
    Other RWIN values that might work well with your current MTU/MSS:
    513920 (MSS x 44 * scale factor of 8)
    256960 (MSS x 44 * scale factor of 4)
    128480 (MSS x 44 * scale factor of 2) <-- current value
    64240 (MSS x 44)
    bandwidth * delay product (Note this is not a speed test):

    Your TCP Window limits you to: 5139.2 kbps (642.4 KBytes/s) @ 200ms
    Your TCP Window limits you to: 2055.68 kbps (256.96 KBytes/s) @ 500ms
    MTU Discovery (RFC1191) = ON
    Time to live left = 50 hops
    TTL value is ok.
    Timestamps (RFC1323) = OFF
    Selective Acknowledgements (RFC2018) = ON
    IP type of service field (RFC1349) = 01000000 (64)
    Precedence (priority) = 010 (immediate)
    Delay = 0 (normal delay)
    Throughput = 0 (normal throughput)
    Reliability = 0 (normal reliability)
    Cost = 0 (normal cost)
    Check bit = 0 (correct, 8th checking bit must be zero)

    DiffServ (RFC 2474) = CS2 010000 (16) - class 2 (RFC 2474). Similar forwarding behavior to the ToS Precedence field.

    However my downloads are now 90kpb/s so confused

  9. #9
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    Quote Originally Posted by pipexnoob View Post
    IP type of service field (RFC1349) = 01000000 (64)
    Precedence (priority) = 010 (immediate)
    Delay = 0 (normal delay)
    Throughput = 0 (normal throughput)
    Reliability = 0 (normal reliability)
    Cost = 0 (normal cost)
    Check bit = 0 (correct, 8th checking bit must be zero)

    DiffServ (RFC 2474) = CS2 010000 (16) - class 2 (RFC 2474). Similar forwarding behavior to the ToS Precedence field.

    However my downloads are now 90kpb/s so confused
    Where do you test your speed?

    Your Default ToS setting should be 136 and not 64

  10. #10
    Junior Member
    Join Date
    Nov 2006
    Posts
    18
    Various speed tests, one built into Firefox, one through British Telecom website and one through a uk based speed tester, see below.


  11. #11
    Junior Member
    Join Date
    Nov 2006
    Posts
    18
    Also my Default ToS is set to 136?

  12. #12
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    Try testing your speed at this link using the 2 test servers in the UK:

    http://www.speedtest.net/

    Yes, set Default ToS to 136 to speed up data packet transfers.

  13. #13
    Junior Member
    Join Date
    Nov 2006
    Posts
    18
    Ok my ToSefaultTOSValue is 136, the only thing 64 is my TTL.

    heres my results...


  14. #14
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    Do this nitro test and post the pop-up results under the 'Statistics' button:

    http://nitro.ucsc.edu/

  15. #15
    Junior Member
    Join Date
    Nov 2006
    Posts
    18
    WEB100 Enabled Statistics:
    Checking for Middleboxes . . . . . . . . . . . . . . . . . . Done
    checking for firewalls . . . . . . . . . . . . . . . . . . . Done
    running 10s outbound test (client-to-server [C2S]) . . . . . 336.0kb/s
    running 10s inbound test (server-to-client [S2C]) . . . . . . 173.00kb/s

    ------ Client System Details ------
    OS data: Name = Windows XP, Architecture = x86, Version = 5.1
    Java data: Vendor = Sun Microsystems Inc., Version = 1.5.0_06

    ------ Web100 Detailed Analysis ------
    Cable modem/DSL/T1 link found.
    Link set to Full Duplex mode
    Information: throughput is limited by other network traffic.
    Good network cable(s) found
    Normal duplex operation found.

    Web100 reports the Round trip time = 252.24 msec; the Packet size = 1460 Bytes; and
    There were 11 packets retransmitted, 59 duplicate acks received, and 61 SACK blocks received
    The connection stalled 1 times due to packet loss
    The connection was idle 0.59 seconds (5.36%) of the time
    C2S throughput test: Packet queuing detected: 1.74%
    S2C throughput test: Excessive packet queuing detected: 31.07%
    This connection is network limited 99.91% of the time.
    Excessive packet loss is impacting your performance, check the auto-negotiate function on your local PC and network switch

    Web100 reports TCP negotiated the optional Performance Settings to:
    RFC 2018 Selective Acknowledgment: ON
    RFC 896 Nagle Algorithm: ON
    RFC 3168 Explicit Congestion Notification: OFF
    RFC 1323 Time Stamping: OFF
    RFC 1323 Window Scaling: ON

    Server 'nitro.ucsc.edu' is not behind a firewall. [Connection to the ephemeral port was successful]
    Client is not behind a firewall. [Connection to the ephemeral port was successful]
    Packet size is preserved End-to-End
    Server IP addresses are preserved End-to-End
    Client IP addresses are preserved End-to-End


    There you go, i have to go out now unfortunately but all this help is great thanks.

  16. #16
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    Quote Originally Posted by pipexnoob View Post
    ------ Web100 Detailed Analysis ------
    Cable modem/DSL/T1 link found.
    Link set to Full Duplex mode
    Information: throughput is limited by other network traffic.
    Good network cable(s) found
    Normal duplex operation found.

    Web100 reports the Round trip time = 252.24 msec; the Packet size = 1460 Bytes; and
    There were 11 packets retransmitted, 59 duplicate acks received, and 61 SACK blocks received
    The connection stalled 1 times due to packet loss
    The connection was idle 0.59 seconds (5.36%) of the time
    C2S throughput test: Packet queuing detected: 1.74%
    S2C throughput test: Excessive packet queuing detected: 31.07%
    This connection is network limited 99.91% of the time.
    Excessive packet loss is impacting your performance, check the auto-negotiate function on your local PC and network switch
    Update your antivirus and antimalware programs, and go into Windows 'Safe Mode' and scan and remove any virus and malware.

    Make sure your modem is placed at least 2 feet away from other electrical devices such as router, speakers, sub-woofer, cordless phone, power supply, etc.

  17. #17
    Junior Member
    Join Date
    Nov 2006
    Posts
    18
    Ill check for virus's and malware (that spyware??) but i use firefox and very careful what i download. As for the position when my connection was only 2mb i could download 160kpb's + and the modem hasnt changed position its quite close to 4 power sockets.

    I have a modem from my last service providor is there anyway i can configure that modem to dial to my current service providor?

  18. #18
    Junior Member
    Join Date
    Nov 2006
    Posts
    18
    Heres todays results, slightly better...


  19. #19
    Elite Member trogers's Avatar
    Join Date
    Jan 2005
    Location
    Bangkok, Thailand
    Posts
    12,323
    Electromagnetic interference acting on the modem is known to slow down speed.

    Make sure your modem is placed at least 2 feet away from other electrical devices such as router, speakers, sub-woofer, cordless phone, power supply, etc.

  20. #20
    Junior Member
    Join Date
    May 2006
    Posts
    11
    after your tweaks trogers............my download speed is up and my packet loss has all but dissapperared

    WEB100 Enabled Statistics:
    Checking for Middleboxes . . . . . . . . . . . . . . . . . . Done
    checking for firewalls . . . . . . . . . . . . . . . . . . . Done
    running 10s outbound test (client-to-server [C2S]) . . . . . 361.0kb/s
    running 10s inbound test (server-to-client [S2C]) . . . . . . 2.61Mb/s

    ------ Client System Details ------
    OS data: Name = Windows XP, Architecture = x86, Version = 5.1
    Java data: Vendor = Sun Microsystems Inc., Version = 1.5.0_06

    ------ Web100 Detailed Analysis ------
    Cable modem/DSL/T1 link found.
    Link set to Full Duplex mode
    No network congestion discovered.
    Good network cable(s) found
    Normal duplex operation found.

    Web100 reports the Round trip time = 340.04 msec; the Packet size = 1460 Bytes; and
    No packet loss - but packets arrived out-of-order 3.13% of the time
    C2S throughput test: Packet queuing detected: 1.85%
    S2C throughput test: Packet queuing detected: 3.14%
    This connection is receiver limited 80.47% of the time.
    This connection is network limited 19.34% of the time.

    Web100 reports TCP negotiated the optional Performance Settings to:
    RFC 2018 Selective Acknowledgment: ON
    RFC 896 Nagle Algorithm: ON
    RFC 3168 Explicit Congestion Notification: OFF
    RFC 1323 Time Stamping: OFF
    RFC 1323 Window Scaling: ON

    Server 'nitro.ucsc.edu' is not behind a firewall. [Connection to the ephemeral port was successful]
    Client is probably behind a firewall. [Connection to the ephemeral port failed]
    Packet size is preserved End-to-End
    Server IP addresses are preserved End-to-End

    URL=http://www.speedtest.net][/URL]

    your a star nice one

Similar Threads

  1. Very Slow DSL Download Speed
    By Alex122488 in forum Broadband Tweaks Help
    Replies: 14
    Last Post: 11-20-09, 04:07 AM
  2. DSL download speed is 56k slow
    By Ramboner33x in forum Broadband Tweaks Help
    Replies: 1
    Last Post: 08-22-06, 04:06 PM
  3. Slow Download Speed when connected to Router and Switch.
    By BooGeyMan in forum Networking Forum
    Replies: 3
    Last Post: 04-27-06, 08:18 AM
  4. is it 56KB/sec a slow download speed for a DSL?
    By necromarkos in forum General Broadband Forum
    Replies: 5
    Last Post: 12-12-05, 01:43 PM
  5. Very rare case of slow download speed
    By checky123 in forum Broadband Tweaks Help
    Replies: 4
    Last Post: 04-19-05, 03:51 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •