Results 1 to 4 of 4

Thread: Logitech MX-700 issue

  1. #1
    Advanced Member westy's Avatar
    Join Date
    Dec 2000
    Location
    New Market, MN. USA
    Posts
    871

    Logitech MX-700 issue

    I could use some assistance trying to track down an issue with the mouse on my Logitech MX-700 combo.

    For no reason at all, my mouse cursor freezes on the screen. The actual movement of where the mouse is still moves because I can open or right click and open programs and stuff, but I can't tell where the cursor is. Once in a while, I get an error message that tells me the pointing device has switched to channel 1 or channel 2, but this isn't always the case. The only way to get it back working is to reboot. I've tried uninstalling the drivers and re-installing the latest ones, but that didn't do any good.

    I'm at my wits end with rebooting !

    Any thoughts or suggestions ?

    Thank you in advance !

    "We do not inherit the Earth from our parents, we borrow it from our children."

    Asus P5Q-E LGA 775 / Intel Core 2 Duo E8500 Wolfdale / Artic Cooling Freezer 7 Pro / NVIDIA GTX650 Ti Boost / Corsair Dominator 8GB DDR2 1066 (PC2 8500) / Corsair CMPSU-650TX / Asus 20X DRW-2014L1T / Klipsch 4.1 / Creative Sound Blaster Z / Crucial MX100 CT512MX100SSD1 2.5" 512GB SATA III MLC Internal Solid State Drive / Too many hard drives to mention.....

  2. #2
    Senior Member
    Join Date
    Jun 2002
    Location
    Ertlanta, Gargea
    Posts
    7,002
    My first thing would be to ditch the logitech drivers and see if the built in windows drivers for wireless mice works.

    If that's a no go, you can try this... http://support.microsoft.com/default...b;en-us;895550

  3. #3
    Moderator YeOldeStonecat's Avatar
    Join Date
    Jan 2001
    Location
    Somewhere along the shoreline in New England
    Posts
    51,112
    Uninstall the Logitech drivers...I always just use the native Windows drivers.

    Make sure chipset drivers are the latest...relates to USB ports...

    Try a different USB port.
    MORNING WOOD Lumber Company
    Guinness for Strength!!!

  4. #4
    Tortoises R0cks :D Rivas's Avatar
    Join Date
    May 2002
    Location
    Canada
    Posts
    10,257
    did you install any new device before the problem started ?
    I had same problem with my logitech mouse and keyboard i updated drivers from logitech website and problem was solved.Otherwise i dont know.
    To be human is to choose.


    It is better to die on your feet
    than to live on your knees.

    - Emiliano Zapata

Similar Threads

  1. Computer-Specific Internet Browsing Issue
    By Holyfield in forum General Broadband Forum
    Replies: 8
    Last Post: 12-24-06, 06:51 AM
  2. To Many User Accounts?
    By mandm6 in forum Software Forum
    Replies: 11
    Last Post: 06-21-06, 08:29 PM
  3. Freak issue, but not unique. (Bit Torrent related)
    By PicHold in forum General Broadband Forum
    Replies: 14
    Last Post: 01-06-06, 03:41 PM
  4. Replies: 1
    Last Post: 09-29-05, 09:35 AM
  5. Frustrating connectivity issue (DI-524)
    By SirDevon in forum Wireless Networks & Routers
    Replies: 6
    Last Post: 03-02-05, 07:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •