Results 1 to 12 of 12

Thread: Help Me Pleeeeeaaaaaassssee!!!

  1. #1
    Junior Member
    Join Date
    Feb 2006
    Posts
    2

    Unhappy Help Me Pleeeeeaaaaaassssee!!!

    I wasnt too sure where to post this but i thought it would fit in nicely here.

    I have got an ATI Radeon 9800 pro. I bought this because it had one of the highest user ratings and overall looked extremely good. However, i have successfully installed the card, updated all drivers, have the latest updates on the game and windows, but i am still have problems when playing BATLLEFIELD 2!!!

    It's all fine when i load up the game and get onto a server, but once im on the quality drops! For example, the writing on the scoreboard is unreadable?! (it's fuzzy and distorted). The terrain is blotchy and multicouloured in some areas????!!!! and the people are patchy with different colours and arent smooth and textured like theyre supposed to be. I get along by with these problems and still manage to play the game, ALOT! But overtime it's annoyed me and i've decided i need HELP!

    If anybody, has had the same problems and has fixed them or knows how to fix them please, please let me know.

    My PC spec. is:
    Windows XP
    1GB DDR RAM
    1.7Ghz Processer (AMD-Semperon)
    80GB hardrive
    and of couorse ATI Radeon 9800 pro - 128mb

    Thanks alot if anyone can help, please.

  2. #2
    resident plumber Mark's Avatar
    Join Date
    Apr 2001
    Location
    .
    Posts
    13,148
    welcome to speedguide, it might help if you posted a screenshot of the issues you are haveing here, would be easier to see exactly what is going on.

  3. #3
    Moderator YeOldeStonecat's Avatar
    Join Date
    Jan 2001
    Location
    Somewhere along the shoreline in New England
    Posts
    50,898
    Do you have an LCD monitor? Running the game at the same resolution as your desktop?
    MORNING WOOD Lumber Company
    Guinness for Strength!!!

  4. #4
    Ohh Hell yeah.. Sava700's Avatar
    Join Date
    Feb 2002
    Location
    Somewhere
    Posts
    24,052
    updated cat driver?? Proper amount of power going to card? Is it clean from dust and whatever else on it that might cause it to overheat?

  5. #5
    Junior Member
    Join Date
    Feb 2006
    Posts
    2

    ATi problems

    Thanks for everyone's reply's so far.



    Thats the screenshot.

    I am running all minimum requirements and more for the game, and i have a 2 built in fans and 1 standing fan beside my computer. I have just cleaned my computer after i read the post, but still, the problems are there.

  6. #6
    Ohh Hell yeah.. Sava700's Avatar
    Join Date
    Feb 2002
    Location
    Somewhere
    Posts
    24,052
    the card isn't performing like it should.. likely going bad with a heat related issue.. i've seen this on 3 cards right before they started causing the same thing on desktop which then is only a matter of time before it won't even show anything.

  7. #7
    Moderator YeOldeStonecat's Avatar
    Join Date
    Jan 2001
    Location
    Somewhere along the shoreline in New England
    Posts
    50,898
    Any prior drivers still installed? I'd go through add/remove programs...did you have a different type of graphics card in there before?

    ATI drivers...run the Catalyst Uninstaller you see on the driver download page..clean out remnants of prior ATI drivers.

    Overclocking at all?
    MORNING WOOD Lumber Company
    Guinness for Strength!!!

  8. #8
    Morterator Immortal's Avatar
    Join Date
    Apr 2000
    Location
    Mississauga, Ontario , Canada. Behaviour : Good
    Posts
    22,668
    Have u tried lowering the settings in bf2? See if that make a diff...

  9. #9
    Jen's Best Friend RoscoPColtrane's Avatar
    Join Date
    Sep 2000
    Location
    Fort Worth, Texas
    Posts
    6,154
    Quote Originally Posted by YeOldeStonecat
    Any prior drivers still installed? I'd go through add/remove programs...did you have a different type of graphics card in there before?

    ATI drivers...run the Catalyst Uninstaller you see on the driver download page..clean out remnants of prior ATI drivers.

    Overclocking at all?

    GOod point here, make sure you ran "driver cleaner" on your other drivers. Especially if it was nvidea prior to the ati. I had a 98pro and it worked great for that game. hopefully you can get it taken care of. Personally i would run the driver cleaner, install the newest "official" cats and see if it helps. if not then id return it in fear of the card being bad...

    Good luck with it, don't give up those cards a pretty good (especially for the price now!)
    ****************************************************************************************
    Abit NF7-S 2.0, Barton 2500+ @ 2.2 Ghz, 2 Gig ddr3200, 80gig Seagate HDD, ATI x850 PRO @ 550/600, WinXP Pro

    J B K M

    Pittsburgh Steelers Super Bowl XL Champions!!!!!

  10. #10
    Jen's Best Friend RoscoPColtrane's Avatar
    Join Date
    Sep 2000
    Location
    Fort Worth, Texas
    Posts
    6,154
    one other thing i know that EA is having problems with their newest patch saying it needs patched again soon, is this something that is wrong with it? i never went into details on the problems however ive noticed that the sandbags textures in the game look funny on my system too...diff card and everything... just an idea maybe.
    ****************************************************************************************
    Abit NF7-S 2.0, Barton 2500+ @ 2.2 Ghz, 2 Gig ddr3200, 80gig Seagate HDD, ATI x850 PRO @ 550/600, WinXP Pro

    J B K M

    Pittsburgh Steelers Super Bowl XL Champions!!!!!

  11. #11
    Advanced Member SpareX's Avatar
    Join Date
    May 2001
    Location
    Its chilly here...
    Posts
    642
    I've got that card.. I had a wierd problem like that on a few other games. Thinking Like Sava I cleaned the system and I thought it was heat or defective. Heat not being it. I swapped the card at the shop i got it at. (I bought it were i worked at the time so exchanged the very next day without fail) There was a small improvement but not alot..

    SO. I reduced the quality settings to lowest and stepped up point by point.. I found that some AA settings and a few other things EA does is very funky with these cards.. but slowly step it up and go from there.. Also make sure nothing is runnin in the background.

    Good luck and keep us posted.
    Beer, Pretzels, and a Monkey with a shotgun. Dare I ask for more?

    SYSTEM A / system b
    INTEL P4 3.06Ghz / intel p4 2.53Ghz
    INTEL D865PERL / intel d845pebt2
    1GB DDR3200 OCZ RAM / 512MB 2700 ram
    ATI RADEON 9800 PRO 128/ pny ti4400
    SEAGATE SATA 7200 80Gb / maxtor 7200 100Gb
    SB AUDIGY GAMER/ onboard sound
    XP Pro on both

  12. #12
    ATI cards have had issues with patch 1.20 ...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •