Results 1 to 2 of 2

Thread: Need help in tweaking MTU

  1. #1
    Junior Member
    Join Date
    Feb 2006
    Posts
    3

    Need help in tweaking MTU

    My registry list this: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\MTU - REG_DWORD - 0x00005dc(1500). Yet the TCP/IP Analyser shows that My MTU isn't fully optimized:

    CP options string = 0204056401010402
    MTU = 1420
    MTU is not fully optimized for broadband. Consider increasing your MTU to 1500 for better throughput. If you are using a router, it could be limiting your MTU regardless of Registry settings.
    MSS = 1380
    MSS is not optimized for broadband. Consider increasing your MTU value.
    Default TCP Receive Window (RWIN) = 32120
    RWIN Scaling (RFC1323) = 0 bits
    Unscaled TCP Receive Window = 32120

    For optimum performance, consider changing RWIN to a multiple of MSS.
    Other values for RWIN that might work well with your current MTU/MSS:
    507840 (MSS x 46 * scale factor of 8)
    253920 (MSS x 46 * scale factor of 4)
    126960 (MSS x 46 * scale factor of 2)
    63480 (MSS x 46)
    bandwidth * delay product (Note this is not a speed test):

    Your TCP Window limits you to: 1284.8 kbps (160.6 KBytes/s) @ 200ms
    Your TCP Window limits you to: 513.92 kbps (64.24 KBytes/s) @ 500ms
    MTU Discovery (RFC1191) = ON
    Time to live left = 52 hops

    TTL value is ok.
    Timestamps (RFC1323) = OFF
    Selective Acknowledgements (RFC2018) = ON
    IP type of service field (RFC1349) = 00000000 (0)

    Can someone explain to me why this is? The speed tests that I run all show my upload larger than my download. But per experience an RWIN of 32120 has worked great until recently.

  2. #2
    Administrator Philip's Avatar
    Join Date
    May 1999
    Location
    Jacksonville, Florida, United States
    Posts
    10,576
    Blog Entries
    6
    Assuming you're testing your machine (no transparent proxies, etc.) the Analyzer reports the correct MTU seen by other servers on the Internet.

    The smaller MTU reported can be caused by a router, or something similar on the line that limits it to a lower number than what's in your Registry.

    If you're using a broadband router, look through its management interface and see if there is an option to edit MTU.

    I hope this helps

Similar Threads

  1. SG Tweaking programs, tools and links
    By Philip in forum Broadband Tweaks Help
    Replies: 3
    Last Post: 10-29-12, 11:14 AM
  2. MTU madness
    By mitsubishi in forum Broadband Tweaks Help
    Replies: 4
    Last Post: 09-26-05, 05:04 PM
  3. Win XP keeps resetting mtu, rwin etc. HELP
    By Hayabusa in forum Broadband Tweaks Help
    Replies: 3
    Last Post: 09-11-05, 12:54 PM
  4. Problem with MTU MSS TTL
    By dallama in forum Broadband Tweaks Help
    Replies: 1
    Last Post: 07-06-05, 02:31 PM
  5. alittle MORE tweaking help,please !!
    By EaZyPic in forum Broadband Tweaks Help
    Replies: 1
    Last Post: 05-28-05, 11:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •