This is one even the Netgear support people can't solve. I Cannot map network drives or use intranet or remote desktop for resources behind my company's firewall using Cisco VPN Client and a netgear WGR614v6 wireless router. VPN connection works if I bypass the router and connect directly to DSL modem.
Here is what I''ve already tried:

Turned off firewall on my laptop (running Windows XP SP2)

Here''s what I''ve tried so far on my router and nothing has worked:

Used port forwarding for UDP ports 50, 51, 500, 4001 and 1723 for my laptops IP
Disabled the SPI firewall
Checked "respond to ping on internet port"
Upgraded firmware to V1.0.11_1.0.7NA
Disabled Access control
Disabled all security (normally WPA-psk)
Set MTU to 1300 on both Cicso VPN client and WGR615
set MTU to 1430 on both Cisco VPN client adn WGR615
Added laptop''s IP to DMZ server
Tried both IPSec over UDP and IPSec over TCP on Cisco VPN Client
Reset router to factory defaults

Still no go on VPN. Can someone suggest something else for this router other than what we already know which is this VPN client and router combination are incompatable. Perhaps a setting in the laptops Intel® PRO/Wireless 2200 that I can tweak? One post I read said the user tries a Cisco Systems Aironet PCI Wireless LAN Adapter and got it to work but that would be my last choice and not guaranteed in my situation.