Results 1 to 14 of 14

Thread: Proxomitron reduces RWIN to 32768

  1. #1

    Proxomitron reduces RWIN to 32768

    I'm using Proxomitron with IE 6.0.
    The problem is that it sets my RWIN to 32768 (according to the speedguide analyzer) regardless what is set up in the registry and therefore downloads from distant servers are very slow.

    As soon as I deactivate the local Proxy (localhost:8080) in the IE options I have full speed and the speedguide analyzer displays the correct RWIN of 506680, but then of course the Proxomitron doesn't work because it needs that local proxy.

    Anyone can help me?
    Thanks in advance

  2. #2
    Dr Tweak mnosteele52's Avatar
    Join Date
    Jul 2001
    Location
    Chesapeake, VA
    Posts
    11,912
    Tweaks are negated when using a proxy since you are directed through it and not connected directly to the internet.


  3. #3
    Junior Member
    Join Date
    Jun 2005
    Posts
    28
    Quote Originally Posted by Tony Tough
    I'm using Proxomitron with IE 6.0.
    The problem is that it sets my RWIN to 32768 (according to the speedguide analyzer) regardless what is set up in the registry and therefore downloads from distant servers are very slow.

    As soon as I deactivate the local Proxy (localhost:8080) in the IE options I have full speed and the speedguide analyzer displays the correct RWIN of 506680, but then of course the Proxomitron doesn't work because it needs that local proxy.

    Anyone can help me?
    Thanks in advance
    I use proxo also, but can not confirm your issue.

    So what you are saying is with proxomitron on when you go here:

    http://forums.speedguide.net:8117/

    your RWIN changes?

    Mine does not.

    So maybe try different filters... or settings under config for proxo may need some tweeking...

    1) try kye-u filter set
    2) also ck under http tab in proxo under config, only thing you should show is the 8080

    all other boxes s/b blank unless you are filtering https


    don't have time now but maybe another proxo user can help in the meantime

  4. #4
    Quote Originally Posted by 5MpstweakR
    I use proxo also, but can not confirm your issue.

    So what you are saying is with proxomitron on when you go here:

    http://forums.speedguide.net:8117/

    your RWIN changes?
    Yes, exactly.
    Even the deactivation of all filters or using "Bypass" has the same effect.
    Also in the http tab all boxes besides the 8080 are blank.

    I tested an other web filter in the meantime called BFilter (also with localhost:8080 as proxy setting) and there
    http://forums.speedguide.net:8117
    shows the correct RWIN from windows registry (253440) and I have full download speed.
    Last edited by Tony Tough; 10-18-05 at 10:31 AM.

  5. #5
    Junior Member
    Join Date
    Jun 2005
    Posts
    28
    TT,

    If you want I can post the .txt version of Kye-U's filter set here, or PM me and I can send you the file for Kye-U.Browser.Security.Pack.v4.44.cfg

    You are probably using the latest version of Proxo 4.5 if not go here:

    http://castlecops.com/downloads-cat-19.html

    I am using 4.3 without issue.

    _________________

    beyond that it may be a false positive especially if

    1) your browser speed is up to par - pages loading fast etc

    2) your download speed is unaffected - which you can check by dwnlding a big file via ftp:

    ftp://test.tampabay.rr.com/ftp.50m.sav

    or

    ftp://ftp1.optonline.net/pub/test64

    just downld maybe 30-50% or until your speed stabablizes and do the calc. to figure your dwnld speed.

    ________________

    Also try the following:

    1) go to the tcp/ip analyzer with proxo on http://forums.speedguide.net:8117/

    2) then execute TCP optimizer or run regedit to see if your RWIN value has actually changed. If the TCP Optimizer current settings show no change - this would indicate the analyzer may not reflect reality for your instance.

    if not then again maybe trying a different filter set or even a different version of proxo may get rid of your issue...

    the good news is if I am not seeing your problem there is hope that we may be able to isolate your issue if we can determine what is different...

    3) Also you may want to give firefox or opera a try

    4) one other thing look at IE browser setting for network & proxy and make sure you have http 1.1 for proxy enabled
    Last edited by 5MpstweakR; 10-18-05 at 11:49 AM.

  6. #6
    I tried different versions of proxomitron with different filters, with no filters or bypass : all the same effect.
    Also no difference with firefox.

    And of course only http:// from servers with higher latency is affected not ftp or other protocols, because only these are routed through localhost:8080.

    For example:
    with activated proxomitron on localhost:8080 I get about 120 KB/s from a http server with about 215 ms latency with one connection.
    Without the local proxy 8080 I get 550 KB/s with one connection.
    With BFilter (another program like proxomitron that works similar and also via localhost:8080) I also get 550 KB/s.

    So I think that the problem is inside the proxomitron.exe, which doesn't work 100% with my system configuration and sends that low RWIN in the tcp/ip headers to other servers.
    Last edited by Tony Tough; 10-18-05 at 01:49 PM.

  7. #7
    Junior Member
    Join Date
    Jun 2005
    Posts
    28
    So I think that the problem is inside the proxomitron.exe, which doesn't work 100% with my system configuration and sends that low RWIN in the tcp/ip headers to other servers.
    if it is a real slow down the choice is obvious, if perceived (i.e. not real) it wouldn't bother me if I had the issue - which I don't.

    so when you did the following was it real or perceived?:

    1) go to the tcp/ip analyzer with proxo on http://forums.speedguide.net:8117/

    2) then execute TCP optimizer or run regedit to see if your RWIN value has actually changed. If the TCP Optimizer current settings show no change - this would indicate the analyzer may not reflect reality for your instance.

    ___________________

    BTW, I usually do my speed tests with proxo and firewall down (still safe relatively speaking inbound since I'm behind a router), I was curious so I went here:

    http://speedtest.umnet.umich.edu/

    and did a speed test with proxo on (not bypassed) and firewall inactive, and actually got a very good result 4.77 Mb/s or 95.4% of advertised.
    Last edited by 5MpstweakR; 10-18-05 at 04:32 PM.

  8. #8
    Quote Originally Posted by 5MpstweakR
    so when you did the following was it real or perceived?:

    1) go to the tcp/ip analyzer with proxo on http://forums.speedguide.net:8117/

    2) then execute TCP optimizer or run regedit to see if your RWIN value has actually changed. If the TCP Optimizer current settings show no change - this would indicate the analyzer may not reflect reality for your instance.
    The RWIN value in the registry isn't changed and also the TCP Optimizer (which also takes the value from registry) settings show no change - but that doesn't say anything, because what is sent out is a different thing and the speedguide analyzer doesn't look at registry settings, it looks what is sent out via TCP/IP

    From the speedguide FAQ:
    If the IP address displayed by the Analyzer is yours, then the readings are most likely accurate. Complaining about them is equivalent to telling the manufacturer of your mirror that it is not reflecting your face accurately, because according to the description of your latest makeup kit, you should look much more attractive after applying it (my apologies to the male users, I couldn't come up with a more "manly" example :-) ).

    The Analyzer does not look at Registry settings, it takes the values directly from the header information in TCP/IP packets, the same information your end advertises to servers.
    Last edited by Tony Tough; 10-18-05 at 04:52 PM.

  9. #9
    Junior Member
    Join Date
    Jun 2005
    Posts
    28
    because what is sent out is a different thing and the speedguide analyzer doesn't look at registry settings, it looks what is sent out via TCP/IP
    if you can write a header filter for proxo which matches on anything other than the correct RWIN and if matched sends out the correct RWIN maybe this could be a workable solution, the other choice is to use the source forge proxy

    sounds like it is a real slowdown if the http server is sent the wrong data... that sucks

    I was trying to find Kye-U but his site is down, he might be able to provide some insight.

    He browses sometimes at wilders security if you want to post or reference here over there...

    http://www.wilderssecurity.com/index.php

  10. #10
    Junior Member
    Join Date
    Jun 2005
    Posts
    28
    I Found Kye-U...

    If you are not ready to give up and still want help with this proxo issue go here:

    http://kyeu.hostingzero.com/proxo/fo...267a646d31d3d1

  11. #11
    Quote Originally Posted by 5MpstweakR
    I Found Kye-U...

    If you are not ready to give up and still want help with this proxo issue go here:

    http://kyeu.hostingzero.com/proxo/fo...267a646d31d3d1
    Many thanks.

  12. #12
    Dr Tweak mnosteele52's Avatar
    Join Date
    Jul 2001
    Location
    Chesapeake, VA
    Posts
    11,912
    Quote Originally Posted by mnosteele52
    Tweaks are negated when using a proxy since you are directed through it and not connected directly to the internet.

    What do you guys not understand? A proxy sits between you and the internet to block direct access to your pc thereby negating any tweaks you have done. The TCP/IP Analyzer cannot read your actual RWIN when using a proxy.


  13. #13
    Junior Member
    Join Date
    Jun 2005
    Posts
    28
    What do you guys not understand? A proxy sits between you and the internet to block direct access to your pc thereby negating any tweaks you have done. The TCP/IP Analyzer cannot read your actual RWIN when using a proxy.
    mnosteele52,

    We are not ignoring your answer.

    We understood the thought behind your answer.

    We are trying to understand why this appears to be an isolated occurrence. As stated I and many others do not have this same issue Tony is having with Proxomitron.

    Also, as Tony stated Bfilter is also a local proxy and he does not have this problem with that software.

    Kye-U has posted at Yahoo proxylist to see if anyone knows of a coding issue Scott Lemmon programmed into his software. Kye thinks it may be a coding/programming issue within the Proxomitron software given certain pc configs.

    http://kyeu.hostingzero.com/proxo/fo...4252f754934386

    Kye post @ at Yahoo prox-list:

    http://groups.yahoo.com/group/prox-list/message/22257

    above link if u are registered @ Yahoo prox-list

  14. #14
    Junior Member
    Join Date
    Jun 2005
    Posts
    28
    Good news on this 32768 RWIN limit in proxomtron which Tony and many others were reporting who use proxomitron on a Windows XP with SP2 home or pro machine.

    z12 (Mike) verified the 32768 rwin buffer was hard coded in proxomitron

    you can follow further updates on this here:

    http://kyeu.info/proxo/forums/viewto...77a8a9cfa6435a

    hopefully Mike and others with the expertise will figure a way to share the solution for those who experience this issue (some XP SP2 users of proxomitron)

Similar Threads

  1. Cant set the rwin with cablenut
    By piranha in forum Broadband Tweaks Help
    Replies: 23
    Last Post: 07-08-02, 09:15 AM
  2. setting up speed patches
    By carl in forum Broadband Tweaks Help
    Replies: 25
    Last Post: 01-19-02, 08:32 PM
  3. RWIN won't go higher than 1460
    By Ghost Stalker in forum Broadband Tweaks Help
    Replies: 19
    Last Post: 10-01-01, 10:26 AM
  4. what is a good packet loss percentage vs. high rwin
    By Brad P in forum Broadband Tweaks Help
    Replies: 7
    Last Post: 07-24-01, 05:48 PM
  5. Help with Optimal RWIN for me!
    By sixdog in forum Broadband Tweaks Help
    Replies: 5
    Last Post: 06-26-01, 10:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •