Results 1 to 6 of 6

Thread: Netgear DG834G and Battlefield 2 - "There is a problem with your connection" - Help!

  1. #1

    Question Netgear DG834G and Battlefield 2 - "There is a problem with your connection" - Help!

    Hi there,

    I'm having major problems with BF2 and my connection via wireless laptop to my Netgear DG834G and the internet. I get the "problem with connection" sign after c1 minute, for a minute, then fine for a minute (30ish ping - BT BROADBAND) then bad again (not totally frozen, people still move very gradually) and so on.

    I've tried port forwarding after STATIC IP set up for the client ports listed in the back of the manual, and turned off zero wireless thing. I also tried adding all the ports 1 to 60000 to if that helped. None of these worked.

    Should it work? Is there anything else I can do? Or am I doing any of these things wrong.

    Also my laptop wireless connection speed to the router keeps varying, from bout 24mbps to 54 - problem there?

    Spec: 2 days old Fujitsu Siemens Amilo M3438G
    NetGear DG834G

    PLEASE help, I've just splashed out 1400 on 2 pieces of equipment which dont work! It seems that other people have had the problem but have resolved it - ive spent 2 horrible days trying!

    Thanls alot for any help

  2. #2
    It took me a while to find this solution to the problem, and it annoyed the crap out of me, so I'm posting it in the first 5 forum links for it in google:

    I got rid of the "Problem with your connection" problem by disabling VOIP in the options. Apparently, EAX can also cause it sometimes, but in my case it was just the VOIP. Hope this solves the problem.

  3. #3

    Problem with your connection


    good job, i had this damn problem with the "connection" for a month now, not even EA Support could help me... I even had a tech come to check my computer...

    Now i simply disabled the VoIP and back to normality...

    Good job...


    "lassan" @

  4. #4

    Where do i finde the VOIP

    i have tried both and it still does'nt work
    What do i do ?
    Last edited by poder; 03-14-09 at 05:01 AM.

  5. #5
    Hello folks!

    I'm having exactly the same problem. I have tried EVERYTHING. DMZ (static IP), disabling DOS protection, disabling VOIP and EAX. I've upgraded firmware, rebooted, turned of restarted... I've even had fresh installs of Vista, XP. Infact, I've even got a 90% new system.

    I've had this problem for years, with several Routers, and several ISPs. Granted, all the routers have been free with the packages which may mean I've had all low grade/cheap ones. Still I'd expect them to perform their most basic function; opening bloody ports properly

  6. #6

    Wink ive got it

    this is top on my search engine so i will annouce my solution here, if you have bt but live in a relativly remote area it could be that bt is too fast 4 ur local cables meaning you could lose data at the joint between the internet and your cables ,try downloading something at the same time to slow down bt, ur ping will go up by about 10 but it gets rid of the problem

Similar Threads

  1. Replies: 1
    Last Post: 10-20-06, 05:06 PM
  2. Replies: 0
    Last Post: 09-07-05, 05:36 AM
  3. Replies: 0
    Last Post: 09-07-05, 05:34 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts