Results 1 to 2 of 2

Thread: Cisco 827+NAT and MTU issue

  1. #1

    Cisco 827+NAT and MTU issue


    A "senior" tech-support person once told me that i should add the 'adjust-mss 1452' command on a cisco 827 PPPoA, for a smooth connection with the network, and that it because of the NAT. he didn't say why exactly..

    As far as i know, incoming NAT doesn't limit the packet size (correct me if wrong) and therefore i shoudn't put this command.

    Any ideas ? experience ? anything?


  2. #2


    this may help quoted from

    Can't access some web sites
    Symptoms: 1) If you're using MS ICS or Windows server as router to access the Internet, your clients may not be able to access certain web sites. However, the ICS host or the server doesn't have this problem.
    2) After installed a new router or cable modem replacing dial-up to access the Internet, you can't access some web sites.
    3) You also find that most web sites you can't access are block to ping or they are security sites using HTTPS.

    Causes: 1) The problem occurs because many web servers block ICMP messages and the packets are dropped. As a result, the requested web site doesn't load.
    2) This problem is caused also by an incompatible MTU networking setting. If you use MS ICS, you may want to configure all your Client computers to use the new, lower MTU as the default for all Internet communication. To modify the MTU size, locate the following registry key: HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ Tcpip\ Parameters\ Interfaces. If you use a router like Cisco DSL Router, you may want to adjusting the PPPoE MTU Size. For example, to adjusting the PPPoE MTU Size on the Cisco DSL Router, do

    interface ethernet0
    no shut
    ip address <ip address> <subnet mask>
    ip adjust-mss 1452


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts