Results 1 to 7 of 7

Thread: Internet Connection Sharing - Enable - Failed

  1. #1
    antzen
    Guest

    Question Internet Connection Sharing - Enable - Failed

    Something odd has happened, I can't re-enable ICS. I had it working and then when troubleshooting another network problem, which proved to be a malfunctioning DNS, I disabled ICS and ICF. When I later fixed the DNS problem I wanted to re-enable ICS to get the LAN working again it won't start.

    System state now

    The NIC connected to the Internet is working properly, and has not been changed since I disabled ICS.

    The NIC connected to the Local Area Network has the following properties:


    -----------------------------------------------------------------------------
    (Local Area Network NIC "General" Tab)

    (x) Client for Microsoft Networks -> Name Service Provider: Windows Locator
    (x) File and Printer Sharing for Microsoft Networks
    (x) QoS Packed Scheduler
    (x) Internet Protocol (TCP/IP)

    -------------------------------------------------------------------------
    Internet Protocol (TCP/IP) Properties dialog

    (Internet Protocol (TCP/IP) "General" Tab)

    (x) Obtain an IP address automatically
    (x) Obtain DNS server address automatically

    (Internet Protocol (TCP/IP) "Alternate Configuration" Tab)

    (x) Automatic private IP address
    -------------------------------------------------------------------------

    (Local Area Network NIC "Advanced" Tab)

    Nothing is checked on this tab at the moment.

    -----------------------------------------------------------------------------


    When trying to enable ICS

    When I try to enable ICS by checking (Local Area Network NIC) -> (Properties) -> (Internet Protocol (TCP/IP)) -> (Properties) -> (Advanced Tab) -> (x) Allow other network users to connect through this computer's Internet connection .. and click ( OK ) this is happening:

    A dialog appears:

    ----------------------------------------------------------------------------
    (Local Network)

    When Internet Connection Sharing is enabled, your LAN adapter will be set
    to use UP address 192.168.0.1. Your computer may lose connectivity with
    other computers on your network. If these other computers have static IP
    addresses, you should set them to obtain their IP addresses automatically.
    Are you sure you want to enable Internet Connection Sharing?

    ( Yes ) ( No )
    ----------------------------------------------------------------------------


    I click ( Yes )

    A dialog appears:

    ----------------------------------------------------------------------------
    (Network Connection)

    An error occurred while Internet Connection Sharing was being enabled.

    The system cannot find the file specified.

    ( OK )
    ----------------------------------------------------------------------------


    I click ( OK ) and the ICS is not enabled.

    Now these entries has been created in the System Event Log:

    ----------------------------------------
    The Application Layer Gateway Service service entered the running state.
    ----------------------------------------
    The Internet Connection Firewall (ICF) / Internet Connection Sharing (ICS) service was successfully sent a start control.
    ----------------------------------------
    The Internet Connection Firewall (ICF) / Internet Connection Sharing (ICS) service entered the running state.
    ----------------------------------------
    The SSDP Discovery Service service entered the running state.
    ----------------------------------------
    The Universal Plug and Play Device Host service was successfully sent a start control.
    ----------------------------------------
    The Universal Plug and Play Device Host service entered the running state.
    ----------------------------------------
    The Internet Connection Firewall (ICF) / Internet Connection Sharing (ICS) service entered the stopped state.
    ----------------------------------------
    The Internet Connection Firewall (ICF) / Internet Connection Sharing (ICS) service was successfully sent a stop control.
    ----------------------------------------
    The Application Layer Gateway Service service entered the stopped state.
    ----------------------------------------


    I thought perhaps that I should enable ICS on the Internet NIC, but the result is the same "cannot find the file specified". I have no idea why this has happened, but my guesses are that there's been something going on in the registry, but what?

    I've tried this suggestion: "I had this problem before, what I did was to remove the nic from the device manager, and re-install it with the latest drivers in safe-mode." -- didn't work.

    Unanswered questions on the above suggestion:

    1) Which NIC did you remove from Device Manager? The NIC connected to the LAN or the NIC connected to the Internet, or both?

    2) Did you remove the NIC (NICs) from Device Manager and directly reboot into Safe Mode and reinstall there, or did you allow XP to boot normally first, and then reboot into Safe Mode?

    3) Is it the NIC connected to the LAN or the Internet that I should "(x) Allow other network users to connect through this computer's Internet connection"? I've tried the LAN NIC thus far, but the results are the same with the Internet NIC...

    I now turn to this forum, which seems greatly above the other tried forums... in competence

    I hope that I can get this working, since I'm using WinRoute Lite right now, but that software messes with my gaming experience in the way of lost/dropped server-client packets.. (?)

    Well... that's it I think...

    /az

  2. #2
    You haven't mentioned OS and if it's not XP you can try the following. Only install ICS on the primary computer. On the primary computer go to control panel/windows components and uncheck ics if it's checked, apply. Reboot and again go to control panel/windows components and recheck the box and apply. This should start the ICS screen and may have installed missing files...... but it's a long shot. Good luck and they'll be others along who know more than I.

  3. #3
    Advanced Member
    Join Date
    Apr 2001
    Posts
    835
    Log to this page it has a lot of links to instructions to Windows Network Settings, and Sharing.

    Link to: Windows Network - Installing & Sharing.

    If you can not make it working with ICS, disable ICS and use this instead.

    http://www.analogx.com/contents/down...work/proxy.htm



    However if you are Not on a DialUp or any other "kinky" Internet source may be it is time for a Cable/DSL Router.

    Jack.
    Microsoft MVP - Networking.

  4. #4
    Junior Member
    Join Date
    Oct 2004
    Location
    Bristol UK
    Posts
    1

    A solution?

    I know this thread is long since dead but I had this problem recently and found a solution that I hope will help those that come after me

    Start > Control panel > Administrative tools > Services

    Check your services to see if 'DHCP' and 'TCPIP netbios helper' services are running. Get em started if not and try enabling ICS again. I'd disabled these services as they weren't needed for normal pc operation (I use static IPs on the network) but they do appear neccessary to configure ICS. Once configued you can set them back to 'manual' or 'disabled'.

    I hope that helps!

  5. #5
    antzen
    Guest
    A post is never really "dead" as long as it can help people out of problematic situations :grin:

  6. #6
    Junior Member
    Join Date
    Dec 2005
    Posts
    1

    Interrnet connection sharing problem

    Hi,
    I am also getting similar kind of problem. I have DSL connection I am using ICS to distribute the bandwidth it worked well for one year. When ever i restart the coimputer and dail via DSL model other users accessing through my system are able to access internet for 10 to 15 mins after that they are disconnecting from internet where as on my system I am still able to browse. Following message logged in event viewer

    The Application Layer Gateway Service service entered the stopped state.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Any idea ?

    Thanks,
    Phani

  7. #7
    Junior Member
    Join Date
    Feb 2008
    Posts
    1
    So I am currently using an AirLink 101 awll3028 (works as AP, Adhoc, and wifi adapter)I am having similar problems while configuring it to work as an AP, I get the error "enable sharing (private) failed [800702fd]!" I have gone through these steps and have not yet found a solution. I am running Comodo Firewall...

    Well, nevermind, While writing I disabled the firewall and now it works, Comodo usually asks whenever anything weird happens such as doing the network thing. just goes to show how helpful these forums are!!!

    In response to the last post, If you continue having this problem this is what i have done in the past when working with a router/modem setup (not sure if your using a router)turn it all off (including the PC) reset the modem (the tiny button on the back, there is no need to reset the router)) connect your computer directly to the modem, get that online (the modem now recognizes your computer as the "primary" via your computers MAC) then plug your computer into a non internet port on the router, go to the admin panel, and search for "clone mac address" and use that, now it will tell the modem that the router is your computer, now connect the modem to the internet port on the router and you should be good to go. That will only work for DSL, if your using cable you will need to connect the router to a "non internet" port on the router, as the way they connect is different. if you are using the computer as a router, then you will need to insure that the only thing that talks directly to the router has the appropriate MAC address (this would become a problem with many switches, as they may or may not deal with the MAC the proper way). If you are using a virtual network connection you may need to spoof one of the mac addresses via the registry (Google it, and backup the registry first) to insure that the modem thinks that the correct device is talking to it.

    the reason this works is because most US ISP's say you can only connect one computer to the internet, period, at a time, therefore you may need a workaround, so the ISP thinks that just one, very busy, computer is connected to the net, if you host things on port 80 , 21, or 23, then they will probably slow you down or blackout occasionally.

    I sure hope this helps or might lead you in the right direction.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •