Results 1 to 2 of 2

Thread: TCP/IP Analyzer results.

  1. #1
    Hifiman
    Guest

    Question TCP/IP Analyzer results.

    I tried optimizing my DSL (PPPoE) service using SG TCP/IP Analyzer results and TCP Optimizer. Below are the results, based on custom settings of MTU to 1454 and RWIN to 260176. My OS is Windows 98.
    If I use the optimal settings in TCP Optimizer, it sets MTU to 1492 and RWIN to 255552. However, I still get the same results from TCP/IP Analyzer : it still tells me that MTU =1454 and that I should consider setting it to 1500. It this case it detects the change of RWIN to 255552.
    The same thing happens when I run TCP/IP Analyzer after setting MTU to 1500 : TCP/IP Analyzer never seems to detect any changes I make to MaxMTU.
    After making any changes in TCP Optimizer I always apply these changes and reboot my system. So how come TCP/IP Analyzer is unable to detect my changes to the MTU-setting ?
    I've also used TCP Optimizer's MaxMTU-feature to find the largest possible non-fragmented packet. When I do this it tells me to set MTU to 1454 (though I use a PPPoE DSL service at MaxMTU should be set to 1492 for best results).
    So what would give me the best results :
    Using Optimal settings for DSL (PPPoE) in TCP Optimizer which will set MaxMTU to 1492 and RWIN to 255552
    or
    Using Custom settings and set MaxMTU to 1452 (as suggested by TCP Optimizer's MaxMTU-feature) and RWIN to 260176 ?

    And how come TCP/IP Analyzer seems to be unable to detect any changes I make to MaxMTU, while it does reflect the changes I make to RWIN ?


    MTU = 1454
    MTU is not fully optimized for broadband. Consider increasing your MTU to 1500 for better throughput.

    MSS = 1414
    Maximum useful data in each packet = 1414, which equals MSS.
    MSS is not fully optimized for broadband (although it might work well for slower connections). Consider increasing your MTU value.

    Default Receive Window (RWIN) = 260176
    RWIN Scaling (RFC1323) = 2 bits
    Unscaled Receive Window = 65044
    RWIN is a multiple of MSS
    Other values for RWIN that might work well with your current MTU/MSS:
    520352 (MSS x 46 * scale factor of 8)
    130088 (MSS x 46 * scale factor of 2)
    65044 (MSS x 46)

    bandwidth * delay product:
    Your RcvWindow limits you to: 10407.04 kbps (1300.88 KBytes/s) @ 200ms
    Your RcvWindow limits you to: 4162.816 kbps (520.352 KBytes/s) @ 500ms

    MTU Discovery (RFC1191) = ON

    Time to live left = 53 hops
    TTL value is ok.

    Timestamps (RFC1323) = OFF

    Selective Acknowledgements (RFC2018) = ON

    IP type of service field (RFC1349)= 00000000

  2. #2
    Senior Member earthmofo's Avatar
    Join Date
    Nov 2000
    Location
    Providence, RI USA
    Posts
    1,128
    Try here for help setting your MTU:

    DSL MTU Guide
    "A never ending quest for knowledge as with knowledge comes wisdom"

    Main System running Windows XP Pro: Intel Celeron 2.4 Ghz, 1 Gig Ram, 2 80 gig WD 7200 rpm HD's, Radeon 9200 Pro, Envision EN9110 19" LCD Display, HP 9500 CD-RW, D-Link DFE-530TX+ PCI Adapter, D-Link DI-704P Router, Motorola SB5100 Cable Modem with Cox HSI

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •