Results 1 to 4 of 4

Thread: Optimization

  1. #1
    Tojo
    Guest

    Optimization

    Hey everyone!
    I'm on dial-up (56k) and it's really rather slower than it should be I think.
    usually about 2-2.5kbps

    I read somewhere to take your tcp/ip tests and then post the results here and someone would help so here goes:

    MTU = 576

    MSS = 536
    Maximum useful data in each packet = 536, which equals MSS.

    Default Receive Window (RWIN) = 8576
    RWIN Scaling (RFC1323) = 0 bits
    Unscaled Receive Window = 8576
    RWIN is a multiple of MSS
    Other values for RWIN that might work well with your current MTU/MSS:
    523136 (MSS x 122 * scale factor of 8)
    261568 (MSS x 122 * scale factor of 4)
    130784 (MSS x 122 * scale factor of 2)
    65392 (MSS x 122)

    bandwidth * delay product:
    Your RcvWindow limits you to: 343.04 kbps (42.88 KBytes/s) @ 200ms
    Your RcvWindow limits you to: 137.216 kbps (17.152 KBytes/s) @ 500ms
    Consider increasing your RWIN value to optimize TCP/IP for broadband.

    MTU Discovery (RFC1191) = ON

    Time to live left = 113 hops
    TTL value is ok.

    Timestamps (RFC1323) = OFF

    Selective Acknowledgements (RFC2018) = ON

    IP type of service field (RFC1349)= 00000000

    sys info:
    800Mhz PIII
    256MB ram
    56k voice/fax all that junk modem
    Windows 98 se

    Thanks!

  2. #2
    Member manheim's Avatar
    Join Date
    May 2002
    Location
    Lincoln, NE
    Posts
    56
    Yeah, I hear for ya fellow 56ker, are you using the settings mnosteele52 provides in his sig and in Cablenut add-on?

    For any 56k ISP, check to see if your ISP supports 1500 MTU/1460 MSS. You can use SG Optimizer to find out your highest MTU; then use that value and adjust your TCP window and stuff
    -Manheim...... Omni-one-

  3. #3
    Dr Tweak mnosteele52's Avatar
    Join Date
    Jul 2001
    Location
    Chesapeake, VA
    Posts
    11,912
    Welcome to Speedguide Tojo, I suggest setting your MTU to 1500, you can do so by going to your control panel - network icon - configuration - dial up adapter - properties - advanced and set IP packet size to large. Then use the following settings in CableNut:

    BcastNameQueryCount - 1
    BcastQueryTimeout - 100
    BSDUrgent - 1
    CacheTimeout - 600000
    DefaultRecvWindow - 8760
    DefaultTTL - 128
    EnableDNS - 0
    GlobalMaxTcpWindoSize - 8760
    KeepAliveInterval - 500
    KeepAliveTime - 14400000
    Lanabase - 0
    LocalCopyMade - 1
    MaxConnections - 64
    MaxConnectRetries - 5
    MaxDataRetries - 64
    NameTableSize - 255
    NameSrvQueryTimeout - 100
    PMTUBlackHoleDetect - 0
    PMTUDiscovery - 1
    RoutingBufSize - 146432
    RoutingPackets - 100
    SackOpts - 1
    SessionKeepAlive - 7200
    SessionTableSize - 255
    Size/Small/Medium/Large - 3
    Tcp1323Opts - 0
    TcpTimedWaitDelay - 30
    MaxDupAcks - 2
    DefaultTOS - 92
    IGMPLevel - 2
    MaxConnectionsPer1_0Server - 8
    MaxConnectionsPerServer - 4

    VERY IMPORTANT TO DO THE FOLLOWING

    1. Under your Configuration tab for your Network settings make sure you have only the needed protocols.

    2. Install the vtcp 386 patch and the NDIS Update.

    3. Open IE and select tools - internet options - connections - LAN settings, make sure NOTHING there is checked.

    4. Make sure you have the latest drivers for your modem from the manufacturer.

    5. Clear your temporary internet files.

    6. Download and update then do a scan with SpyBot, anything checked in red is spyware and safe to remove.

    7. Make sure you do the faster web page tweak in my Help & Tips link.


    Also read the 56K tweaks link in my signature, there are a few other tweaks there.



  4. #4
    Tojo
    Guest
    Thanks!
    I tihnk that helped a bit, but as you said in the tweaking thread and I've read elsewhere it's probably a lot to do with my line. I'm in a rural area and one some older lines.

    anyways thanks again!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •