I had the same problem - my solution was very wierd.
I had my "disable SPI firewall" CHECKED, and once I unchecked it - so that the firewall was on - it actually started working. I know it sounds...