View Full Version : bios update for asus a7m266

05-23-02, 06:25 PM
I recently put together a computer for my girlfriend and everything seems to be working fine except for a few problems. I'm using the amd xp 1700 with the asus a7m266 motherboard. The asus site says the motherboard supports the xp cpu but only with bios 1006 and higher. The motherboard shipped with bios 1005 so the computer has been running at 1100 Mhz because when the cpu speed is set to 1466 Mhz the comp won't go past the post. I've tried downloading the bios update from the asus site but it fails saying the server sent back extended information. Not sure what that means. If anyone has a good link to the bios 1007 update for the a7m266 I'd appreciate it. Also, the computer locks up intermitantly, once or twice a day. Could this be caused by running the cpu at a slower speed? Thanks for any help.

05-23-02, 11:15 PM
Strange....I would think that particular mobo would support up to ummm...at least a 2100. Sounds like your still working on the 100 fsb.

First thing if you don't already know how is to go here (http://usa.asus.com/inside/flash_mb.htm) and print this page off so you'll have it.

You'll need the AFlash utility. (http://cgi.asus.com.tw/cgi-bin/dl.asp?filename=mb/flash/aflash.exe) Also a floppy.

Now on to your mobo......What's the exact board? A7M266-D?

If so,
here's a link to the driver. (http://cgi.asus.com.tw/cgi-bin/dl.asp?filename=mb/socka/760mpx/a7m266-d/1006a7md.zip)

Also, before you start, drop into the bios and write down every setting .

I'm assuming that your not familur with flashing your bios. If you are, then keep in mind, that I'm only trying to help. :)

05-23-02, 11:49 PM
downhill, yes the system is running with a 100 fsb right now which puts it at 1100 Mhz. When I set the fsb at 133 in the bios setup, it shows the cpu speed at 1466 Mhz, which it should be for the xp 1700, but when the system reboots at the new speed it freezes at the post screen. Right now the only way to get the system to run is to leave the fsb at 100. I've also tried moving the jumper on the mb and manually put in the fsb with the same results. The mb is just the a7m266, not the D model which supports dual processors. I found the link for the bios at the asus site but like I said I keep getting an error message when I try to download it. I have updated bios before(not that often)so I know to be careful but it makes it a little difficult when I can't even get the bios update. Is anyone else having trouble downloading from asus? Thanks again for the help.

05-24-02, 09:49 AM
Do you have an older Athlon chip (non XP) you could boot up with and then flash the bios? Then replace the old chip with the new chip. I'm thinking having the XP in there without the updated bios may be causing some problems.

Also, check out www.amdmb.com. They have mobo specific forums there that might help you out.

05-24-02, 10:41 AM
maroon, thanks for the link! That is a great site for amb mbs! It took me about one minute in their forums to figure out what the problem might be. The s2k slew rate was set to 0 in the bios. Once I set it to 1 the system boots up fine with a fsb of 133 running at 1466. Not sure if this fixed the occational lockup problem but I'll keep an eye on it. Thanks for the help guys. Later.

05-24-02, 01:50 PM
The A7M66 CAN work with an XP with the new BIOS.. but it's not the board you would want to run an XP on. My opinion.