PDA

View Full Version : Tweaking cable modem with cablenut software



bstreyle
03-11-01, 07:08 PM
Hi, This is my first posting, but I have been looking over the messages posted here. I have a cable modem with @home.com, and this is connected to a Netgeat RT314 router. When I first got cable, my speeds were preety good, but lately they are poor. My speeds during the morning and early afternoon are good with speeds around 300-800 kbps depending on what site I test at from www.toast.net. (http://www.toast.net.) I also use DSLreports.com, and find those test speeds are generally lower than the others. I have downloaded the cablenut 4.0, have not used it yet and I downloaded the vTCP patch for windows98 (file name 236926USA8) and have not installed it. I seen where alot of people have posted their setting from the test sites, so here are mine:

DLSreports tweak test results:

* Please wait up to 30 seconds.. collecting data
* Your RWIN reads as 65535
* All tests passed perfectly.
* We recommend you leave everything as it is!
* End

Here are the results from speedguide.net:

P properties for IP = 24.23.107.186
Note: Read the FAQ if the above is not your IP address.

TCP options string = 020405b401010402
MTU = 1500
MTU is fully optimized for broadband.
MSS = 1460
Maximum useful data in each packet = 1460, which is equal to MSS.
Default Receive Window (RWIN) = 65535
RWIN Scaling (RFC1323) = 0 bits
Unscaled Receive Window = 65535
Note: Under Windows 9x, if you have RWIN set to any other value, and the Analyzer reports 65535 you
might need to install the MS Vtcp386 fix.
For optimum performance, consider changing RWIN to a multiple of MSS.
Other values for RWIN that might work well with your current MTU/MSS:
513920 (MSS x 44 * scale factor of 8)
256960 (MSS x 44 * scale factor of 4)
128480 (MSS x 44 * scale factor of 2)
64240 (MSS x 44)
bandwidth * delay product:
Your RcvWindow limits you to: 2621.4 kbps (327.675 KBytes/s) @ 200ms
Your RcvWindow limits you to: 1048.56 kbps (131.07 KBytes/s) @ 500ms
MTU Discovery (RFC1191) = ON
Time to live left = 117 hops
TTL value is ok.
Note: Since TTL is decreased by at least 1 with each hop, the value above is equal to your TTL minus
the number of hops to forums.speedguide.net
Timestamps (RFC1323) = OFF
Selective Acknowledgements (RFC2018) = ON
IP type of service field (RFC1349)= 00000000
Precedence (priority) = 000 (routine)
Delay = 0 (normal delay)
Throughput = 0 (normal throughput)
Reliability = 0 (normal reliability)
Cost = 0 (normal cost)


7026 connections tested since 03-10-2001, 14:30 ET

Program version: Beta 0.92


Ok, Where do I go from here? Thanks for any help you can give.

Lobo
03-11-01, 07:12 PM
There are two patchs on patch page for vtcp386 Fix, if you are running WIN 98 or SE you need one with big V, Vtcp386 Fix, retest after installation, reboot, post back here :)

tekelberry
03-11-01, 07:14 PM
Since you exposed your IP address to the whole world I did a tracert for you. It seems like the problem lies with @Home. It is not your fault that you have bad cable service, it is @homes fault.
Those dirty bastards!

Lobo
03-11-01, 07:18 PM
The problem sir is you do not have that patch in :) An yes x out your IP in future posts

bstreyle
03-11-01, 07:29 PM
I,m back and I installed the patch and my results are now (without my IP address)

Dslreports:

Please wait up to 30 seconds.. collecting data
* Your RWIN reads as 65535
* All tests passed perfectly.
* We recommend you leave everything as it is!
* End

Results from Speedguide.net:

SpeedGuide.net TCP/IP Analyzer



TCP options string = 020405b4010303000101080a000000000000000001010402
MTU = 1500
MTU is fully optimized for broadband.
MSS = 1460
Maximum useful data in each packet = 1448, which is less than MSS because of Timestamps, or other
TCP/IP options used.
Default Receive Window (RWIN) = 65535
RWIN Scaling (RFC1323) = 0 bits
Unscaled Receive Window = 65535
Note: Under Windows 9x, if you have RWIN set to any other value, and the Analyzer reports 65535 you
might need to install the MS Vtcp386 fix.
For optimum performance, consider changing RWIN to a multiple of MSS.
Other values for RWIN that might work well with your current MTU/MSS:
513920 (MSS x 44 * scale factor of 8)
256960 (MSS x 44 * scale factor of 4)
128480 (MSS x 44 * scale factor of 2)
64240 (MSS x 44)
bandwidth * delay product:
Your RcvWindow limits you to: 2621.4 kbps (327.675 KBytes/s) @ 200ms
Your RcvWindow limits you to: 1048.56 kbps (131.07 KBytes/s) @ 500ms
MTU Discovery (RFC1191) = ON
Time to live left = 117 hops
TTL value is ok.
Note: Since TTL is decreased by at least 1 with each hop, the value above is equal to your TTL minus
the number of hops to forums.speedguide.net
Timestamps (RFC1323) = ON
Note: Timestamps add 12 bytes to the TCP header of each packet, reducing the space available for
useful data.
Selective Acknowledgements (RFC2018) = ON
IP type of service field (RFC1349)= 00000000
Precedence (priority) = 000 (routine)
Delay = 0 (normal delay)
Throughput = 0 (normal throughput)
Reliability = 0 (normal reliability)
Cost = 0 (normal cost)


7115 connections tested since 03-10-2001, 14:30 ET

Where do I go from here or am I good to go?

Thanks for the quick replies!

cablenut
03-11-01, 07:30 PM
A good RWIN value for you would be 64240 with Tcp1323Opts set to "0"

Lobo
03-11-01, 07:32 PM
The patch is not in, try rebooting and retesting untill your RWIN # is higher than 65535 :)

bstreyle
03-11-01, 08:09 PM
I did install the patch and did reboot. I got the patch from:
http://www.speedguide.net/Cable_modems/cable_patches.shtml and dowmloaded the file MS Vycp.386 fix for Windows 98

I redid the test at DSLreports and got:
* Please wait up to 30 seconds.. collecting data
* Your RWIN reads as 65535
* All tests passed perfectly.
* We recommend you leave everything as it is!
* End
and the reading from speedguide is:
TCP options string = 020405b4010303000101080a000000000000000001010402
MTU = 1500
MTU is fully optimized for broadband.
MSS = 1460
Maximum useful data in each packet = 1448, which is less than MSS because of Timestamps, or other
TCP/IP options used.
Default Receive Window (RWIN) = 65535
RWIN Scaling (RFC1323) = 0 bits
Unscaled Receive Window = 65535
Note: Under Windows 9x, if you have RWIN set to any other value, and the Analyzer reports 65535 you
might need to install the MS Vtcp386 fix.
For optimum performance, consider changing RWIN to a multiple of MSS.
Other values for RWIN that might work well with your current MTU/MSS:
513920 (MSS x 44 * scale factor of 8)
256960 (MSS x 44 * scale factor of 4)
128480 (MSS x 44 * scale factor of 2)
64240 (MSS x 44)
bandwidth * delay product:
Your RcvWindow limits you to: 2621.4 kbps (327.675 KBytes/s) @ 200ms
Your RcvWindow limits you to: 1048.56 kbps (131.07 KBytes/s) @ 500ms
MTU Discovery (RFC1191) = ON
Time to live left = 117 hops
TTL value is ok.
Note: Since TTL is decreased by at least 1 with each hop, the value above is equal to your TTL minus
the number of hops to forums.speedguide.net
Timestamps (RFC1323) = ON
Note: Timestamps add 12 bytes to the TCP header of each packet, reducing the space available for
useful data.
Selective Acknowledgements (RFC2018) = ON
IP type of service field (RFC1349)= 00000000
Precedence (priority) = 000 (routine)
Delay = 0 (normal delay)
Throughput = 0 (normal throughput)
Reliability = 0 (normal reliability)
Cost = 0 (normal cost)


7262 connections tested since 03-10-2001, 14:30 ET

Analyzer version: Beta 0.93

What could be wrong? The patch did install and it told me to reboot, which I did!!!

Lobo
03-11-01, 08:11 PM
Are you on host pooter

bstreyle
03-11-01, 08:12 PM
What is a host pooter?

Lobo
03-11-01, 08:14 PM
Your not home networked are you, do you have a speed patch in, who's, and what size is your CPU :eek:

bstreyle
03-11-01, 08:20 PM
Yes, I am on a home network using a netgear RT314 router. It's just my computer and my daughter's laptop. I have a 700mz pentium 3 with 192 MB of RAM.

bstreyle
03-11-01, 08:22 PM
P.S. I'm not running any speed software. I was looking for one when I came upon this site (cablenut).

Lobo
03-11-01, 08:29 PM
OK, I think I know what the problem is, you have not put any values in cablenuts software
do this:

Then on desktop click on cablenut 4.0
Click on ccs files
then click on cable
Select either normal cable or fast cable (See instructions)
this will enter settings
click on save to registry at bottem, reboot or it will not work.
:p

Lobo
03-11-01, 08:33 PM
Fast cable 9x settings for you :eek:

bstreyle
03-11-01, 08:49 PM
Back again! Installed cablenut 4.0, went to the CCS files and went to cable and clicked on fast Cable 9X and saved the registry. Rebooted and here are the new results:

DSLreports:

* Please wait up to 30 seconds.. collecting data
* Your RWIN reads as 31168
* All tests passed perfectly.
* We recommend you leave everything as it is!
* End


Speedguide:

TCP options string = 020405b40103030201010402
MTU = 1500
MTU is fully optimized for broadband.
MSS = 1460
Maximum useful data in each packet = 1460, which is equal to MSS.
Default Receive Window (RWIN) = 204400
RWIN Scaling (RFC1323) = 2 bits
Unscaled Receive Window = 51100
RWIN is a multiple of MSS
Other values for RWIN that might work well with your current MTU/MSS:
513920 (MSS x 44 * scale factor of 8)
256960 (MSS x 44 * scale factor of 4)
128480 (MSS x 44 * scale factor of 2)
64240 (MSS x 44)
bandwidth * delay product:
Your RcvWindow limits you to: 8176 kbps (1022 KBytes/s) @ 200ms
Your RcvWindow limits you to: 3270.4 kbps (408.8 KBytes/s) @ 500ms
MTU Discovery (RFC1191) = ON
Time to live left = 53 hops
TTL value is ok.
Note: Since TTL is decreased by at least 1 with each hop, the value above is equal to your TTL minus
the number of hops to forums.speedguide.net
Timestamps (RFC1323) = OFF
Selective Acknowledgements (RFC2018) = ON
IP type of service field (RFC1349)= 00000000
Precedence (priority) = 000 (routine)
Delay = 0 (normal delay)
Throughput = 0 (normal throughput)
Reliability = 0 (normal reliability)
Cost = 0 (normal cost)


7418 connections tested since 03-10-2001, 14:30 ET

Analyzer version: Beta 0.93

How do my setting look now?

Lobo
03-11-01, 08:55 PM
OK, it's in, good job, now Host computer-you
client is laptop. same software must be on both puters, in other words you have to put 4.0 on laptop, but you do not have to use fast settings if CPU is to small, questions :)

bstreyle
03-11-01, 08:59 PM
Lobo, Thanks for all the help!!!! I'll be curious how thing look now for speed.

Bruce

cablenut
03-11-01, 09:00 PM
Your settings look optimal hope you enjoy them :)

Lobo
03-11-01, 09:02 PM
Morning best time for speed, download and install our faster loading of web pages patch from patch page, unzip and go where you unzipped it to and click on it, reboot.
How do do speed test
1. The best time is early in the morning (3 AM - 6 AM)
2. Make sure defrag has been run so no files are fragmented
3. Delete Temp internet files, not while testing, but after each test. IE browser, click tools, internet options, click on delete files and no this will not harm system, just get rid of temp files
4. Go to a fast server such as www.happypuppy.com (http://www.happypuppy.com) and click on 10 demos, select a LARGE file to download (not all of it of download, just most of it, before you click cancel) this will show you how fast you are downloading, it's not going to be quick except except early in morning when not many people on net. I recommend you go to www.analogX.com (http://www.analogX.com) and download Net State live, run this while downloading as it will give you avg of your download speed.
5. Probably the most important, nothing can be running during test, no firewalls, no virus stuff, no ICQ, no AIM (some of you may have to go into BIOS to disable virus scanner, nothing running except Net Stat live
Scheduled tasks will run disk defrag, 98 & SE in Taskbar, WIN ME in control panel


Or if you wish you may go to www.testmyspeed.com (http://www.testmyspeed.com) and do one of the online tests, these vary to much for me but you may like them. Another one is at www.dslreports.com/tools (http://www.dslreports.com/tools) :)