PDA

View Full Version : Try this one Lobo



Lobo
03-11-01, 04:56 PM
Sir, the first thing is if you have your pooters hooked up as server and client you must have same tweaks on each pooter.
The first comper readings look good, the second, not so good, (In future when posting test results x out your IP address. Do the following for 2nd pooter, reboot, retest, post back here:
Please go to this http://www.dslreports.com/front/drtcp.htmlRL
Download DR. TCP to your desktop
Where it saids adapter settings, select your adapter
Where it says Windows sclaing- yes
Where it says Selective Acks-yes
Path MTU Discovery - yes
Black Hole Detection - No
TTL-64 or 32 (up to you)

Where it says Time Stamping, select No or yes, up to you
The choices I give above will not affect speed
Reboot for changes to take affect

Do not change any numbers in this box unless you know what you are doing.
A blank box only means that the default setting is being used :)

Lobo
03-11-01, 05:15 PM
Also I forgot to tell you Cablenut has a newer patch out 4.0. You do not need 4.02 as it just makes 4.0 work on WIN 95 & ME. This is better patch and if you download it, it will take registry back to default first before appling new settings so you have nothing to do, use fast cable settings 9x on both your pooters :)

Paklet2
03-11-01, 06:12 PM
Thanks for the info. I did everyting as you suggested. Dr.TCP & and new CableNut patch. However...

From PCpitstop:

Bandwidth Down 1843 Kbits/sec
Bandwidth Up 126 Kbits/sec
Average Ping 82 ms
Ping Loss 0%
TCP Receive Window 522680

From Speedguide:

TCP options string = 020405b4
MTU = 1500
MTU is fully optimized for broadband.
MSS = 1460
Maximum useful data in each packet = 1460, which is equal to MSS.

Default Receive Window (RWIN) = 49152
RWIN Scaling (RFC1323) = 0 bits
Unscaled Receive Window = 49152
bandwidth * delay product:
Your RcvWindow limits you to: 1966.08 kbps (245.76 KBytes/s) @ 200ms
Your RcvWindow limits you to: 786.432 kbps (98.304 KBytes/s) @ 500ms

Lobo
03-11-01, 06:42 PM
Is this from one pooter what patch is in :)

Lobo
03-11-01, 06:52 PM
You do not have 4.0 installed right, after this, retest and post back here, do this:

Then on desktop click on cablenut 4.0
Click on ccs files
then click on cable
Select fast cable (See instructions)
this will enter settings
click on save to registry at bottem, reboot or it will not work. :)

Lobo
03-11-01, 06:58 PM
Don't do the pitstop one as there is no speed at night only speedguide's tweak tester :)

Paklet2
03-11-01, 09:42 PM
Computer # 1 : patchVtcp.386 fix for Windows 98 SE, patch Cablenut3.65, & Speedguide web patch.

TCP options string = 020405b40103030301010402
MTU = 1500 MTU is fully optimized for broadband.
MSS = 1460Maximum useful data in each packet = 1460, which is equal to MSS.
Default Receive Window (RWIN) = 522680 RWIN Scaling (RFC1323) = 3 bits Unscaled Receive Window = 65335 RWIN is a multiple of MSSOther values for RWIN that might work well with your current MTU/MSS: 513920 (MSS x 44 * scale factor of 8)256960 (MSS x 44 * scale factor of 4)128480 (MSS x 44 * scale factor of 2) 64240 (MSS x 44)
bandwidth * delay product:Your RcvWindow limits you to: 20907.2 kbps (2613.4 KBytes/s) @ 200msYour RcvWindow limits you to: 8362.88 kbps (1045.36 KBytes/s) @ 500ms
MTU Discovery (RFC1191) = ON
Time to live left = 119 hopsTTL value is ok.Note: Since TTL is decreased by at least 1 with each hop, the value above is equal to your TTL minus the number of hops to forums.speedguide.net
Timestamps (RFC1323) = OFF
Selective Acknowledgements (RFC2018) = ON

Computer # 2 patchVtcp.386 fix for Windows 98 SE, patch Cablenut3.65, & Speedguide web patch, cablenut 4

TCP options string = 020405b4
MTU = 1500 MTU is fully optimized for broadband.
MSS = 1460Maximum useful data in each packet = 1460, which is equal to MSS.
Default Receive Window (RWIN) = 49152 RWIN Scaling (RFC1323) = 0 bits Unscaled Receive Window = 49152 For optimum performance, consider changing RWIN to a multiple of MSS.Other values for RWIN that might work well with your current MTU/MSS: 513920 (MSS x 44 * scale factor of 8)256960 (MSS x 44 * scale factor of 4)128480 (MSS x 44 * scale factor of 2) 64240 (MSS x 44)
bandwidth * delay product:Your RcvWindow limits you to: 1966.08 kbps (245.76 KBytes/s) @ 200msYour RcvWindow limits you to: 786.432 kbps (98.304 KBytes/s) @ 500ms
MTU Discovery (RFC1191) = OFF
Time to live left = 52 hopsTTL value is ok.Note: Since TTL is decreased by at least 1 with each hop, the value above is equal to your TTL minus the number of hops to forums.speedguide.net
Timestamps (RFC1323) = OFF
Selective Acknowledgements (RFC2018) = OFF
IP type of service field (RFC1349)= 00000000Precedence (priority) = 000 (routine)Delay = 0 (normal delay)Throughput = 0 (normal throughput)Reliability = 0 (normal reliability)Cost = 0 (normal cost)

SirÖObviously I donít have Cablenut 4 installed correctly. I believe I did everything as you indicated but I canít seem to get the RWIN to change. Found the CCS folder, found the fast cable, saved setting, rebooted and what you see above is what I got. Not that what I have isnít acceptableÖ it is. Itís the principle of the thing. Thanks for all your help, especially when your instructions are correct, but the user is failing to follow them correctly.
:) :( :rolleyes:

Lobo
03-11-01, 10:40 PM
Sir, you have to have same software on both puter, 4.0 on both, not 3.65 on one and 4.0 on other, and no do the ccs thing again, and click on save to registry at bottom, then reboot :)

rmrucker
03-11-01, 11:43 PM
PC Pitstop is NOT able to correctly report the Receive Window. They take the DefaultRcvWindow entry out of your registry and echo it back at you. This is NOT the same as actually determining this by looking at the packets. SpeedGuide's TCP Analyzer is the ONLY tool on the Internet that can do this.

It appears your computer #2 is possibly going through a proxy?? See this thread -- especially the last page or so: http://forums.speedguide.net/cgi-bin/ultimatebb.cgi?ubb=get_topic&f=14&t=000081

Your Computer #2 is looking quite similar to Big's set up...

Paklet2
03-11-01, 11:57 PM
Lobo,

It looks like my RWIN is good from Pcpitstop but not good when I check with speedguide. Color me confused. Any suggestions?

Paklet2
03-12-01, 03:56 PM
:D :) LoboÖ Ė rmrucker nailed it on the head. I went to tools>options>connections>LAN turned off the two automatic settings and here are the new results I got

:D :D :D :D

Paklet2
03-12-01, 04:05 PM
Let me say it one more time:

Thank you guys!!!! Things are cooking now!!!

Send me a bill.... I'll pay it! :D

Lobo
03-12-01, 05:21 PM
Yes but unless you do this @home will (every time you reboot check those boxes back, do this:
To get rid of @home proxy server do this
Start, Run, and type: regsvr32 -u ahiehelp.dll
This will disable proxy server.
In control panel, internet options, connecions, LAN settings,
take check mark out of ALL boxes (yes auto detect too)
:)

Paklet2
03-12-01, 05:29 PM
Did it already and it holds after reboot. Thanks again Lobo.

Storm90
03-12-01, 10:11 PM
Lobo What do you think of this? Just wondering! Let me know. I am running great and have great pings.
SpeedGuide.net TCP/IP Analyzer
TCP properties for IP =
Note: Read the FAQ if the above is not your IP address.

TCP options string = 020405b40103030201010402

MTU = 1500
MTU is fully optimized for broadband.

MSS = 1460
Maximum useful data in each packet = 1460, which is equal to MSS.

Default Receive Window (RWIN) = 256960
RWIN Scaling (RFC1323) = 2 bits
Unscaled Receive Window = 64240
RWIN is a multiple of MSS
Other values for RWIN that might work well with your current MTU/MSS:
513920 (MSS x 44 * scale factor of 8)
256960 (MSS x 44 * scale factor of 4)
128480 (MSS x 44 * scale factor of 2)
64240 (MSS x 44)

bandwidth * delay product:
Your RcvWindow limits you to: 10278.4 kbps (1284.8 KBytes/s) @ 200ms
Your RcvWindow limits you to: 4111.36 kbps (513.92 KBytes/s) @ 500ms

MTU Discovery (RFC1191) = ON

Time to live left = 50 hops
TTL value is ok.

Timestamps (RFC1323) = OFF

Selective Acknowledgements (RFC2018) = ON

IP type of service field (RFC1349)= 00000000


11434 connections tested since 03-10-2001, 14:30 ET
Analyzer version: Beta 0.93

;) I get better speeds then what the wrin suggest.

[ 03-12-2001: Message edited by: Storm90 ]

* Your RWIN reads as 241408 (scaling is on)
* All tests passed perfectly.
* We recommend you leave everything as it is!
Detail..
TCPopts hex string is 020405b40103030201010402
Max Segment Size is 1460
Your MTU is set ok
Window Scaling 2 bits (RFC1323)
SACK Permitted (RFC2018)
Ping stability 38 41 39 37 38 38 39 40 38 39
Your TTL is 61
Quick packet-loss tested ok
Scaled DefaultRcvWindow (RWIN) is 241408
Your RWIN limits you @38.7ms to 49903kbps
Your RWIN limits you @200ms to 9656kbps
Your RWIN is advertised as 241408 (scaling is on)
(Beyond 65k, advertised RWIN is scaled)
Your Path MTU Discovery is ON
TOS flag 0 on data packets
Max packet from you 1500 bytes
* End
I also wanted you to see what I meant about my pings. Two months ago they were at 120. With a few tweaks of my own. They are much better.

[ 03-12-2001: Message edited by: Storm90 ]

Storm90
03-12-01, 10:46 PM
Plus I wanted to add the tester I use off line for my Rwin gives higher settings for kbps Then speedguide. There closer to dls tweak test. So I go by them. But the rest of the report is great! ;) If I take my Rwin higher I loose speed. If I take it lower the same thing happens. I notice to just about every ones gives about the same report on the rwins. Check and see what I mean. :confused: That is if their tweaks are set up right for their system.
:confused:

[ 03-13-2001: Message edited by: Storm90 ]

Lobo
03-12-01, 11:45 PM
All yours looks great, Mine like the big juicy RWIN's for some odd reson, I don't have much time to play with it anymore, but yours looks super :) :) :) :) :) :)

Storm90
03-13-01, 12:31 AM
Email me tomorrow ok. I will send you something that will help Ok!