PDA

View Full Version : parameter problem



betajib
08-11-20, 03:43 PM
Good afternoon, there was a problem, I change RSS, RSC, Windows auto tuning, and everything changes fine, but after restarting the computer, everything is restored back. I have Windows 10 2004 latest updates, and the latest drivers, I used TCP optemizer, but I also tried the command line and powershell with administrator rights through the command line, but after rebooting everything returns, help to solve this problem

Philip
08-11-20, 06:31 PM
How did you check to see that everything returned to the default?

Some of the settings are not read when the Optimizer starts (they may be network adapter-specific, or the default may be the same as the optimal value, etc.)

betajib
08-11-20, 11:56 PM
i look in cmd netsh interface tcp show global, This is the first time for me, most of the commands do not change, for example, I disable RSS RSC, after reboot they are enabled again, Restoring the system did not help

Philip
08-12-20, 09:26 AM
You may want to try to read them using PowerShell cmdlets, as netsh is being phased out and it doesn't show all the current values correctly for all parameters.

To get the RSS/RSC/LSO in Powershell try: Get-NetAdapterChecksumOffload
Some of the other settings show with: Get-NetTCPSetting -SettingName "Internet"

To disable RSS you can do: Disable-NetAdapterRss -Name * (use this to disables RSS for all adapters). The TCP Optimizer works in a very similar way, it shows the commands at the "Apply" screen. There are some more details in the tweaking article here: https://www.speedguide.net/articles/windows-8-10-2012-server-tcpip-tweaks-5077

betajib
08-12-20, 01:02 PM
my friend, I checked the settings through powershell and cmd, when I change the values, I immediately recheck and the values ​​change, but only until I restart the computer, after the restart I recheck and the value goes back up, I have a lot of experience in setting up the network, but here I am faced a paradox

Philip
08-13-20, 07:26 AM
There could be something with the Network Adapter driver, or third party network software modifying it.

I just tested disabling RSS with my built-in adapter under Windows 10 Pro, version 2004 and it works as intended, the setting survives reboots.

1394

betajib
08-13-20, 08:25 AM
I believe it also worked for me before reinstallation, but after reinstallation, trouble happened, as you see you don't want to work, and I don't know the reason