PDA

View Full Version : TCP optimizer suddenly wont change settings?



klepp0906
07-04-18, 01:39 PM
Im at wits end and out of ideas regarding what I can do to troubleshoot this. Its now above my pay-grade :P

If i set tcp optimizer to current, optimized, restore from back up. .. doesnt matter - the settings dont change.

If i go look at my network adapter, LSO, offloading etc all still enabled after restart.

I double checked assuming it was purely a visual bug (even though that would still drive me nuts) but it wasnt. Get-NetAdapterLso still shows LSO as enabled.

If i run current vs optimal in tcp optimizer the summary shows the settings being changed, but they arent being applied in windows/device manager for whatever reason.

If i change them in device manager - all is fine.

What/where is my hang up?

klepp0906
07-04-18, 02:00 PM
oddly enough this is happening on another one of my pcs. now i begin to wonder. software bug? due to a recent windows update?

klepp0906
07-04-18, 02:30 PM
upon further "preliminary" inspection - it seems that it largely applies to LSO alone.

2 pc's, 2 different NICs, and i also could have SWORE it changed fine before. It makes me wonder what else isnt changing.

That being said, I run tcp optimizer, it calls for LSO off, it stays on. If i run powershell and manually change it off. it goes off, and toggles off in device manager.

Is the command incorrect in TCP Optimizer perhaps? I cant tell spacing, font seems a lil wonky. almost seems like an extra space is between - and name? Shouldnt have a space afaik ya?

klepp0906
07-04-18, 02:33 PM
yep, look at the next command down (forget as i dont have it open now, i spent WAAAy too much time on this).

similar command, no space after the hyphen and my hypothesis would be that one is applying corrently.

Means a hotfix release is in order over a typo :P

st1cky
07-06-18, 11:38 PM
Yes you are right, something messed up in TCP Optimizer Code.

I think he will fix it soon.

But there is no differences on/off.

LSOv2 got optimized with the latested drivers.

Philip
07-11-18, 01:45 AM
TCPOptimizer was updated to correct that typo, thanks for letting us know.