View Full Version : Network card not being seen?

04-24-17, 08:05 AM
When I first boot up, I do not get an network connection. My network icon has a little red crossed out circle over it. If I check the device it says there is no device.

When I boot up the second time, it sees it and everything works as expected. This is no occasional, this is every time. I can't think of anything that I've changed that would have caused this problem.

04-24-17, 10:16 AM
Is it a motherboard built-in NIC or a separate card ?
I would do the following:

1) Find the exact chip/model of the NIC, and download proper drivers from the manufacturer or PC vendor (may be needed for next step, if you don't have connectivity!!)
2) Go do "Device Manager" and uninstall the drivers for the network card. Reboot.

The NIC should be found, drivers should be installed. You may want to switch to the manufacturers/vendors' drivers.

If that doesn't do it, could be something not getting initialized properly in the BIOS on cold boot ? Try disabling "Fast boot" or similar options that skip hardware checking and see if that makes a difference.

I hope this helps

05-03-17, 10:57 PM

Thanks for the advice. I had tried the Original mobo drivers but they were very old and I didn't want to risk it. Asus does not have any updated drivers on their site for the onboard ethernet either. I actually think it may be that the mobo is dying. I noticed when trying to boot into the Bios and Safe mode that my keyboard light did not come on until Win was almost loaded. The keyboard was not functional during the boot process.

05-04-17, 10:13 AM
There are different boot modes that may be configured in the BIOS that determine when the USB comes on. "Fast boot" usually means BIOS releases the boot before many peripherals are initialized (mostly USB, com ports, etc.) and they come on with the OS, but are not available prior. This may also prevent booting from USB drives.

05-04-17, 05:32 PM
Its a long shot but do a memory test. I had a bad stick **** with me a while back that made my network card not work sometimes, other times it would affect something else, depending on what loaded first.

05-04-17, 08:53 PM
Phil and Yard,

Thanks for the suggestions. For starters, nothing had changed or been updated when this started to happen. There is nothing to relate it to. I did think about the Memory sticks being bad and that one is on the list. I've tried setting the bios back to factory settings and to different profiles but it still persists. I did put in a new PSU about 6 months before this started and I'm going to swap that with a known good one just to see if that might be it. Possibly one of the rails is failing? I don't really think so since everything else is rock solid.

I'm going back into the bios to see what I can see.

05-23-17, 01:24 PM
Still can't find the reason. I'm thinking of doing a new Win 10 reinstall and see if that fixes it.

05-26-17, 07:20 AM
When you cold-boot, and the network adapter shows with a red cross, as if there is no connection... Does disabling/enabling the network adapter have any effect (Control Panel\Network and Internet\Network Connections\right-click on the adapter, disable/enable).

If it fixes it, probably some software/driver incompatibility, or may be trying to initialize too early.. It may also be going bad. Is there a second network port you can try by any chance ? (some mobos have dual nic ports)

Is it a cold boot, vs. restart ? e.g. if you cold-boot it doesn't work, if you reboot it works ?

05-31-17, 07:50 AM

Thanks for all the help and concern. I have tried the disable/enable trick you mentioned above. I have even removed it from the device manager and reinstalled. My mobo only has 1 network port. Always the same thing, on an initial cold boot I do not get any network connectivity. Then during a "restart" every thing connects. I've gone through the BIOS and have not been able to resolve it there either

I also seem to be having some other smaller problems that makes me think it's the Mobo. It's probably about time I upgrade anyway. I've been wanting to move over to an SSD setup with mechanical backup so I guess I may start shopping new Mobo and CPU.

06-04-17, 08:21 PM
The Strangest thing.
Turning on my computer is a 2 step process, first the CPU and then the Monitor. The other day I turned on the CPU but forgot to turn on the monitor. When I finally did, I had network connectivity. I shut down the computer and tried it again turning on the monitor last and bingo, everything was working like it should. So I turned the whole thing off. Then I turned on the monitor and then the CPU and... no network connectivity. I had to restart to get the connectivity. I tried it once again with the monitor off while the machine booted and... bingo, i have connectivity. I have no freaking idea why it would even be susceptible to the monitor being turned on.

06-05-17, 08:47 AM
I can think of two possibilities...

1. Power issue - if you have too many devices drawing power at exactly the same time (the power draw peaks when turning them on), there may be a subtle drop at that time that affects certain peripherals/circuits. This can manifest itself only with some PSUs too. You can try moving the monitor power to a different outlet (preferably on a different breaker, but that may be difficult), or/and you can reduce the number of devices connected to the same outlet in general to test that theory.

2. EMI/poor shielding - many computers/peripherals have very poor shielding and are very prone to electro-magnetic interference. This includes Cat5 cables (no shielding at all), power cables, and devices (computers, routers, speakers, fluorescent lighting, monitors, etc.). Separating them physically usually resolves the issue. I test by moving the monitor a bit away from the computer, or moving the computer itself away from other possible sources of EMI (UPS?)... Then I'd look at the network cables/switch and see if they are in close proximity to other possible sources of EMI (power cables, coiled network cables, etc.).

It is unusual, thanks for sharing. Please post if you figure it out :)

12-01-17, 10:45 AM
My ongoing Saga...
I've tried everything I can possibly think of. I thought it might be the cables, I even tried an analog hookup including HDMI. At one point the blue analog cable seemed to work, but not consistently. I got the computer to boot with the little RED X over the network icon and then it would connect once in Windows. I'm going to clean out the case and reconnect all cables with some spares to see if it might be a cable problem. After that it's a new PSU and after that... new computer.

04-18-18, 11:58 AM

I found an article that stated the Windows 10 fast startup setting in the control panel power options menu may be the culprit. Once I disabled it everything when back to playing nice. I'm just thankful I didn't need to invest in a new mobo etc.

So now it looks like I can live with the build a little while longer. I guess a couple of SSDs are in my near future.

04-18-18, 06:13 PM
Interesting... Thanks for sharing.