View Full Version : Windows 8.1 - Lenovo - WiFi Limited

Qui-Gon John
11-01-15, 06:26 AM

I am working on a Lenovo Laptop. It has Broadcomm WiFi.

I did a Factory Recovery and once done, the computer had Windows 8 and the wifi worked fine. I got connected to my home router no problem.

I then upgraded this laptop to Windows 8.1, (almost immediately - once I had the needed updates in place). So no surfing, no chance of a virus, etc.

Now when it tries to connect to my home router it says LIMITED, has the small yellow shield over the wifi and will not pull up web pages.

My wifi Security Mode on my router is WPA2-PSK [AES].

Any help would be greatly appreciated.

11-01-15, 07:49 AM
The LAN drivers were likely replaced by the default Microsoft version. Download and install (from a USB stick, if necessary) the manufacturer drivers for Windows 8 instead.

Your other option is to navigate to Control Panel > Hardware and Sounds > Device Manager > Network Adapter > update driver. You can update the driver by choosing a different compatible driver from the ones on your computer.

I hope this helps.

Qui-Gon John
11-01-15, 08:13 AM
Thanks, I forced it to reload the Broadcomm drivers already on the laptop and now it works right!

11-08-15, 07:44 AM
Download the "Lenovo ThinkVantage" tools...(or...if you did an upgrade of the OS from the factory install...it's already on there).
Run the updates. It "sniffs" your system, and goes to Lenovo's site to automatically download and updates the necessary Lenovo drivers and system software on your laptop)

Donna Copeland
01-06-16, 06:08 AM
I need to know how to turn on my WiFi on my Lenovo in windows 8

01-12-16, 02:19 PM
Depends on your model... Many have a "Function" key for toggling WiFi, usually it is: Fn+F5 (hold down the Fn key and click F5). You can also disable/enable it from the list of Network Adapters: right-click on the Wi-Fi icon in the System tray > open "Network Sharing Center" > click on "Change adapter settings" > right-click on your Wireless Adapter > choose "Enable" from the menu.